Welcome to discussions

Quick Suggestions

  • guest-b9Uydy0I
    5 posts

    Having the exact same issues on PS4.

    The Cartographer got fixed at my game.


  • Ubi-Borealis
    Ubisoft Support Staff 3626 posts
    Best Answer

    Hello all!

    I'd like to reach out to you all with an update. I'm happy to announce that the issue wherein settlement NPCs couldn't be interacted with is due to be fixed in TU 1.2.1. This update will deployed 27 April, 2021 at 1 PM CEST / 8 AM ET.

    If you are still encountering issues when interacting with settlement NPCs following TU 1.2.1, please don't hesitate to update this thread so we can take a closer look. Please include a video that shows the following:
    - You have TU 1.2.1. installed. You can view this information in the opening game menu in the bottom right-hand corner.
    - The issue still occuring in-game.

    Thanks! 😊

    Official Response
  • guest-b9Uydy0I
    5 posts

    Same issue here on PS4

  • guest-b9Uydy0I
    5 posts

    I'm having the same problem on PS4.

    There are more threads with this problem. Hope it gets fixed soon..

  • Dclark5891
    5 posts

    I have the same connection issue and seeming as I have youtube running in the back ground with no problems, its on their end. But from what I've learned is no company will admit they have connection issues. It's always your internet to them.

  • MrSugarBoi
    3 posts

    Hello I was wondering if anyone can help I can’t speak to some of the people in my camp for example my longship customiser, the hunter to trade legendary animal heads, my crew master or my stable guy is there a fix for this ? Thank you in advance

  • Saulvdberg123
    1 posts

    I can't interact with wallace to turn in my animal trophies in the settlement. The interact option doesn't pop up when i want to talk to him and there are no talking dots above his head

  • MrSugarBoi
    3 posts

    Hello I need help there’s people in my camp which I am not able to talk to which are important four example my long ship customisation, my hunter so I can trade my legendary trophies for rewards, my barracks woman so I can change the people on my long ship and my stable master so I can upgrade my horse those are the ones at the moment I can’t speak to and haven’t been able to for a couple days now thank you in advance

  • smithy10GB
    Original poster 70 posts


    I have been on and off live chat for a while with ubi because I have also been having trouble connecting to their servers, they think it might be related and, apparently, passed word on to the development team.

    Unfortunately they want me to port forward to the servers so now I have the mess about with my isp to get this done, which still probably won't work.

    Let's be hones from what I have gathered talking to live chat is that instead of their QA teams looking into the issue, its our jobs to do their jobs for them, pretty shoddy to be honest.

    After 5 hours of back and forth between different live chat agents they make it out to that the connectivity issues are user error not even thinking for 1 second that their servers could be the problem. It's funny really, it's my connections fault event hough I can play any other game just fine, wonder how that works...

  • smithy10GB
    Original poster 70 posts

    @dclark5891 yeah it's a shame really, they even tried to get me to port forward after 5 hours of back and forth with multiple advisors.

    Here is the issue, in 2020 if I have to port forward, to "troubleshoot" their game. Then there is clearly a problem.

    But ubisoft are hell bent on sticking to a script that puts the customer at fault, shameful.

    Here's a tip ubisoft if you are reading, it will save you a lot of money.

    Fire your live chat advisors, and replace them with a troubleshooting document, it is literally the only thing they say. You will save stacks of cash.

  • N0va56
    3 posts

    @n0va56 this has now also extended to the tattoo guy, and the stablemaster. Even though everything is built I cannot interact with them, it is really annoying since growing the settlement was the part of the game I was looking forward to most

  • N0va56
    3 posts

    @halo3man777 I have the same thing, except I cant talk to the ship master, quartermaster, stable master, or tattoo guy. It's really frustrating

  • Tink-Tank
    31 posts

    @n0va56 Please go to the back of the bug reporting queue and pick a number.

    You number is 63124541232345231 estimated wait time is 24 years and 234 day.

    Thank you for your understanding.

    The bewbieshaft team.

  • smithy10GB
    Original poster 70 posts

    @n0va56 same here, I tagged woofer in another thread, hopefully I get a response.

  • smithy10GB
    Original poster 70 posts

    @mrsugarboi unfortunately not, I have the same issue, I tagged ubiwoofer in a separate post so hopefully he gets back to me.

  • claud1o-
    50 posts


    By the way, I am getting the same server message as well, and I believe the interaction with NPCs may have stopped working either after I recruited a 3rd player raider or sm1 else recruited mine.

    This could point in the direction of a server issue on Ubisoft side

  • MnrGod
    4 posts

    I couldn’t interact with the opal shop, so I loaded a previous save. That fixed the problem there, but then I noticed I couldn’t interact with the huntress (I had a quest on hold there).
    I no longer have another save before this point now, so cant test if that could solve it.

  • Ubi-Woofer
    Ubisoft Support Staff 1061 posts

    Hey smithy10GB and everyone! I merged your posts into this singular thread to try and keep all of the discussion on this topic together. Thank you all for taking the time to post about it, and for providing the details of which NPCs are affected for you.

    I have looked into this issue, and can see that it has already been brought to our attention, though we don't have a great deal of information about it just yet. We are recommending platform-specific troubleshooting (PC / PS4 / XB1 / XSX|S / Google Stadia) and connectivity troubleshooting (PC / PS4 / XB1 / XSX|S / Google Stadia) in the first instance as we are unsure if these issues are localised, however as there are quite a few players affected, we're also wanting to gather some more information to hopefully identify the root cause.

    First, could you all please specify the level of your settlement, and whether this issue has been occurring since you upgraded the buildings, or since a later point? Can you also please let us know the current quest you are working towards, and whether you have been completing a lot of side quests or focusing mainly on main quests throughout your playthrough?

    The devs have also requested that videos of the issue be provided for their reference; if anyone could provide a short clip via YouTube or a similar site (so that we can easily share the link with those who need access) that would be very much appreciated. For players on PC and PS4, it would greatly aid us if you could also provide copies of your save files in a support case or Live Chat.

    For the second issue briefly mentioned regarding a connectivity error, please let me know if the aforementioned steps help to resolve this. I've seen an error message myself when trying to view community / my own photos on the map in the past 24 hours, so if there's a wider issue at hand I'll do my best to get that investigated as well.

    Please accept my apologies for that large message, and thank you all for your time and assistance in advance!

    Official Response
  • claud1o-
    50 posts

    First, could you all please specify the level of your settlement, and whether this issue has been occurring since you upgraded the buildings, or since a later point? Can you also please let us know the current quest you are working towards, and whether you have been completing a lot of side quests or focusing mainly on main quests throughout your playthrough?

    Hi and thanks for coming back to us.

    My settlement is lvl 5 and a half, I was able to customise raiders crew but never the ship before I no longer had the option to interact. In my settlement the barracks, shipyard, cartographer and hunter are all bugged.
    As said I believe the problem might have started either when I recruited another player raider or when I got the message that mine was recruited by another player.
    I am currently questing "Twist and Turns" and I am mixing secondary Qs with main ones (with a slight preference for main ones).

  • deadly_cabaret
    2 posts

    @ubi-woofer I'm playing on PS4 and have the same issue, I have completed The Way of the Berserker quest but I was having issues before that, it seemed to start when I spoke with Petra and helped her find Wallace. My settlement which is currently almost 5. I have tried to even romance Petra which was the only dialogue option I had available. I have tried to fast travel, travel to Norway and back, I have even tried to reload a previous save, hold a feast, and upgrade my settlement again. I should also note that my husband also plays on PS4 and has not encountered this problem. When you approach an NPC there is simply no way to interact with them. I was on my second or third pledge when the error happened and was focusing heavily on wealth and mystery locations. I will update my current case with a copy of my saved game.

  • Chaadunk
    1 posts

    I’m having the same issue, settlement level 4.5 started when I finished path of berserker, couldn’t interact with barracks shipwright I don’t have cartographer so I can’t check and can’t talk to hunter, as well as tattoo person. Reloaded the game to an earlier save where I hadn’t done the quest and seemed to work, then checked again after finishing kingmaker and tried to put in the npc you get for it and another jomsviking I recruited and the game went through the same exact glitch, I think it’s bugging out with certain people going into my barracks and bugging a lot of the settlement any help would be great!

Suggested Topics

Community Details