Welcome to discussions

Quick Suggestions

  • Wood138
    11 posts

    I have activated my key on Uplay right, you can give my key back so i can screwed someone like Ubisoft screwed me please ?
    By the way, 3 days to respond, you seem very concerned by our problem lol.
    This entire company is a joke like your answers @Ubi-Borealis , keep up the [censored] work and steal your customers.
    I m gonna post this story on tweeter and write a nice letter at UFC que choisir, here in France to inform them about your policies.


  • Ubi-Borealis
    Ubisoft Support Staff 3544 posts
    Best Answer

    Hello all!

    I'd like to reach out to you all with an update. I'm happy to announce that the issue wherein settlement NPCs couldn't be interacted with is due to be fixed in TU 1.2.1. This update will deployed 27 April, 2021 at 1 PM CEST / 8 AM ET.

    If you are still encountering issues when interacting with settlement NPCs following TU 1.2.1, please don't hesitate to update this thread so we can take a closer look. Please include a video that shows the following:
    - You have TU 1.2.1. installed. You can view this information in the opening game menu in the bottom right-hand corner.
    - The issue still occuring in-game.

    Thanks! 😊

    Official Response
  • Wood138
    11 posts

    For Information Update 1.2 of 03/16 do not fix anything on this issue.

  • MrWhiskers573
    5 posts

    This is ridiculous. I was hoping that with TU 1.2.0 it would be fixed, but it is still not working for me. It is so difficult to fix? Or there is not interest at all?

  • Wood138
    11 posts

    @MrWhiskers573
    They do not care at all.
    This issue is created since day one and it is not fixed.
    The only way is class action.
    Several thousands of players are touched here in EU.
    There's no class action here but people think to get revenge one way or another.
    This situation is totally unacceptable.
    @Ubi-Borealis We are waiting for your explanation
    You report the bug right?
    So what's going on ?

  • ryanp82
    7 posts
    This post is deleted!
  • ryanp82
    7 posts

    Today's patch had a bunch of changes and bug fixes but of course none of those were to fix the bug where the entire settlement is unresponsive. What a [censored] company.



  • SovngardeHero
    9 posts

    Im 115 hours in on ps4, completed everything, platinumed the game, and i just got this bug. Fortunately, and unfortunately, i am done with the game.

    Im just hoping this bug wont prevent me from playing Wrath of the Druids, as i am really excited to go to ancient Ireland

  • SovngardeHero
    9 posts

    Edit: I did a river raid which blocked me from speaking to npcs. I tried fast travelling away and back, as well as restarting game. Nothing worked so I saved and quit the game (this was before i knew about the bug).

    Loaded up the game to do Ostara stuff, hoping it was early enough before i did the raid that bugged my game.

    Idk what happened but now I am able to speak to the shop owner npcs and Reda again.

  • Ubi-Borealis
    Ubisoft Support Staff 3544 posts

    Hello there!

    I would like to reach out to you all with an update from the development team. They are planning to fix the issue wherein players are unable to interact with settlement NPCs in a future update! We currently are unable to provide a definite ETA for this update. Rest assured that once we have more confirmed information, it will be shared within this thread and in the News & Announcements forum.

    @Wood138 - The player support team tries their best to address any questions or concerns that have been made, and we aim to respond to players as soon as we are able to. I apologise if this takes longer than anticipated. If you'd prefer to have a live chat, you're welcome to reach out to our support team here.

    @MrWhiskers573 - As mentioned above, the development team intend to fix this issue in a future update. Once we know more about this update, we will let you know within the forums.

    @ryanp82 - I apologise for any disappointment that has been caused during this investigation. I ask you to refrain from bypassing the language filters in future, as this goes against our forum rules. Please consider this as a warning.

    @SovngardeHero - Thanks for sharing your experience with us. I actually encountered a similar issue, where upon returning from a river raid I was unable to interact with any of the settlement NPCs. I created a new save, reloaded it and I found I was able to interact with the NPCs again. I wonder if the same happened for you 🤔 I've notified the development team about this behaviour in the meantime. I'm glad to hear that you're able to interact with them again after reloading the game for the Ostara event!

    Thanks 😊

    Official Response
  • Colezinho10
    1 posts

    I am experiencing this same issue with being unable to interact with NPC and continue the main thread of missions, which is annoying having read through the forum and that Ubisoft have been aware of this basically since launch and not fixed. Having thought this issue would have been a top priority to fix in any update from the get-go you have released further updates and not corrected and now an update with a festival. You then pat yourself on the back for doing that despite the fact that any player with this long reported NPC issue still won't be able to play this addition.

    I have seen time and again the support team fob off paying customers with the same questions and a basically absolve Ubisoft of any responsible for this fundamental flaw in the game at it's most basic level. Ubisoft is responsible for the quality of the game regardless of whether it is purchased digitally or physically, and to suggest otherwise is quite frankly offensive. So people ARE going to request and expect Ubisoft to re-imburse their outlay because you have failed to produce a game fit for purpose. This attitude is going to turn many players away from buying any of your games in the future.

    For the record, I am playing on PS4 my issue began after finishing the the first 2 story arcs Lecestershire & Grantsebridgeshire (in that order) and I upgraded the village and began the mission 'In Dreams' where I collected Thistles for Valka. Whether this has any relevance at all I doubt but in my inventory I now have 2 sections under the quest items both titled 'Thistles' one has no picture and states 1 collected and the other has a picture and the 10 I have collected so far. From that point on I could not interact with Valka, I then did the first River Raid and realised that the issue had spread to every NPC in Ravensthorpe and beyond.

    I have seen the post that states you are working on a fix in a future update but cannot give a date - it's nearly 6 months after launch and the first post notifying of this issue!! It's incredible that Ubisoft takes such a blasé approach to something that is clearly affecting a wide range of players. You have shown little respect to the people who play your games, it appears as long as you have taken their money then it's job done. I've loved playing Assassin's Creed & Ghost Recon but your last 2 launches have been riddled with issues so I am seriously considering whether I bother with any future games under Ubisoft.

  • eeliich
    2 posts

    After the latest update, when playing river raids and returning to the settlement I can't talk to anyone in the buildings and also all of the quests disappear. I thought it was just a one time thing because after restarting the game everything went back to normal but then I played the river raids and it happened again.

  • fakie77
    2 posts

    Hello,

    I have the same issue when i return Ledecestrescire quest to Randvi, unable to interact with settlement NPC... I reload old backup, i do others quests and when i return Ledecestrescire quest, same bug.. don't know what to do, can't consult conquest table so i can't progress in game...

  • dsnack33
    1 posts

    I am unable to talk to Randvi to finish the Reporting on Lunden quest. I cannot talk to any npcs now. This is a game breaking bug since I cannot proceed any further with the story. I have gone to Norway and have played dice with several people and nothing works. How do I fix this or how do I get my money back for this pos game?

  • ryanp82
    7 posts

    @ubi-borealis Your warnings honestly mean nothing just like your responses in here. Fix your [censored]

  • Ubi-Borealis
    Ubisoft Support Staff 3544 posts

    Hello there!

    Thank you all for continuing to share your experiences and feedback within this thread. As I mentioned in my earlier post, the development team is planning to fix this issue in a future update. We are unable to provide a definite date for when this update will be released. Once we have a confirmed update, we will let you all know within this thread and in the News & Announcements forum, so please keep an eye out for this.

    @Colezinho10 - Thank you letting us know more about how you're unable to interact with NPCs, and for taking the time to share your feedback with us. I apologise for any disappointment that has been caused, and I am sorry to hear that you aren't happy with the support you have received. We will ask players certain questions on the development team's behalf, as this information is helpful to the investigation and to get a better understanding of how the issue is affecting players in-game.

    Please note that the player support team are also unable to share unconfirmed details from the investigations, such as details regarding fixes or providing ETAs when there are none available. As soon as this information is made available to is, we will let you all know as soon as we can. We hope to have an update for you all soon.

    @eeliich - Thanks for sharing your report about being unable to interact with settlement NPCs following a river raid. I've encountered this issue myself, and found that restarting the game would revert everything back to normal. I understand that this isn't a convenient workaround, though. Rest assured that this has been forwarded to the development team, and they are investigating this behaviour further.

    @ryanp82 - Please refrain from bypassing the word filter, as this goes against our forum rules. If you continue to do this in the future, your posts will be edited or deleted, and you may incur sanctions.

    Thanks! 🙂

    Official Response
  • Wood138
    11 posts

    OK @Ubi-Borealis
    Another post to say nothing...
    You are just thieves at ubisoft everyone in this post has seen this.
    Hope that people reading this will learn and never buy an Ubisoft game ever.
    Last time for me, not gonna pay for games that you can not finish.



  • guest-lZQu273V
    1 posts

    Hi,

    I am also experiencing this same issue; I can not interact with anybody in the settlement (despite recruiting a Jomsviking and playing Orlog). So this prevents me from starting any new quests or continuing river raids (I have done A River to Raid and The Legend of Saint George). The last quest I have been able to complete is Reporting on Grantebridgescire. My settlement is on level 4.

    Is there something I could do to be able to proceed or is just to wait for a fix? I have tried reloading previous saves.

  • PiRi.
    3 posts

    I can't progress the story because after talking to Randvi on "reporting on grantebridgescire" the game doesent start the supposed cutscene. After the report i can just run around the settlement but i can't talko to anyone(blacksmith, shopkeeper, Randvi so i can't open the alliances map...)

  • UbiExcellent
    Ubisoft Support Staff 756 posts

    Hi folks! Mirroring what my colleague Ubi-Borealis posted above, the issue with not being able to interact with settlement NPCs should be fixed in a future patch. I understand this has been an on-going issue, but I hope this news is welcomed. I also want to take this time to thank you all for adding to this thread and for ultimately helping our teams find this solution. Please stay tuned for further details about the patch release date on our News and Announcements forum.

    Official Response
  • Wood138
    11 posts

    @UbiExcellent
    Yeah since the launch the bug is going to be fixed in a future update.
    You are a liar and you know that the bug will not be fixed now that your poor and ridiculous buggy game is free on all over the internet.

Suggested Topics

Community Details

140
Online
191.4k
Users
32.1k
Topics
161.1k
Posts