Continue your odyssey

Welcome to discussion

Welcome to discussion

Quick Suggestions

Hello! These new forums are an open beta and we welcome your feedback in this section.
  • Warpsmith921
    3 posts

    Since yesterday, I'm having a slight issue when returning home from a Raid. After the loading screen (boat in the animus), it seem to go straight into the cut scene for the mission - the baker's plaint. But when leave there (chose not to select that mission). I am unable to speak with anyone else in the settlement other than Petra in the hunting house & to hire other vikings.
    Only way I've been able to sort it (I think) but save my game & then restarting the game.

    This is on the play station 4.

    Thanks

  • NChamp2014
    13 posts

    My game updated last night to 2.2 and now when I start a mission I have a black screen for about 5 to 10 seconds before I can do anything again. First time playing the game in quite some time.

  • XxADaManxX1
    2 posts

    I am not able to interact with any NPC's besides the guy with the dice game. This is causing me to not be able to progress in the game at all.

  • PiRi.
    3 posts

    This happnes every time i finish Grantebridgescire saga. After talking to Randvi i can't talk to any npc in the settlement and i can't continue to any new quest.

  • t34416l31
    10 posts

    Wow. Even your patches are buged huh? just downloaded the new update that is supposed to "fix know bugs". All of my settlement NPCs are broken. I can not speak to any of them, never mind utilize their purpose. I have played ALOT of ubisoft games, and this by far takes the cake when it comes to bugs and issues just FINISHING THE MAIN STORYLINE! Is this really the kind of quality I should expect from ubisoft from now on? Because I would like to know if that's the case so I can save 60-70 bucks and spend it on something that is actually finished when I buy it. Totally disappointed in Ubisoft

  • t34416l31
    10 posts

    @ubi-borealis this is becoming ridiculous. You really can't even introduce a patch without it causing more problems? Don't you think this kind of stuff should have been worked out PRE RELEASE? You really think it's ok to give your customers a broken game, then string them along for MONTHS telling them "yeah, we are working on it! This next one will fix it!"

  • UbiKoality
    Community Manager 440 posts

    @xxadamanxx1 Hello! I'm sorry to hear about this. Can you please try rebuilding your PS5's database? You can find the steps for that process here. It acts like a computer disk defragmenter and will not affect your save data, so it would be great to try to see if that helps get this corrected. If it doesn't, would you be able to grab some video evidence exhibiting the problem? I would be glad to get it reported!

    Official Response
  • MrWhiskers573
    5 posts

    @ubikoality Hello, I’m having exactly the same problem in PS4. It happened me after completing Lestershire quests and going to talk back to Randvi. I tried to rebuild the database, but it didn’t work, I also tried to load other games but it always gets the bug in the same moment after talking with Randvi.

  • coqueirotree
    1 posts

    I just created the barracks and I'm unable to interact with my quartermaster. This is very lame. I've found many minor bugs already, but this one is a pretty bad one.

  • UbiExcellent
    Ubisoft Support Staff 756 posts

    Hi everyone, and apologies for the delay. For those of you that are unable to interact with Settlement NPCs following the release of TU 1.1.2, please provide the following information:

    • What platform(s) are you playing on?
    • Which NPCs are not speaking with Eivor?
    • Does creating a manual save, exiting the game completely, then launching the newly created save have any impact on this issue?


    @NChamp2014 Can you send us a video link of the black screen issue you mentioned above, which lasts about 5-10 seconds upon launch please?

    Official Response
  • ElMadre1
    76 posts

    I never had this issue until yesterday. When I got back from a River Raid, I could not longer interact with anyone other than the Jomsvikings waiting to be recruited, and Petra. Today, when I loaded it up, things were back to normal. Completed another raid, same problem.

    I'm on PS4, 400 rank, settlement complete.

    I don't know if it's related, but I did have at least one of my crew members die on each of the raids.

  • Wood138
    11 posts

    @UbiExcellent
    I am on PC version.
    I am unable to talk to ANY Npc in the camp.
    I can't go to asgard and drink at Valka house.

    The bug was since i have reported to randvi after the ragnar sons story.

    I have reported to her, i have seen the cinematic with Ceowulf son whic is now at the camp.

    I have made manual save, quick save to, from cloud, fomr local and the problem is still there.

  • Fullmetallspark
    1 posts

    My game has bugged in a way that has stopped me from talking to ALL the npcs in my settlement. It happens after the first conversation with Eivor, Ceolbert and Ranvi which starts automatically when you enter the map room. I have loaded save states before this happens and every single time the conversation finishes I can no longer speak to anybody, including Randvi which means I cannot progress further in the story. I have tried uninstalling and reinstalling the game twice, once before the bug occurs and once after and the same problem persists. This has broken my game and made it completely unfinishable. I cant even access the asgard quests anymore. I've tried several things to try and get round this but nothing works. Please help or even better fix the game so I can keep playing it.

  • Wood138
    11 posts

    @t34416l31
    I think they do not care about stuck players. You have the proof .( my post has not answer)
    The game has already been sold a lot, and Ubisoft ignore all issues that are blocking players.
    This is the last game from UBISOFT i purchase.
    Ubisoft are worst than CD Project Red , at least they try to fix.

  • MrWhiskers573
    5 posts



    Here I post a video were you can see the situation when I speak to Randvi after completing Leicestershire quests. The video is in spanish but hope it shows clear enough.

  • Hadley66
    4 posts

    @ubiexcellent

    I am on PS4.

    I cannot speak with any settlement NPCs, other than the new one, Vagn.
    For example, one of my quests calls me to talk to Dag, who stands non-responsive by the longhouse.
    (There are also several NPCs just standing idly in a clearing between the brewery and the river raid dock)

    Saving and restarting has no apparent effect.

  • Ubi-Borealis
    Ubisoft Support Staff 1911 posts

    Hello all!

    Thanks for continuing to update this thread. I'm sorry to hear that some of you are still unable to interact with settlement NPCs following TU 1.1.2. If you are still affected by this, please can you let us know the following information:

    • Which NPCs are you unable to interact with?
    • When did you first notice you were unable to interact with them?
    • Can you please send us a video that shows you're unable to interact with the settlement NPCs?


    We can then pass this information along to the development team for further investigation.

    @ElMadre1, @Wood138 & @Fullmetallspark - Thank you for taking the time to share your reports. Would you be able to provide us with the additional information above? In particular, a video would be very helpful for the investigation.

    @MrWhiskers573 - Thanks for taking the time to send us a video. I've passed this report along to the development team so they can take a closer look at this.

    Thanks all! 😊

    Official Response
  • Hadley66
    4 posts

    @ubi-borealis

    1. again, I can interact with none of the settlement NPCs save the new one, Vagn.
    2. the game has been unplayable for me for months now, so when it happened is tough. The last milestone I recall was a fight with Dag, who now stands unresponsive outside the longhouse.
    3. provide instructions on how to capture and provide video, and I would be willing to do so, but I question what you hope such material will help you learn. How do you expect such a video — a player character being looked at but otherwise ignored by NPCs, even if that PC goes so far as to repeatedly bump into the NPCs — to help?
  • ryanp82
    7 posts

    Playing on the PS5 version. I completed the alliance map for Grantebridgescire and it breaks the game upon talking to Randvi when I get back to my settlement. I'm unable to interact with any of my npc's there including her. I can't choose the alliance map to advance the story or even go back to Asgard. This is a major issue for a lot of people that's been going on for almost 4 months now and there's no fix in sight. I've honestly wasted my time and money on this game.

  • Ubi-Borealis
    Ubisoft Support Staff 1911 posts

    Hello there!

    @Hadley66 - Thanks for letting me know that additional information about which NPCs you're unable to interact with, and when this first happened for you. To share a video, I would recommend recording it and then uploading it to a sharing platform (such as YouTube or Google Drive), then posting a shareable link in this thread. Depending on the platform you use, you may have different recording options available to your (Such as PS4 share or recording using the Microsoft Game Bar). You can also use your own capture devices, such as cameras or mobile phones.

    Videos are helpful to the investigation as it allows the development team to see exactly how your game has been affected, and see if this behaviour matches other reports. It's also useful if the development team has been unable to replicate this in their own testing to provide a better understanding from the player's point of view.

    @ryanp82 - Thanks for sharing your experience with being unable to interact with your settlement NPCs. I'm sorry to hear that this has halted your progression. Have you been able to try reloading an earlier save to test if this always happens when completing the Grantebridgescire alliance? Knowing that this is the trigger could be very helpful for the investigation.

    If possible, would you also be able to provide a video that shows you unable to interact with NPCs after reporting to Randvi? We can then pass this along to the development team.

    Thanks all! 😊

    Official Response

Suggested Topics

Community Details

35
Online
129.0k
Users
22.2k
Topics
115.1k
Posts