Continue your odyssey

Welcome to discussion

Quick Suggestions

Hello! These new forums are an open beta and we welcome your feedback in this section.
  • KankerDroog
    17 posts

    @harpershouse welcome to the club, we are here waiting already for 3 months for ubisoft to fix this bs, they are never gonna fix this, this game is just a waste of money.

  • GekkeGeert12
    1 posts

    I tried everything. Still can't progress my game. Could you please fix this Ubisoft. I love to play Assassin's Creed and now i'm stuck here for like 4 weeks now !👎

  • AngelInTheGame
    11 posts


    are 3 months and have not solved the glitch yet, I really have no words! how to throw away 80 euros badly spent!

  • jacobblank1115
    1 posts

    In the quest Walls and Shadows, I believe, when im investigating the temple it does not register me as having read all of the letters and therefor i cannot finish the quest or return with my findings. I have read every letter about 10 times and also looked it up just to make sure i didnt miss one.

  • martinplaska
    1 posts

    Hi, I'm having the same issue I do have some old saves but I'm on 85hours and would have to go back to 35Hours really don't want to.

    I also had the returning the queen issue resolved that by saving and reloading.

    • Case Number: 14034141


  • Drambo37
    1 posts

    Hi, are there any updates on this? I’m playing on ps5 and would love to continue but like many others on here, have been stuck as it won’t let me interact with the clues to investigate Tryggrs murder. Very frustrating

  • Bromegus15
    1 posts

    2nd massive update. Still nothing on this quest. I know Ubisoft has been “having trouble” recreating the problem but it’s been months now. Can we just get a straight answer as to why this particular issue is such a problem. I’d really like to finish this game but I’m level 400 with 80+ hours. I’m NOT starting over.

  • KankerDroog
    17 posts

    this is ridiculous.......

  • JanosKakophonis
    12 posts

    I get the feeling that this is probably something way bigger than expected and support is unable to fix it at all so they rather pretend that there is no problem. [censored] you Ubisoft!!!

  • guest-Pwubvwiz
    1 posts

    I’ve been having similar issues for a long time with Walls and Shadows. Showing 3/4 bar completed. It will not let me interact with the hanging man (although it shows the blue outline on the chandelier). This is on XBOX One platform. I was really hoping this would be fixed on the latest patch that came out today. For some reason creating River Raids was more important than fixing a main mission that is required to progress the story arc?!?

  • joshwa420
    1 posts

    Should have named the game jotunheim because all the game does is freeze and be a huge pain in the [censored].

    Cant examine barber tools... Sort your [censored] out ubisoft.

    If social media can get a guy naruto running at area 51 surely we can get these guys to pull their finger out.

  • godfather6471
    1 posts

    @guest-pwubvwiz I have been having this issue since late December. I have been hoping at each update that they would fix this. Now it’s update 1.1.2 and still nothing. [censored] Ubisoft. Find a quick fix. Left there be an option to restart this quest. Anything. I can’t progress with the story until you guys do something 🖕

  • JanosKakophonis
    12 posts

    It's not only that AC Valhalla is the worst release in tems of being a bug-ridden clusterf*** by far but what really makes me foam at the mouth is that it is the most profitable as well since the release of the franchise (!!!)
    It proves over and over again that the more successful a company becomes, the less they care about the crap they release into the wild as people will buy it anyhow, no matter what. I just hope that once, in the post-lockdown future when we all crawl back into the light of the outside world, people will find something better to do with their precious lifes than messing about with broken-[censored] games like AC Valhalla and whatever may come afterwards. Would love to see these mf's come crashing down in the following quarters with a sharp drop in sales and a few heads rolling in management :))

  • JanosKakophonis
    12 posts

    @Ubi-Borealis, thanks for nothing really. You have the audacity to tell me that even though I went through the whole process of uploading my save file, dealing with customer support, yadi-yadi-ya, basically doing your job for you, just to prove that indeed, THE GAME IS STILL BROKEN, you will still not grant me a refund??? Well, how about an UNOFFICIAL support policy that will PAY BACK MY MONEY for selling me a product that can be OFICIALLY declared as fraud for being bugged beyond belief since four months now.

  • MRand0m
    1 posts

    i have issiues with investigate the temple aswell...
    in the crypt i have taken all clues, but cannot continue. its stuck. No bar in top left corner or anything, just "investigate the temple" THATS ALL!!!
    Cant even progress in story since lunden is all i have left to do....

    Ps5, 60 hours in.

  • H.Callahan2211
    1 posts

    Having the same problem. Also got no quest marker for the reaver of the South quest. I've done everything else possible waiting for these to be fixed. Why can't we get our money back as the game obviously isn't fit for purpose?

  • HairyYharnamite
    2 posts

    Come here months on from previous posts becuase I've encountered the same issue. During the investigation of the villa am unable to interact with the guy hanging from the rafters and progress the story, please help

  • HairyYharnamite
    2 posts

    Unable to interact with guy in rafters and progress story still! Please say there's a patch coming soon

  • Ubi-Borealis
    Ubisoft Support Staff 1402 posts

    Hello there!

    Thank you for continuing to update this thread with your experiences of investigating the Temple in "Walls and Shadows." I have passed on all of your reports to the development team as part of the ongoing investigation into this issue.

    At this moment in time, we have no new information to share with you all from the investigation, including an ETA for when there will be a resolution. Once we have any updates to share with you all, these will be posted within this thread and within the News & Announcements forum. Please check these locations regularly for the most up-to-date information from the investigation.

    If you are unable to report to Erke and Stowe after completing the investigation of the Temple, please can you check out this megathread for updates regarding this investigation.

    @martinplaska - Thanks for sharing your ticket number with us. I can see that your save file has been passed on to the development team for further investigation.

    @JanosKakophonis - Please note that, as a member of the player support team, I personally have no influence or control over the refund policies of the Ubisoft Store. Refund requests are investigated on a case-by-case basis, following the digital and physical refund policies. If you do not meet this criteria, then we are unable to guarantee a refund will be granted by the store team.

    Thanks all! 😊

    Official Response
  • Jurks9310
    1 posts

    Same for me here, I'm stock at the same place. Hopefully they fix this asap

Suggested topics

Community details

48
Online
124.2k
Users
21.4k
Topics
110.3k
Posts