Continue your odyssey

Welcome to discussion

Quick Suggestions

Hello! These new forums are an open beta and we welcome your feedback in this section.
  • Abeonis
    53 posts

    @frozenbites Have you emptied enough barrels? There are a number of barrels hidden behind hanging nets of boxes that need to be destroyed first.

  • Magnetons198989
    2 posts

    Can u guys fix the Cellar in Essexe aint working for a lot of ppls and that way we cant get the weapon also there are few more broken bugs whitch am not gonna mention atleast not in here.
    I might be mistaking the name of the region but its the Cellar with the burrels of the wine we shoot them all and the thing in the middle isnt filling so we can pick the item plz fix it.

  • orionsrise
    7 posts

    @abeonis All 10 barrels destroyed. Never floated up and the barrels don't reset

  • Abeonis
    53 posts

    @orionsrise There's quite a few more than ten barrels.

  • hammerthecanary
    10 posts

    Me too same issue none of the wine barrels can be shot again so treasure can’t rise. Have completed the whole story and only have 5-6 trophies left and over 100 hrs played not gonna start all over for one glitched treasure

  • orionsrise
    7 posts

    Apologies bug every guide only showed 10 being needed to trigger the event, but ALL barrels are open, floor is dried and no tablet. Any help from the devs?

  • RyukaiStorm
    3 posts

    The beer did not raise the tablet in the floor.
    The beer kegs do not reset and its stuck under the floor still.
    I can not get Excalibur without it.
    And I tried so many things to reset it that i auto saved past the point of going back and doing it again.

    Can you make a patch that allows the kegs to reset?
    So I can raise the tablet or can you fix it so I can collect it???undefined

  • MrDanielsN07
    1 posts

    Same issue here on xbox, has Ubisoft said they will sort this issue out yet?

    I can't even carry on with my game as the screen is blurry from the collectable effects.

  • orionsrise
    7 posts

    Bump because I'm not hearing anything from support

  • Altrage
    4 posts

    Hello, there is a glitch on ps5 version with the Treasures of Britons: Old Cellar location. I popped all the kegs to cause the wine to flow which should've lifted the artifact high enough for me to grab it. Nothing happened after waiting like 5 minutes so I left the cellar through the barred door, when I ran out into the grassy area Eivor said that the wine has lifted the artifact for him to get it.

    So I ran back down and the wine flowing effect is gone and the barrels are all empty and the artifact is out of reach. I've tried respawning through fast travel, and I wish I could have reloaded but the game autosaved when I ran out of the cellar...I'm 60+hrs into the game and won't be able to get 100% if there isn't a work around this glitch. Please help!

    I should also note my character was perma-drunk for some reason during all this until I turned the game off and back on.

  • Ubi-Baron
    Ubisoft Support Staff 730 posts

    @altrage Thank you for reporting this to us.

    We are aware of that occurring and this has been confirmed by the AC Team, so at the moment the team are currently looking into this issue to find a solution.

    Official Response
  • Altrage
    4 posts

    @ubi-baron thank you for replying, I know everyone at Ubi is working hard to deliver a great game! I hope the fix is not a pain for the developers and a speedy fix is on the way! Happy Holidays!

  • angora_rabbit97
    1 posts

    I had gone through the Old Cellar in Essexe without picking up the treasure, I tried going back through the cave and the sequence for the valves on the barrels are gone and I cannot retrieve the treasure to complete the mystery. I tried reloading the save but they're still no valves on the barrels to shoot at.

  • sbackp
    1 posts

    Same issue on PC. Have reloaded the game multiple times without any change. Would be great if Ubisoft could fix this so that I can finish the game. I have havent experienced any other bugs that hindered or stopped me entirely from completing a quest/goal

  • I20Coyote
    2 posts

    I'm stuck on my first save the only major glitch I had wont allow me to pick up the tablet in the old cellar in essex to get Excalibur the only major thing left for me to do

  • Cerejas2017
    6 posts

    Old Cellar bug, i can’t finish or restart the mystery só i can’t get Excalibur. How can I fix it? Thanks in advance.

  • Cerejas2017
    6 posts

    @frozenbites

    I have the same problem! Do you have any solution? Thanks.

  • HEKB-86
    1 posts

    @frozenbites I have the same problem. Help us ubisoft

  • ShadowSunNinja
    1 posts

    @ubi-baron

    Exact same issue here. Really the only bug aside from animal heads not appearing in the longhouse for me. Plan to 100% this game. Thanks for your attention.

  • DragdaPinkiePie
    2 posts

    I cant reach the tablet. Tried everything. Emptied all the barells and nothin, the tablet didnt move. 😕

Suggested topics

Community details

54
Online
124.3k
Users
21.4k
Topics
110.3k
Posts