Continue your odyssey

Welcome to discussion

Quick Suggestions

Hello! These new forums are an open beta and we welcome your feedback in this section.
  • KIBILDIS
    2 posts

    Reporting right after the 12/15/20 update and I still have the same issue, barrels empty and cannot retrieve tablet. Was looking forward to getting Excalibur after this update but unfortunately they didn’t address it. @deadlaywaiting

  • DragdaPinkiePie
    2 posts

    @ryukaistorm I have the same problem 😕 the patch was my hope but it didnt solve it

  • inxcognito
    13 posts

    I still have this issue even after patch v1.1.0

    It's the only Mystery I have left and I also can't unlock Excalibur cause of this..

  • inxcognito
    13 posts

    After opening all the wine barrels and lifting up the tablet from the sewer, I and a lot of other players can't interact with it to collect it.

    For me personaly, this is the last Mystery I have to complete to unlock 100% completion and I also because of this I can't collect

    spoiler



  • HorizonStarZ
    1 posts

    My girlfriend and I went to do the challenge to get the treasure of Britain in essexe in the Old Cellar and we've been soft locked out of getting the final reward because the caps you have to shoot on the barrels to make the treasure float up to be collected don't respawn. we tried a lot of things such as re-opening the game, loading a different zone (Norway etc) and exiting and going back to the cellar and nothing works.
    I'm aware this is a very early bug (in the sense of since the game came out) after a look around online about it and we can't seem to contact Ubisoft Support about it either.
    Does anyone know if Ubisoft is aware of this bug or not? We've had this bug since last week I believe (definitely before the patch 1.1.0 patch a couple of days ago)
    Thanks for any feed back.

  • xSnakePlissken
    5 posts

    So I’m at the old cellar trying to get the tablet so I can get Excalibur. I’m supposed to hit all the spigots on each cask. I already did that early in the game before I knew about the tablet in the area in the floor. The casks no longer have spigots so I have no way to flood the room with wine so I can get the tablet. Is this issue on Ubisoft’s radar?

  • Ubi-Wan
    Ubisoft Support Staff 610 posts

    @xsnakeplissken Hello there! Our team is aware of this issue and have reported finding a solution which should be implemented in an upcoming patch. Please stay tuned to the game's forums for updates on patches!

    Official Response
  • Cerejas2017
    6 posts

    @magnetons198989 I have the same problem, and I can't reset it, do you have your solved already? Thanks for your help.

  • Cerejas2017
    6 posts

    I have the same problem, but I can't see no solution...

  • Cerejas2017
    6 posts

    I have the same problem (PC) - All 10 barrels destroyed. Never floated up and the barrels don't reset. Please Ubisoft help!

  • orionsrise
    7 posts

    I gave up and restarted. Good luck to the rest of you

  • geoooooooorge
    7 posts
    • Can't get Excalibur because the treasure doesn't rise up in old cellar after shooting all the wine barrels down. Only 8 or 9 are spawning and I believe I need 10? [censored] man. A fix would be nice please.


  • KIBILDIS
    2 posts

    It’s December 23, 2020 and have not seen an update that fixes the empty mead barrels to obtain the old cellar tablet. It remains under the grate with no way to pick it up. I saw a thread posted by developers saying that it would be addressed in the future update on Dec. 18 although have not seen any yet. Any assurance that it’s still being looked at, or that it will be addressed would be great.

  • SM00VG00N2020
    1 posts

    Same issue... please fix

  • durham_red2
    2 posts

    Unable to complete the old celler and collect the tablet on xbox series x

    All the barrels have been opened but you can't collect the tablet at the end.

    Please fix as it stopping me completing the quest and getting the sword.

  • inomil25
    1 posts

    I have broken all the pipes but I cant take the stone. Is my last thing to do in the excalibur Quest. The old cellar need a way to make a reset.

  • Ubi-Woofer
    Ubisoft Support Staff 713 posts

    Hey there everyone! Thank you for reporting these issues with the Treasure of Britain world event in Essexe set in the Old Cellar. I've merged a large quantity of threads for this issue into this new megathread, so I do apologise for the disruption to any existing conversations.

    As my colleague UbiWan has stated above, a fix has been found for the issue whereby the tablet is not raised after the barrels are opened. This will be implemented in an upcoming patch, and we'll update you all here as soon as we know more about when the fix will be made available!

    I did notice while merging these threads that a second issue has been mentioned however, whereby the tablet is raised, however it cannot be collected. If anyone affected by this slightly different issue could provide a video showing that you have broken the stoppers on ten barrels but the stone tablet still cannot be picked up, that would be amazing. Please confirm which platform you're playing on as well for me! I'll then be able to pass this information to the developers for their review and reproduction, as this may require a separate fix.

    Thank you all for your patience and understanding in the meantime!

    Official Response
  • Altrage
    4 posts

    I reported this before the latest update, I got a response from ubi saying it was being looking into. I was really hoping the newest update would fix it but it didn't. I mean it doesn't seem like it should be too hard of a fix, you need a true/false query. If tablet is in inventory then true and keg toppers don't respawn. If tablet isn't in inventory then false and keg toppers respawn. Allow the true false check to happen once eivor leaves the puzzle room and boom. It should be fixed.

  • TygerGard
    2 posts

    @ubi-woofer Also same problem of not being able to collect the Tablet. When i cam back after waiting a few days, I saw that there were only 9 barrels that can be shot. Perhaps this is the problem as it requires 10.

  • guest-QalK7I0O
    3 posts

    Hallo,
    I found a glitch when i went to the old seller in essexe and destroyed the wine barrels the tablet did not come in reach now i'm stuck with getting the exalibur. Can u pleas fix this i payed 95eu for this game lel it be worth it please
    Thanks
    in advance

Suggested topics

Community details

13
Online
125.0k
Users
21.6k
Topics
111.2k
Posts