Continue your odyssey

Welcome to discussion

Welcome to discussion

Quick Suggestions

Hello! These new forums are an open beta and we welcome your feedback in this section.
  • Jimseven47
    5 posts

    and here we are on June 19th and although the patch notes say this issue has been addressed I still can't collect the 11th and final tablet ... in fact now it does not appear to be there at all .... ! What is going on ?

  • Ubi-Mark.
    Ubisoft Support Staff 831 posts

    Hello @jimseven47,

    Sorry to hear that you are still experiencing this issue.

    Can you please perform all the troubleshooting steps listed in this article? Secondly, can you please reinstall your game? These steps will help you to eliminate any potentially corrupted files that can lead to this issue.

    If you're still experiencing this, can you please provide us with a short video of this occurring, so we can have a look?

    Many thanks and if you have any additional questions, please let us know.

    Official Response
  • CentralApollo54
    2 posts

    June 19, patch 1.2.2, xbox series x.

    The tablet in the Old Cellar is still unattainable, but now it doesn't even show up under the grate. None of the barrels are refilled, and my game is still incomplete...

  • Coastie309
    1 posts

    @don_smack_a_lot

    same here

  • LARASTL123
    2 posts

    Still not fixed here on Xbox One either. No more barrels to shoot. Tablet still unable to be picked up. Was really hopeful this last patch would address it. Really unfortunate that 2 achievements are tied up in this glitch.

  • keremthns
    13 posts

    @ubi-borealis How about sending this tablet to everyone (or the people who experienced this) and solve this problem ? I’ve been waiting for 6 months!

  • keremthns
    13 posts

    @ubi-mark hi, tablet is not there anymore. I opened a ticket and shared my save file 5months ago. Please looked at it. I’ve done latest update.

  • UbiKobold
    Ubisoft Support Staff 530 posts

    Thank you for letting us know that the tablet is still unable to be picked up and/or is missing entirely. We've been continuing to forward each individuals information up the Game team as they continue investigating. I'm so sorry for any inconvenience that this may be causing in the meantime, but thanks everyone for your patience during these times.

    Official Response
  • LukasVitek
    1 posts

    I have the same problem 👎

  • LARASTL123
    2 posts

    UPDATE: I uninstalled and re-installed this morning. My last save still had me in the old cellar and I immediately got the voice cue to try picking up the tablet. Was able to collect and get the final 2 achievements.

    Had tried the uninstall thing before, but not since the latest patch. Not sure why it worked this time, but thought I would pass it on in case it works for someone else.

Suggested Topics

Community Details

19
Online
130.3k
Users
22.6k
Topics
117.0k
Posts