Welcome to discussions

Quick Suggestions

  • Lewloulewlou
    3 posts

    I'm having the same issue. Tried reloading, reinstalling the game and so on like everyone else and hasn't fixed it. I also self destructed while in the arena(jumped out the tall tree a few times) to try and force a hard reset but that also didn't work.

    I can see the support staff have requested videos/screenshots which have now been provided a few times. Any fix for this yet? Hopefully it can be fixed in a patch.

  • Ubi-Baron
    Ubisoft Support Staff 788 posts

    @Dun4skme Thank you for reporting this to us.

    Had you died a few times on this boss fight before it stopped allowing you to interact with it? We have had reports of this occurring after dying a few times and this has been passed on to the team.

    Official Response
  • Aizle
    2 posts

    @ubi-baron I have the same issue, but with Regan, and yes I died a few times learning the fight and then the corpse stopped being interactable.

  • Aizle
    2 posts

    @ubi-baron I just thought of another thing that might be relevant. After a couple deaths, I would begin to hit the space bar to quickly rush through the cutscenes to get to the fight. Perhaps there's a connection there.

  • TheNamesSavvy
    1 posts

    Seems like everyone did the exact same thing. Died 3 or 4 times, tried to start the fight again, no prompt to start it. Strange

  • Dun4skme
    2 posts

    I died once then the corpse cannot be interact anymore. Others are fine, I'm just having issue with this only.

  • ozzy235
    1 posts

    After a couple of attempts at the Grantebridgescire Mystery boss (Goneril) the boss is impossible to spawn and the mystery can't be completed nor the rewards for defeating her can be acquired. I have tried re-loading and re installing but nothing seems to be fixing this.

  • Deeeegeeeee
    1 posts

    I have the same issue

  • Bir1in
    8 posts

    @ubi-baron I am having the same issue on Xbox one. Killed the first daughter on the second try. Killed the second daughter on the 4th try. Attempted the third daughter twice before the interact icon disappeared. Hope this helps find a fix to this issue.

  • Woodsyboy2006
    2 posts

    This might just be me but does anyone else have the problem where eivor doesn't say the line of dialogue when entering the area where the boss fight happens after it stops letting you do the boss fight

  • Franks360
    13 posts

    Any news on a fix? I've got 100 hours played, and this is my biggest problem in game atm. As well as the lunden warehouse mystery bug coming in second biggest problem.
    Considering this is part of a bigger storyline it would be nice to get it done before I finish the game.

  • Consumed123
    12 posts

    when are they going to fix this issue.... omg... i've never played a new game with this many bugs, it's actually ridiculous 😞

  • Ima4nDAl0reI92
    20 posts

    Ok I’ve been dealing with Ubisoft support for over a week. I’m very angry now. This [censored] of a big needs to be fixed right [censored] now. Do your jobs!

  • Mighty_M1tch
    3 posts

    Me too, I’m hoping this will be sorted soon as possible. I go back to check every time I load the game to double check. Pushing on 60 hours now

  • cjaesq
    1 posts

    Can not access goneril fight. Lost previously and geared up and now can’t access the fight.

  • canibal-58
    1 posts


  • kanjman13
    2 posts

    @graceofmjolnir same thing with me I can’t get Thor’s armour, I’ve defeated the 2nd and 3rd but the 1st is glitched out

  • ScrubLord124
    1 posts

    Very same problem here, it's the only thing stopping me from getting the plat trophy

  • AlayscAC
    1 posts

    Also having the same problem.

  • blanktarget83
    2 posts

    Same. This quest line can't be completed no matter what I try now.
    I've tried to go to different maps, reset my console, nothing seems to trigger it to show up again.

Suggested Topics