Welcome to discussions

Quick Suggestions

  • kanjman13
    2 posts

    @delbertqb1 it’s a head doer

  • Ubi-Woofer
    Ubisoft Support Staff 799 posts
    Best Answer

    Hello everyone,

    We announced last night that TU 1.1.1 will launch today on January 14th, and I am pleased to say that in this patch is the fix for the Daughters of Lerion encounter with Goneril whereby the corpse cannot be interacted with to start the fight.

    Once the update has been applied and you have fully updated your game, you should find that you are able to interact with the corpse upon returning to her lair in Spalda Fens in Grantebridgescire. Please give this a try once the patch is released, and let me know here in this thread if you encounter any further issues!

    I would like to thank you all for bringing this issue to our attention, and for providing all of the requested information throughout our investigation of the issue. This thread will remain open if you have any further questions or concerns, and either myself or another agent will respond as soon as possible. Thank you! 🙂

    Official Response
  • nic_ios
    1 posts

    Im having the same issue, died a few times but now unable to trigger the event again by interacting with the corpse

  • Multi_Shadow
    2 posts

    PS4 same problem

  • Franks360
    13 posts

    If every time you loaded a game it didn't auto save, we'd never have got in this situation.
    Why on earth when I load a save, do you think I need a immediate auto save??
    Like, I've just loaded a save, I don't need all my auto saves overwritten because of it.

    5 posts

    Same here. Tried to uninstall and reinstall didn’t help. Please patch this ASAP.

    5 posts

    Same issue here! Over 50 hours in. This issue has been here since launch! I kept on playing Because at the time I was already over 10 hours in... please fix this soon!

  • SoCl0s3
    4 posts


    I actually don’t know what you need a video for after so many people have explained very detailed what the problem was. Would you mind explain that?
    You simply can’t interact with the tied up body anymore. The white dot which pops up while the character getting closer, and then transforming into „E - Interact“ ist not there. And it started after dying three times.
    You also should look into your Auto-Save-Managment. If you save before an event, and die, you want to be in the exact state of before the event! Not in an state which happen to be an auto-save after dying, just putting you back alive but with all the arrows gone, and stuff. Either that or bring back the arrow- crafting feature! Just as a side note.

  • DimpBoyReeee
    1 posts

    samething here died 2 times and now i just cant start it anymore

  • Lucas_Dutchman
    6 posts

    @shaggys2112 Same here, Ubi please fix this, so I can get 100%

  • Stormgrade2010
    1 posts

    Its 14 days with this problem, and still no Patch to repair.....

  • VitRodrigus
    1 posts

    same here. Tryed couple times to kill her but at some poing I just coudn't try anymore.

  • shaiwan43
    54 posts

    Same. Except the electricity daughter for me. I left and came back and now I can't interact with the corpse. 100% bugged and can't get the Thor's armor now. So frustrating.

  • shaiwan43
    54 posts

    The bug occurs if you trigger ANY of the daughters, and lose, and then try to come back later. AND ESPECIALLY if you crash during the fight.

    Crashing to desktop during the fight is guaranteed to bug the corpse / event trigger. Also loading / reloading save files can bug it too.

  • shaiwan43
    54 posts
  • tinypicker
    23 posts

    Hey, just wondering if this will be fixed tomorrow. Does this count in the "fixed world events that players couldn't complete"? Just wondering and im kinda hopeful!

  • Saratonin57
    2 posts

    After fighting Goneril a couple of times the button to activate the fight no longer appears and I am unable to fight her.

  • Saratonin57
    2 posts

    @ubi-baron I have the same issue. After dying a few times I am no longer able to interact with the corpse. I am also now realizing I too skipped the cutscenes, don’t know if that is linked or not.

  • Lavatherm
    2 posts

    Same thing here, i also have a "not completed" bug on Berkelow bog (2nd sister/daughter) the 3rd one is cleared, i even got the reward (wont spoil that) but Spalda fens and Berkelow Bog still on the map as not esolved, this sucks since i'm already near the end and this won't help me get the 100% completion :s

  • darynbray
    3 posts

    Same on PS5
    Tried it died, now cant trigger it

    4 posts

    Saw this on older forums as well so I am posting it here. The daughters of Lerion missions cannot be restarted after failing. The only way I got around this was loading a WAY older save and progressing to it again. However, upon death, I was unable to retry the mystery again. I would attach a photo of I could.

Suggested Topics

Community Details