Welcome to discussions

Quick Suggestions

  • darynbray
    3 posts

    Same on PS5
    Tried it died, now cant trigger it

  • Ubi-Woofer
    Ubisoft Support Staff 801 posts
    Best Answer

    Hello everyone,

    We announced last night that TU 1.1.1 will launch today on January 14th, and I am pleased to say that in this patch is the fix for the Daughters of Lerion encounter with Goneril whereby the corpse cannot be interacted with to start the fight.

    Once the update has been applied and you have fully updated your game, you should find that you are able to interact with the corpse upon returning to her lair in Spalda Fens in Grantebridgescire. Please give this a try once the patch is released, and let me know here in this thread if you encounter any further issues!

    I would like to thank you all for bringing this issue to our attention, and for providing all of the requested information throughout our investigation of the issue. This thread will remain open if you have any further questions or concerns, and either myself or another agent will respond as soon as possible. Thank you! 🙂

    Official Response
    4 posts

    Saw this on older forums as well so I am posting it here. The daughters of Lerion missions cannot be restarted after failing. The only way I got around this was loading a WAY older save and progressing to it again. However, upon death, I was unable to retry the mystery again. I would attach a photo of I could.

    4 posts

    Unable to retry the mystery as it will not let us interact with the dead body to initiate the fight. Seen others post about this on older forums so I am forwarding it here as well. I would upload a video of photo, but your site does not allow iOS photos or videos.

  • bsholmes1992
    2 posts
    This post is deleted!
  • mr.hanandrobin
    2 posts

    has this been resolved in the recent update ?

  • mr.hanandrobin
    2 posts

    @shaiwan43 did you update the game to 1.0.4 and tried it ?

  • Diegoez16
    12 posts

    Had the same problem and i fixed it by puting the swords of the other withces into the stones then marked in the area it should have been when i start moving toward my mark a blue mystery apears

  • DanRag85
    10 posts

    New title update still has not fixed this glitch. Been two weeks waiting now!!

  • Erkronell
    2 posts

    I'm done with this stupid game.

  • haofeileo
    1 posts

    Still can't interact with 1.04 patch.

  • GlehnXIV
    3 posts

    After the patch. Doesn't work this world event. I cant interact with the corps. 😔 Before and after the patch this world quest isnt good. Why not fix it?

  • Consumed123
    12 posts

    Yeah the new update didn't fix S''t!, the bug is still here been waiting for a fix for weeks and still nothing. Like...

  • Hector41891
    1 posts

    1.0.4 do nothing with this bug. A game still bug

  • NegativeRamos_
    4 posts

    Same, I can't interact with Cordelia in East Anglia. I bumped into the altar but was too weak, so I read the earlier saves pretending that Eivor never met her.
    When I complete the story and I found that there's a bug. Many players in

    Yet it's v1.04 and still I can't interact.

  • elcarancho
    7 posts

    The problem still persist... The new update did nothing... This is a big screw up...

  • oldbaldgamer
    3 posts

    Still bugged for me after the patch

  • darkknight249
    3 posts

    After the patch the bug still persists.

  • zu-tanu2000
    2 posts

    I can't fight goneril cause there isn't a comand for start the fight on the corp

  • subzeroash92
    2 posts

    The problem still happening even after the patch 1.0.4. I do have a photo but wont let me put it up.. I've reloaded, meditated, carried on with the story and came back to it still not working.

  • zu-tanu2000
    2 posts

    I can't fight with goneril cause i can't interacte with the corp and start the fight

Suggested Topics

Community Details