Welcome to discussions

Quick Suggestions

  • Tobi_W_Kenobi
    6 posts

    same here she’s the only one of the daughters I need to fight but I can’t

  • Refreshering
    1 posts

    In the Spald's Swamps or (Болота Спальды), don't quite know the name in english, where you have to defeat witch with two swords, after several attempts i loaded the last save and i can't start this event no more, it should be a button near the corpse of a man under the tree, but it never appear anymore, world event is still glowing, so it's not finished, and cannot be started

  • darkknight249
    3 posts

    I fought Goneril and died many times, now I can't interact with the body in order to try again the fight and I am stuck.

  • Nyonic86
    2 posts

    @thekingsnoose I have the same issue on Goneril. Is there any update or workaround?

  • Nyonic86
    2 posts

    @tobi_w_kenobi I have the same issue. Already posted in another thread as well. Last one I need to do and its really annoying to not know whether or not this will be fixed.

  • vlaiden0305
    5 posts

    I also have this problem, after a few attempts on the boss I cannot start it anymore, cannot interact with the dead body. Help?

  • Franks360
    13 posts

    So I've far travelled around a lot of times, carried on doing other things. It hasn't resolved itself.
    Also I've found out that she is one of three sisters you need to fight to unlock a reward in another area, so even more frustrating.
    It would be nice to just have official acknowledgment that they are aware of the issue.
    I worry that it will fall through the cracks otherwise.

  • Thorback44
    1 posts


    I want to report a bug which make my saved bugued, I tried to do "Goneril" like 10 times and after it, i load my save but can't launch the activity. I already had a bug with saves which make me enter in battle during the load (taking damage when i wasn t abble to moov) it was with Erik Royal Skull and i had to defeat him obligatorily and it was really hard (hardest / red skull...).

    Second bug on saves but this one make my saves corrupt and block the game for good...

    I tried to take older saves but the bug remains!

    Thank's for reading, I'll wait your fix of this...

  • TheKingsNoose
    4 posts

    @nyonic86 I can't seem to find any information on this issue myself, just hoping it gets fixed soon.

  • Gziervogel
    4 posts

    I was able to do the boss fight 5 or 6 times but now it won’t let me do it anymore. When I walk up to the place to interact and start it, no interact icon comes up.

  • Zhiar713
    6 posts

    For some reason i cannot start the Spalda Fens Goneril boss encounter there is no prompt to start it.

  • TheL0neGinger
    1 posts

    Extact same for me but on Xbox One.

  • Xylor_gaming
    1 posts

    Same problem here with ps4 pro

  • albovy
    4 posts

    @graceofmjolnir Same issue

  • JaceM4
    2 posts

    I have the same issue going back a save didn't help me and I've went and done other things came back and the interact prompt is still gone. I assumed maybe their was like a limit to how many times you could fight her in one day but I fought her like 20 times before it stopped letting me and it seems you only made it 3. If someone gets a fix lmk

  • albovy
    4 posts

    @jacem4 yes I only could fight 5 times with him, so probably is a bug no?

  • tinywaldorf2
    3 posts

    I’m unable to interact with Goneril anymore. I was able to 3-4 times, but I am unable to anymore.

  • sharkdiver999
    1 posts

    Im unable to start the fight with gonril of the daughters of lerion after dying several times. Totem that starts fight is inactive and reloading and restarting game is no helping

  • Gziervogel
    4 posts

    early game I fought this boss 5-6 times not succeeding so I decided to leave and come back later. When I came back I no longer had the ability to interact and start the boss fight. Is this a game mechanic or glitch. If it is a game mechanic when will I be able to do this boss fight again. Not being able to fight this boss prevents me from completing Thor’s armour set and therefore Thor’s hammer.

  • guest-DjhcmB6G
    3 posts


    I am having the same problem with Cordelia. She is the only one I have left to beat.

Suggested Topics

Community Details