ubisoft discussions


  • locked topic_solved [RESOLVED] Unable to interact with the corpse to start the fight with Goneril | POST HERE

    23 likes/618 replies/24552 views
    ubisoft:x-posts, 3

    @ubi-baron thankyou for getting back to us! Really appreciate you guys at least hearing us and trying

  • gentester
    ubisoft:x-posts, 65

    Same issue. Spalda and Berkelow both won't clear, the remaining one worked just fine. All 3 combatants are dead and I have picked up the rewards from all three and the overall reward from the 4th location but those two places are still active and reading as cursed, both bodies have vanished now so I couldn't interract with them even if I wanted to. (PC)

  • SilverMan910210
    ubisoft:x-posts, 3

    undefined please tell this can be fix? I don't want to start a new game just to fight 1 boss.

  • xboxdaddyb
    ubisoft:x-posts, 2

    Created an account on the forums just to say I have this same issue, have for a couple weeks, and it's incredibly frustrating. I'm on Xbox X, like many others tried her too early, died 5-6+ times, said screw it I'll come back when I'm higher powered. Now I have 320+ skill have cleared the other sisters but can't interact with the corpse to pop her. At the time I assume I had some other mysteries in the zone done, now I have all but 2 done. Please fix this, not sure how you can't replicate it there are literally videos here showing it.

    • Have you completed any other mysteries in the area?

    Yes, all but 2 at this point

    • Have you left the zone before returning?

    Yes, many, many, many, many times

    • Did you complete any other main quests before returning to the Goneril fight?

    Yes, many, many, many

    • Are you able to interact with the other two corpses for the Daughters of Lerion mysteries, and/or did you complete those fights already?

    Yes, cleared both of those

  • Kamkam353
    ubisoft:x-posts, 2

    First witch goneril I think her name is, is glitched and won’t let me interact really sucks cause Thor’s entire outfit becomes unavailable

  • No0t0_0No0t
    ubisoft:x-posts, 1

    I was able to interact and fight her, after losing a few times i simply could not interact with the body anymore. i already played another 10 hours after that and i will not want to load a previous game that has a 10 hour progress gap. please fix thisundefined

  • tokajero32
    ubisoft:x-posts, 21

    watch the forums more plz mate , and dont make new thread but post in the one already exists. there is a search button on top of your screen to find it.

    anyways the problem exist a month now so i guess they will fix it in the next patch in a few days.

    ubisoft:x-posts, 4

    Same thing to me, always try to go back but cannot interact with the body. Only have 1 more left. The save I had where it worked is long gone.

  • FunkybooZ
    ubisoft:x-posts, 15

    We are now more than three weeks post launch and there isn't even a hint at a possible fix and no communication for days. I don't think a fix is happening and if it does it'll be after we've all moved on to another game. What is even the point of getting the armor and hammer now if it's literally the last things left to do in the game? I wish I had not paid full price for this broken game but at least now I know better for the future with ubisoft.

  • Dackeyras-
    ubisoft:x-posts, 2

    @silverman910210 Salut Silver,
    J'ai exactement le même problème, as tu résolu le truc ?

  • Dackeyras-
    ubisoft:x-posts, 2

    I have exactly the same issue than SilverMan910210 on the post Dec 5, 2020, 2:51 AM !
    The issue is i can't trigger the fight against Goneril !
    Ihave do one time, i loose, i low the level and since i can't trigger the fight ????
    How could you fix this ?

  • fallzing
    ubisoft:x-posts, 9

    @ubi-swaggins I don't have a video, but I have the same bug as others have posted. I attempted fighting this boss while I was very under leveled and died a few times. I left and came back later after leveling up, but the prompt to start the fight would no longer pop up. I was able to beat the other two sisters, but I didn't died during those fights. I would love to be able to beat this quest and get all of the Thor gear. This is one of several quest breaking bugs I've encountered, as well as tons of other minor bugs, game crashes, etc. It's really ruining the game for me and I'm extremely frustrated that Ubisoft would put out a game with some many problems.

  • SkyZ_SolemnAxe
    ubisoft:x-posts, 2

    Hello it's been over 4 weeks since the reported issue and still no fix, I came into this game loving, and now due to this big that you guys can't seem to fix is running my experience and making me regret my choice of playing, just please fix this alter glitch and let me get moljnir 🤦♂

  • SkyZ_SolemnAxe
    ubisoft:x-posts, 2
  • softyX3
    ubisoft:x-posts, 2

    Re: [BUG report ac Valhalla](/topic/81421/bug-report-ac-valhalla)

    Can't collect the second key for Jorvik treasure, the key is on a body in Ritual Circle in North Northhumbria but i cannot collect the key, i have tried to medititate, restart the game etc. but i can't collect it.

    Second bug is i can no longer start the boss fight with one of the sister at Spalda Fens, Grantebridgescire. Had this issue since almost the beginning om the game so i have tried almost everything, i have started the boss fight before and lost it so i know how to start it.

    I only need to do these two objevtives to 100% all the regions. (Treasure in Jorvik, Mystery in Grante wich i also need to take the last treasures in East Anglia.)@softyx3

    Second key for Jorvik Treasure is not a problem.

    Just a visual glitch, the body had the key visual still even after i collected it, so i got the treasure now.

  • softyX3
    ubisoft:x-posts, 2
  • Marmotte41
    ubisoft:x-posts, 1

    same bug with the xbox one version...

  • PyrenicDeath69
    ubisoft:x-posts, 2

    I was able to attempt the first daughter (can't remember her name) but failed due too too low of power. I left and came back later but now I can't reactivate the mystery. This is one of the few things left before I have the game 100% complete. Most of the other glitches have resolved themselves by me me either reloading the game or coming back later, but this is keeping me from getting mjolnir. I know several other people are having this issue and I was hoping last update this would be patched.

  • PyrenicDeath69
    ubisoft:x-posts, 2

    This is one of the few things I have left before I 100% the entire game. Please fix soon!

  • guiaccman
    ubisoft:x-posts, 1

    I have this bug on PC as well, have checked it multiple times with no luck. Would immensely appreciate it if it was fixed, Thanks!

Suggested Topics