Welcome to discussions

Quick Suggestions

  • bokehbakr
    4 posts

    @ubi-baron Thank you for acknowledge, Hopefully this bug will be solved as soon as possible

  • Alex-2325
    4 posts

    FIX THIS BUG UBISOFT! You already said you did and lied. Someone needs to be fired. If this isn’t fixed by next patch so help me god I will never buy another ubisoft game and I will spread the word for others to not do the same because you have so many problems with your game you don’t care to fix that are game breaking bugs.

  • Alex-2325
    4 posts

    I have been waiting for this damn quest to be fixed since release day. I am tired of waiting for something that is so simple to fix. Hindering thousands of people from getting Thor’s armor set and hammer. You suck Ubisoft.

  • Multi_Shadow
    2 posts

    Some information about patch and this bug?

  • Bushwickedly
    109 posts

    I just ran through all 3 of them yesterday. Everything was working. Maybe try searching Lerion's estate and removing the cursed object, and read the notes scattered about the crypt area. Interact with the statue in the basement. I did all that first before engaging any of them.

    I had found one of them previously but never tried engaging it. After accidentally finding the house and doing/reading/interacting w/ everything there, decided to try the sisters. Did Reagan 1st, Goneril 2nd, then the nasty Cordelia last. IMHO, Goneril was WAY harder than Reagan during her 2nd phase, so consider trying in that order despite their posted level differences.

    Anyhow, everything was working as far as I could tell. Only oddity was after beating them, the location boundaries still warned you when leaving the area which seems to be a bug.

  • Bushwickedly
    109 posts

    Also, make SURE you haven't remapped your buttons that interact. It can sometimes cause conflicts like this. I had an issue where everything "worked" until one thing didn't. Look at your interact button in the menu and see if it has a conflict.

  • BazBlack656
    1 posts

    Still Bugged.

  • harlej140
    1 posts

    I have still problem with her. I put other swords into statue and i can't fight with Goneril. Much time ago before update i died 3 times and i never try again

  • tinypicker
    23 posts

    @multi_shadow
    The next patch may be when the yuletide event starts, and the bug is known by the dev team, and they're working on a fix now.

  • Dannspress
    22 posts

    @tinypicker In the middle of December?!!

  • tinypicker
    23 posts

    @dannspress
    Yeah, probably

  • tinypicker
    23 posts

    @dannspress
    Nothing official yet tho

  • UbiExcellent
    Ubisoft Support Staff 756 posts

    @modifynl Hi folks! Our teams are having a difficult time with reproducing this error on their end and are requesting the following information for our on-going investigation please:

    • Have you completed any other mysteries in the area?
    • Has you left the zone before returning?
    • Have you completed any other main quests before returning?
    • Are you able to interact with the other 2 corpses for the Daughters of Lerion mysteries?


    In addition to these questions, our team would also like to gather save files and system files if possible! Please attach these files to a support ticket, then post your case numbers here once the ticket has been created and the files have been uploaded. Thank you all for your assistance with this issue.

    Official Response
  • ChainofPeace
    1 posts

    Hey, thanks for reading this. Died while fighting first daughter of lerion, prompt no longer shows. The same for other daughters, hope you guys fix it soon!

  • Buffelwolf
    5 posts

    @pauliokaz_428 same here... wanted to get the armor but i’m stuck.

  • Clemminou
    1 posts

    Same problem and still not fixed...

  • FireRooster4
    1 posts

    - i have completed all other missions in area
    - i have completed all artifacts, mysteries, and wealth in area
    - i have killed both other sisters and placed daggers

    How do I attach the save file?

  • epic.FireKorgi
    1 posts

    In response to ubi support. I have completed all other mysteries in the region. I left the area after a few time dying fighting her. I did a couple big quests after leaving. I was able to interact to start the other fights. Also this is on xbox series s. I hope this helps resolve the issue

  • AirFrogs
    1 posts

    After I died 2 times to a daugther of Lerion, the game didnt show me the interaction button to start the fight, know i cant get Thor's set. :*(

  • TheBomb1414
    1 posts

    To Ubisoft I had done the quest about 20 times then I wasn’t able to start. So I left and I did all other mysteries in the area and did many main story missions and still wasn’t able to start it. Also I can start the other sisters fights. I’m on PS4 I hope this helps

Suggested Topics

Community Details

105
Online
217.6k
Users
36.7k
Topics
182.2k
Posts