ubisoft discussions

Quick Suggestions

  • UbiKoality
    448 posts

    Hey everyone! I'm extremely sorry to hear that you're all dealing with this bug in Assassin's Creed Valhalla. I deeply apologize for the disappointment, frustration, and inconvenience that it has caused. Your annoyance is completely understandable considering the impact this has on your gameplay experience. Moving forward, please be advised that the development team is aware of and actively investigating this bug at this time. Once additional information and updates become available, they will be posted here. Aside from that, please consider uploading your save files in a case at support.ubi.com. This would be very helpful for the team as these files will aid them in their investigation. In the meantime, thank you so much for your continued patience and understanding!

  • SilverMan910210
    3 posts

    @dackeyras Why are you asking me? I'm the one with the same issue

  • NOLANATOR.66
    1 posts

    Im in the same boat. I really want to get that gear at the end of fighting the sisters. I'm on xbox one.

  • gould19942016
    1 posts

    I cant fight the first witch. It wont let me activate the fight.

  • tinypicker
    23 posts

    Any update? About the patch or glitch?

  • dmapr
    1 posts

    Have the same issue on Xbox One. Having defeated Goneril & Regan got destroyed by Cornelia. After gaining sufficient power to try again came back, but Cornelia fight won't activate anymore.

  • shaiwan43
    54 posts

    Due to a significant number of players experiencing bugs related to Daughters of Lerion; it has effectively locked the Thor Armor and Mjolnir weapon behind a game-breaking bug. With respect, it has been 30 days without relief from this issue and it is not fair that content that has been paid for by customers is locked behind a bug in perpetuity until at some future date, to be determined, a solution is achieved. Players deserve access to the same content as other players. It was incumbent upon Ubisoft to correct this issue prior to launching the game, and if not, to patch it quickly after launch. That has not occurred, and now it would be appropriate to consider delivering relief to the many patient customers who have been waiting.

    Thank you.

  • jr0617
    1 posts

    The game won't let me activate a fight with one of the three sister's no matter what I do. I really don't wanna start all over again

  • Ubi-Wan
    Community Representative 636 posts

    @jr0617 Hello there! Thanks for reaching out to us with this. I'd like to ensure I'm looking at the right encounter. Is this for 'the Daughters of Lerion' mystery? Please provide any details you're able to, including a video clip, if able!

    Official Response
  • dborrell13
    3 posts

    I've started it once or twice and died a while ago, and I went back after killing a different one but now I can't start the fight with the daughter at Walsham Crag! It's very frustrating because I've tried everything

  • FunkybooZ
    15 posts
    This post is deleted!
  • ShadowHunter157
    1 posts

    I'm unable to interact with the corpse that let's me fight cordelia and it doesn't work and we are a month from the day this game launched and still no update on fixing this bug or glitch, so if you one of you Ubisoft staff see this, can you pls fix this problem for me and others because I already have two of Thor's armor and now it doesn't seem worth my time now. Also don't think I don't like the game, I really love this game, but don't let me regret playing this game and maybe give me some hints or tips that I could be missing that could let me fight Cordelia in East Anglia.

  • Wadle10
    1 posts

    This started after I fought her. Lost. Tried again immediately after. repeat. repeat. etc. Now there is no interaction and I'm at a suitable level to fight her. Please fix this. It's all over Reddit and still not fixed. I'm not trying to restart all of my progress to fight one witch. Buggy af

  • Dannspress
    22 posts

    I did not find our problem listed in the new patch tomorrow 😞
    Did anyone find it?

  • bokehbakr
    4 posts

    @Ubi-Baron I've seen the title update 1.1.0 will be soon released but does not have any update related to this bug in the release note? could you please help to confirm if this issue will be fixed in this release or not. Thanks

  • Dannspress
    22 posts

    I did not find our problem listed in the new patch tomorrow 😞

    Did anyone find it?

  • bayoooMan724
    5 posts

    Ok dats it. the incoming update did not mention our concern in goneril. ubisoft staff here is keep asking to us but nothing happen. time to finish this bug game without killing this goneril.

  • Lucas_Dutchman
    6 posts

    Hey Ubi, thanks for the patch, doesn´t include fix for Daughters of Lerion though... screw it, I am selling the game and not buying anything from ubi on launch any more... can advise others to not do that also, since you are not able to fix this in 2 months and I lost interest in this game for good... I´m out, bye

  • Showood
    3 posts

    still the same problem with patch 1.1.0 ...

  • guest-v7i4d4yN
    1 posts

    Please fix the bug for the “Sister’s of lerion” I’m unable too interact and start the mission to fight her. Please and thank you


    spoiler


Suggested Topics