ubisoft discussions

Quick Suggestions

  • guest-atX9K3cA
    1 posts

    I'm cannot fight the third daughter boss battle. It let me try twice, but I guess I got to close and did a save and it wouldn't let me interact with it. Not going to lie, I don't even feel like continuing my gameplay and I already have about 80 hours in the game. Please fix, because that was one of the things that was motivating me to grind towards.

  • Tom_Noppers
    1 posts

    When does the mission of the daughters get patched? I completed the whole map except one daughter because I can't interact.

  • TrueUK
    1 posts

    OK, now I’ve read through all these comments so far about the Daughter’s of Lerion & I’m suffering the same bug on my PS5 (free upgrade) edition! I’ve fought the daughter in Spalda Fens once and got beat! Now, despite reloading game, rebooting console etc... I can’t interact with the corpse to trigger the battle sequence again!

    I’ve had SO MANY issues with this game! I’ve clocked over 157 hours on it (albeit some hours were idle time whilst I watched football on various nights)! The most common bug I get is mysteries not allowing me to interact, most often cairns! However, usually I can just save it & reload it to get it to work or reboot game entirely in worst case!

    I’m on the clean up now, collectibles & other such trophies for platinum! I really hope this bug is patched soon!

  • tinypicker
    23 posts



  • Ubi-MrM
    Ubisoft Support Staff 2950 posts

    Hello everyone,

    We announced last night that TU 1.1.1 will launch today on January 14th, and I am pleased to say that in this patch is the fix for the Daughters of Lerion encounter with Goneril whereby the corpse cannot be interacted with to start the fight.

    Once the update has been applied and you have fully updated your game, you should find that you are able to interact with the corpse upon returning to her lair in Spalda Fens in Grantebridgescire. Please give this a try once the patch is released, and let me know here in this thread if you encounter any further issues!

    I would like to thank you all for bringing this issue to our attention, and for providing all of the requested information throughout our investigation of the issue. This thread will remain open if you have any further questions or concerns, and either myself or another agent will respond as soon as possible. Thank you! 🙂

    Official Response
  • Kormac67
    1100 posts
    you should find that you are unable to interact with the corpse

    You probably meant "able".

  • bokehbakr
    4 posts

    Just update to latest patch 1.1.1, for me this bug is fixed (Cordelia). Finally I can get Thor's helmet and Mjolnir. Thanks heaps Ubisoft!

  • Ubi-MrM
    Ubisoft Support Staff 2950 posts

    Thanks for pointing out my typo @kormac67 - I managed to make that in both of the threads for Goneril and Cordelia apparently 🤦 I've corrected it now! 🙂 Just to confirm - you should be able to interact with the corpses for the sisters now.

    Official Response
  • Pikibee
    5 posts


    Thank you very much! It worked for me!

  • guest-7zssXIWy
    1 posts


  • Veirub
    1 posts

    @trueuk Patch 1.1.1 fixed this bug for me and could kill the Daughters. When it hits consoles you will probably be fine 🙂

  • jeffertson1987
    11 posts

    Thanks ubisoft i can interact and start the mission 🙏

  • vlaiden0305
    5 posts

    @ubi-woofer Took you only 3 months, yeeey.... [censored] ubisoft

  • Jezability
    2 posts

    Yes, can confirm latest patch (1.1.1) has fixed this issue! (and several others.) Great job!

  • FayamanGielo
    7 posts

    I solved the bug! The only way was to restart the game because I had no pre bug saved games. So goodbye lvl 283 Eivor!

  • eikishi01
    5 posts

    @ubi-woofer Hi, I previously defetated Goneril and got the issue with the corpse laying down unreponsive and the wierd sound glitch reported everywhere.

    Now after updating to 1.1.1 [PC], while playing I went back to Goneril and the bug was still there, The I thought of closing the game and reopen while being in Spalda Fens, so I did and Goneril corpse is gone now and there is no other interaction available, the green fog still there like when you fight her but nothing to fight or interact with. 😞

  • eikishi01
    5 posts

    @eikishi01 [update] : After reading other posts where some one mentioned that the other sister left the area I started searching around and then found Goneril corpse outside the battle area with the sound glitch still in effect, I carryed her body to the battle area again to see if something happened but no luck, 1 thing I noted, since I´m in a PC and playing while writting here, I minimized the game to switch to the browser and the Goneril started talking until the game it self went to the menu screen automatically, an expected behaviour I think, but yeah, the issue may be different from the original of "not being able to start the fight" to "won the fight, Goneril is dead laying around with a wierd sound glitch and not completeing the mission".

  • marshallposey22
    1 posts

    @mbenson10 Im having the exact same issue bro. I beat them all but I only have 2 daggers

  • Ubi-Borealis
    Ubisoft Support Staff 6078 posts

    @eikishi01 - Hello there! I apologise for the delayed response. I'm sorry to hear you're having some trouble confirming Goneril's death. As this thread is about a slightly different issue (being unable to interact with the corpse), would you be able to post in a more similar thread, or open a new one? This way, we can keep the investigations separate. If you open a new thread, please can you also include a video of the issue with Goneril? This will help with the investigation. Thanks! 😊

    Official Response
  • Tyrm7
    3 posts

    I still can’t fight the third sister

Suggested Topics