Welcome to discussions

Quick Suggestions

  • Slyfer-007
    1 posts

    we should all get a refund or start a law case !
    for the last 2 weeks i am unable to play assassins creed valhalla... due to the bug a vieuw from above ! i am at 30play hours...
    i do not have save files before the event ! so i am stuck there !
    Atleast a game breaking bug should be hotfixed asap by such a big company.
    i payed 60euro and bought a small pack of points leads me to 90euro for a game that is unplayable the last 2 weeks...
    if you bring out games plz make sure people can play true them, and not have to restart the game if you encounter a bug !
    is there anyway i can atleast get back the point pack money ? the game i can sell again !

  • P-W-D
    1 posts

    i have the same issue

  • cat-e
    1 posts

    I struggled with the same problem for hours today. I cant believe this kind of massive bug has been in the game for so long.
    Starting from the previous save before the rainbow brigde worked for me. Nothing else. Missed few hours of gameplay tho. DO NOT use those goddamn portals!

  • nvrsummer540
    3 posts

    Experiencing the bug and I do not show an exclusive load point to select (only autosave and manual saves) so my only option seems to be to restart...

    I've tried switching the hold alternative to popup instead of hold, but that doesn't fix anything.

    Super super super super disappointing

  • nvrsummer540
    3 posts

    @gamdil I'm pretty far in myself and have nothing but auto saves😢

  • Gy2fly4u85
    7 posts

    The bug can be fixed by getting to the gate from the back of the mountain. DO NOT FIGHT ANYONE!!!! Get to the back side of the mountain, follow it to the gate, then close it from there. Again... DO NOT FIGHT ANYONE!!! If you get hit, that's fine but DO not engage battle, just keep running. Worked my first try.

  • Gy2fly4u85
    7 posts

    When getting to the gate DO NOT ENGAGE IN BATTLE!!!! Simply cross the bridge, get to the back side of the mountain, follow it to the gate, then close it. The quest will continue from there. It doesn't matter if you get hit by anyone, just DO NOT ENGAGE BATTLE. After trying all other options, this one worked the very first time. Goodluck all.

    (Ubi-toon changed the title to workaround)

  • Gy2fly4u85
    7 posts

    @asvpxnicholl DO NOT ENGAGE ANY BATTLES. Go to the back of the mountain, follow it to the door and close it from there. If you get hot, you are fine, just DO NOT ENGAGE IN BATTLE. Goodluck.

  • Hickman010101
    1 posts

    When can we expect a fix? Such BS when stuck for hours with no advance. #Cyberpunk2077 is only 10 days out...time to move on when Ubisoft does not respond!

  • ZERO-ONE43
    4 posts

    @hickman010101 same, considering just dropping ac valhalla and switching to cyberpunk.
    Unbelievable how long they need to fix this, this is literally your job.

  • Galient
    2 posts

    This is ridiculous, it has been going on this long and no fix? It just had it happened to me....

    Edit... Just got past it due to a recent load I had... seems you cannot deviate from the story line at all or else it will glitch it.

  • ZERO-ONE43
    4 posts

    @galient i know, it has been over two weeks since i got stuck, still waiting for it to get fixed but honestly i don't have very high expectations anymore since it takes so long to fix, or keep us at least updated about if they're making progress.

  • jepeman
    11 posts

    @zero-one43 And its still broken, just got to this part and wasted almost an hour exploring Asgard before actually trying to resume, bugged quest, bye bye 1 hour of progress I guess.

  • Hermiteer777
    1 posts

    I've been stuck in Asgard for days. I didn't realize it initially, but the View Above All quest is jammed. Even though the quest is marked as Tracked in the Quests screen, the map does not have a quest marker on Heimdall's Tower. Thor and Freya are nowhere to be found, and the enemies on Heimdall's Tower just stand around looking at me, they do not attack. There is no H on the map for me to leave Asgard, and closing the door on Heimdall's Tower does nothing (it just goes back to the Close prompt). Neither door works where the Bifrost meets Heimdall's Tower. There are missing NPCs, like the one on the northern island, and if there is an NPC I cannot interact with it, like the guy standing on the grate above the well in the middle of the southern island.

    I have been able to collect 28 or 30 treasures, but since I can't interact with any NPCs to solve mysteries, I can't get the last two.

    Hopefully the screenshots demonstrate the issue and will be addressed in an upcoming patch. I'm 33 hours in and don't really want to start over...


  • Ubi-Borealis
    Ubisoft Support Staff 3861 posts

    Hello everyone!

    I apologise for the delayed response. Thank you for continuing to report the issue. As mentioned by my colleague Ubi-Woofer earlier in the thread, we are hoping to implement a fix in an upcoming update. At the moment, we have no further information to share regarding an ETA for this, but please rest assured that this information will be shared within the forums once we receive an update.

    If you encounter this issue in-game, we recommend that you try the workaround that Ubi-Woofer has shared:

    • Reload the last episode save
    • Progress through the battle again and do not use the teleporters
    • Try again to close the door at the conclusion of the battle

    Thank you for your continued patience and understanding as our team continue to work on this.

    Official Response
  • slashtor00
    7 posts

    Congratulations Ubisoft. 1 MONTH and no resolve. I want my money BACK

    Original poster
     KeyGhostACE 1 posts
    Nov 10, 2020, 5:57 PM

  • nvrsummer540
    3 posts

    @slashtor00 they just had another update that still doesn't resolve this ridiculous bug

  • ARICH78
    1 posts

    I havet the same problem on a ps4 fight or no fight dos not mather. d
    when dos your fix the bug

  • OGHick
    2 posts

    I too am continuing to have issues with closing the door on pS4. I've tried all the solutions I could find online and none of them work. Its not even giving me an option to hit the button to close the door. It just has the quest logo on the door without allowing me to interact. Is there anything I can do to get past this point? All my saves are in Asgard so I'm stuck here

  • charliedynamite
    1 posts

    I had same problem. Finally got past it. What I did was start the mission without fighting anyone. Just run all the way thru it. And do not take the portals. Go straight to the door and close it. It worked for me. Hope this helps.

Suggested Topics