Welcome to discussions

Quick Suggestions

  • 20 Likes/568 Replies/21131 Views
    4 posts

    @ubi-woofer I don't know if this helps, but it happened to me after failing to remain in stealth up to the longhouse. So triggering combat before reaching the longhouse may be a part of the problem?

  • Blayser4148
    5 posts

    @momobeast7 That would explain it, as I just charged through town as well.

    I hear of people going back a save and go stealth instead working for them.

  • MaDerby
    1 posts

    NPCs will not assist in opening the door to the longhouse in Buckingham. Any tips?

  • monte991
    3 posts

    I've managed to get to brewing rebellion without any major problems. But now I've come to the Buckingham longhouse and can't force open doors as sigurd has disappeared. I've uninstall the game and reinstalled still nothing has worked anyone else have the same problem and managed to fix it let me know please?

    9 posts

    I ended up loading an old save. It was about 10 hours of play time old. I was able to catch up to where I was in about 4 hours. Skipped all the cutscenes and left behind a few side stuff that I havent redone yet. But I was able to get into the longhouse door by staying in stealth. Really put a damper on the amazing experience I’ve been having. I hope Ubisoft compensates it’s players with waisting our time. Some helix credits would be nice. I love Ubisoft games and assassins creed especially. I’m sure having a system launch deadline and making it run smoothly on 7 different machines (PC, Xbox one, Xbox one x, Xbox series X/S, PS4, PS4 pro, and PS5) was difficult.

  • Zaanickster123
    6 posts

    @lucaboccia i've just started same bro, went back 10 hours. I have to do asgard again but i loved that whole part so i'all happily repeat it haha

  • Zaanickster123
    6 posts

    @zaanickster123 update - guys I bit the bullet and loaded an old save game...but i did the mission stealthily and it worked!

  • WitherTDM
    2 posts

    Is anyone else not even able to speak to Sigurd after learning he's in the little fishing hut? Every time I go in nothing happens. I just see Sigurd standing around. I can't do anything. I'm on PC if that helps.
    Here's a video of what's going on

  • Corbae
    12 posts

    So this issue has been around for almost a week. Still is not on the known issues page and for days no response at all from ubisoft. The only response now is that they can't reproduce it, so they just basically said we are bad at our jobs. People already sent in their saved game files to support I did four days ago. I normally do not complain about bugs, sure they happen in all games, but at least we want decent feed back from the community managers and from the devs trying to fix their broken game. Doesn't ubisoft offer refunds on digital products for two weeks? I think I might refund and just come back when it works and is on sale.

  • Momobeast7
    4 posts

    @lucaboccia If there isn't any progress on a fix by tomorrow morning I'll probably do the same. It sucks because I've been sidequesting and hunting/fishing/upgrading while I wait so I'll lose all that, but it doesn't look like there's gonna be a fix any time soon. I just wanna progress in the game at this point, cuz I was really enjoying it!

  • exoculare
    1 posts

    I HAVE THE FASTEST FIX!!!!!!, as you guys might know....that you can just let one of the guards kill you and hit triangle for the auto save list, that way you don’t have to go back as far. i did that and was able to get back to the lady in the ale house. from their i used stealth the entire way to the door and then Hasim finally helped me open the door and i got the cutscene!!! NO NEED TO GO BACK HOURS OF GAMETIME!!!!

  • Schottgun006
    7 posts

    @ubi-woofer I think myself and many others are looking for a refund ASAP. Pre ordered game, 30 hours in and haven't gotten anywhere in the game in what?...about a week now? Because of a systematic flaw on the Ubisoft end? This is an issue across all platforms. This is unacceptable.

  • Jasette
    27 posts

    @exoculare dude a lot of us have progressed way past getting stuck (on other pledges/quests) so we are completely unable to go back to the last quest objective. I’ve played over 20 hours I think since I ran into this bug 😂 thankfully there was other stuff to do! But that means we don’t have this easy “fix.”

    @ubi-woofer it sounds like some have already sent their save files. If this isn’t fixed in a couple of days I’ll figure out how to do that with my ps4, too 😂 sorry your game is so freakin buggy. Must be v stressful for y’all right now...

  • Jasette
    27 posts
    This post is deleted!
  • megadeth1a
    2 posts

    Yep have the same bug have to go back and do hours worth of stuff again and see if it works. Probably not. This is some game breaking stuff. Shame on ubisoft.

  • AaronCochrane
    1 posts

    At the start of the quest i'm instructed to find Sigurd in the Alehouse, but upon arriving he isnt there. Once realisng this i'm then instructed to ask around the tavern to see if anyone knows Sigurds whereabouts. This is where the issue lies as when i went to do this the speak command doesn't appear meaning i'm unable to speak to the npc's to further progrress the quest. I've already tried relaoding an older save to no avail, i've also tried activating another arc and going back to the previous one also to no avail and i've tried interacting with other npc's in the area and returing to the tavern afterwards again to no avail. Could i please get some advise on what to do next. Thanks

  • linxin2014
    2 posts

    After meeting Sigurd at the pub can't be in the fish shed trigger the plot

  • Sword_Gas
    11 posts

    @ubi-woofer but i cant upload a file of '.save' type on the support case page

  • WiggleWorm57
    1 posts

    Can’t get passed the level and it won’t let me go any further

  • Dragonkilla802
    1 posts

    Mission is broken and not finishing. Sigurd and Basim just stand there when trying to force the door open for the Buckingham longhouse.

Suggested Topics