Welcome to discussions

Quick Suggestions

  • Peronella
    5 posts

    @ubiwan I just followed the steps in the FAQ and I keep having the same issue.

    The first few times the bug appeared I didn't fast travelled or start a different mission in-between. I followed the logical order of events. The only 'strange' thing is that I didn't managed to keep the low profile and had to kill several poor enemies, but nothing else. When I approached the Buckingham longhouse, it popped the 'try to force the door open' message and then I tried and didn't work. Then I stepped back a little and the short dialog between Eivor and Sigurd started, which made me think that it was an only time bug, but it appeared again, and again, and again. So I'd tried different things (starting a new mission, killing all the enemies, going away and then coming back, burning the longhouse down, ...) but none of them worked.. And here we are.

  • monte991
    3 posts

    Brewing rebellion stuck sigurd has disappeared and can no longer progress

  • monte991
    3 posts
    This post is deleted!
  • Momobeast7
    4 posts

    @ubi-woofer Thank you!

  • Ubi-Wan
    Ubisoft Support Staff 631 posts

    @peronella Understood! Thanks for giving all those steps a try, I really appreciate how proactive you are! I'll be forwarding your video and information up to the team. For now, please stay tuned here on the dedicated thread we have for this issue, as it's still under investigation by the team!

    Official Response
  • Blayser4148
    5 posts

    @halaloya Thank you for taking your time to get back to us, really appreciate it.

  • Schottgun006
    7 posts

    @ubi-woofer so you told @Corbae that you wont refund a defective product? Sketch....🤔

  • droopysplay
    1 posts

    @ubiwan i have the same problem on PC i loaded a previous game, doing another mission and desynchronized Eivor, multiple times. Same problem, over and over again.

  • Corbae
    12 posts

    @ubiwan Why do a lot of the messages from Ubi in this thread read like you are implying this is on the players and it is on us to figure out how to make your broken game work.

    The question about whether he was raiding or not at the time of the bug is completely ridiculous as you CANNOT raid this town, blowing your horn does nothing. Don't try to help us trouble shoot if you know nothing about this quest or the game in general. It make you look bad and waste our time.

  • OmgItzZ3R0
    3 posts

    7 Days since the thread was posted and it is JUST NOW BEING INVESTIGATED???????? Ubisoft cmon, I feel like this is a elaborate scam to keep me subscribed to the UBI pass just to finish this game. This quest is literally gamebreaking on literally every single platform. PC, XBOX, PS, doesn't matter everyone is getting shafted. This is absolutely unacceptable out of a AAA title game, are we going to have to wait a month for a patch like some kind of early access indie game? I can only imagine how frustrated the people who actually paid $60+ for this game must feel. The AI is so clunky I had to literally burn the boat Hytham was standing on to progress in that quest. Going on a week without touching the game because I can't progress.

  • Sword_Gas
    11 posts

    @ubi-woofer save submitted. case number 13242018.

  • TheFlash0412019
    18 posts

    I'm not just stuck with the doors not opening I can't even speak to Reda either there has been multiple reports of both issues yet no update. Ubisoft devs apparently know about both issues but are only focused on the seers solace's mission which there are more people stuck on the Brewing Rebellion mission yet nothing kinda ridiculous especially for people trying to follow the story as close as possible.

  • wofpawel
    14 posts

    @omgitzz3r0 +1 - I Totally agree. Never again Pre-order Ubi game.

  • linxin2014
    2 posts

    Brewing uprising can't In the map display After meeting Sigurd at the pub can't be in the fish shed trigger continue the mission
    Don't want to go back ,Because I've been playing for too long

  • eremista
    5 posts

    @ubiwan nothing work....

  • Snowblind5596
    2 posts

    So its Nov 20th when im posting this. I just dealt with this problem for about an hour. I went to the main load screen and tried each autosave load and eventually one worked to where sigurd was standing next to me at the side door to force it open and play the cutscene

  • Snowblind5596
    2 posts

    So its Nov 20th when im posting this. Just ran through this same issue for almost 2 hours. I started loading each autosave slot and one magically worked to where sigurd was standing next to me to bash open the side door and start the cutscene. Hope this helps

  • GoDs.cl
    2 posts

    I have the same bug in this quest. So I tried to lure these guys to the longhouse with enemies. When they finally arrived, they did nothing. Then I tried burning the roof of the longhouse to see if anything happens, they decided to take a trip, waaaayy away from the objective. I have these ss to show you, and a video (but it has anime music so I can't upload it to YT unless I mute it).

  • Peronella
    5 posts

    So yesterday I was finally able to "avoid" the bug. It wasn't a painless solution, I warn you.

    After several hours of trying everything (restarting the mission, killing them all, burning down the longhouse,..), even with the inestimable help of @UbiWan (thanks again), I just gave up and started other missions, mysteries, etc. BUT I just kept feeling uncomfortable and something told me that I needed to restart once again. That is why I came back to the previous mission, the Londen final, finished it and then restarted the Brewing Rebellion mission again. YES, this erased hours of game, and it was heartbreaking, but also worth it. Here's what I did differently this time:

    1. I didn't had any more missions going on at the same time, besides those which are inevitable, you know. I finished everything I could before starting BR.
    2. I didn't kill any enemy before arriving to the longhouse: low profile all the time.
    3. I waited for every animation to finish. When I approached the Buckingham longhouse, it popped the 'try to force the door open' message up and then I waited (without touching anything or even moving) for Sigurd and Eivor to finish their dialog and then for Sigurd to make his move of asking for help, etc. I didn't do any of those things the first time: I tried to open the door right away I arrived to the longhouse.

    I lost several hours of game, but at least now I can go on with the rest of the story. I hope this is helpful for you!

  • Jmdattoma
    6 posts

    This is a bigger embarrassment than the face melting glitch in Unity. I think we should all take some time and just ponder what the hell we've been going through for the last week and a half.

    I MYSELF ran into this problem day 1. Had reset my saves but to no avail. I said, you know what? Im NOT WORRIED! Ubisoft will have this covered in the next 2-3 days TOPS. So i went out pledging to every other place possible. I collected all the abilities, carbon ingots, and sync points. I even killed most of the order! I came back checking this forum 10 times a day, day after day... after day... after day. To find absolutely jack from one of the most prestigious and funded game companies in the world! NO WAY am I starting over and giving up all that I've got.

    I EVEN KNOW HOW TO GET INTO THE LONGHOUSE. You can use level 2 of the dive of the valkyries to break barred doors to get in. But it doesnt matter if there is no mission objective to go to. I am actually getting second hand embarrassment for the devs in this chat because I think we all know deep down that they either don't know how to fix it, or just dont care. We have sent in clips, game files, and everything we can to help these people who half the time dont even respond. The magic in alot of us has died as we are now completely no longer immersed in what once was a good game.

    People wanted to play this game to escape from the hell hole of 2020. This was supposed to be the turning point. It seems not even the small stuff can go well nowadays.

Suggested Topics

Community Details