Welcome to discussions

Quick Suggestions

  • TheFlash0412019
    18 posts

    I'm not just stuck with the doors not opening I can't even speak to Reda either there has been multiple reports of both issues yet no update. Ubisoft devs apparently know about both issues but are only focused on the seers solace's mission which there are more people stuck on the Brewing Rebellion mission yet nothing kinda ridiculous especially for people trying to follow the story as close as possible.

  • wofpawel
    14 posts

    @omgitzz3r0 +1 - I Totally agree. Never again Pre-order Ubi game.

  • linxin2014
    2 posts

    Brewing uprising can't In the map display After meeting Sigurd at the pub can't be in the fish shed trigger continue the mission
    Don't want to go back ,Because I've been playing for too long

  • eremista
    5 posts

    @ubiwan nothing work....

  • Snowblind5596
    2 posts

    So its Nov 20th when im posting this. I just dealt with this problem for about an hour. I went to the main load screen and tried each autosave load and eventually one worked to where sigurd was standing next to me at the side door to force it open and play the cutscene

  • Snowblind5596
    2 posts

    So its Nov 20th when im posting this. Just ran through this same issue for almost 2 hours. I started loading each autosave slot and one magically worked to where sigurd was standing next to me to bash open the side door and start the cutscene. Hope this helps

  • GoDs.cl
    2 posts

    I have the same bug in this quest. So I tried to lure these guys to the longhouse with enemies. When they finally arrived, they did nothing. Then I tried burning the roof of the longhouse to see if anything happens, they decided to take a trip, waaaayy away from the objective. I have these ss to show you, and a video (but it has anime music so I can't upload it to YT unless I mute it).

  • Peronella
    5 posts

    So yesterday I was finally able to "avoid" the bug. It wasn't a painless solution, I warn you.

    After several hours of trying everything (restarting the mission, killing them all, burning down the longhouse,..), even with the inestimable help of @UbiWan (thanks again), I just gave up and started other missions, mysteries, etc. BUT I just kept feeling uncomfortable and something told me that I needed to restart once again. That is why I came back to the previous mission, the Londen final, finished it and then restarted the Brewing Rebellion mission again. YES, this erased hours of game, and it was heartbreaking, but also worth it. Here's what I did differently this time:

    1. I didn't had any more missions going on at the same time, besides those which are inevitable, you know. I finished everything I could before starting BR.
    2. I didn't kill any enemy before arriving to the longhouse: low profile all the time.
    3. I waited for every animation to finish. When I approached the Buckingham longhouse, it popped the 'try to force the door open' message up and then I waited (without touching anything or even moving) for Sigurd and Eivor to finish their dialog and then for Sigurd to make his move of asking for help, etc. I didn't do any of those things the first time: I tried to open the door right away I arrived to the longhouse.

    I lost several hours of game, but at least now I can go on with the rest of the story. I hope this is helpful for you!

  • Jmdattoma
    6 posts

    This is a bigger embarrassment than the face melting glitch in Unity. I think we should all take some time and just ponder what the hell we've been going through for the last week and a half.

    I MYSELF ran into this problem day 1. Had reset my saves but to no avail. I said, you know what? Im NOT WORRIED! Ubisoft will have this covered in the next 2-3 days TOPS. So i went out pledging to every other place possible. I collected all the abilities, carbon ingots, and sync points. I even killed most of the order! I came back checking this forum 10 times a day, day after day... after day... after day. To find absolutely jack from one of the most prestigious and funded game companies in the world! NO WAY am I starting over and giving up all that I've got.

    I EVEN KNOW HOW TO GET INTO THE LONGHOUSE. You can use level 2 of the dive of the valkyries to break barred doors to get in. But it doesnt matter if there is no mission objective to go to. I am actually getting second hand embarrassment for the devs in this chat because I think we all know deep down that they either don't know how to fix it, or just dont care. We have sent in clips, game files, and everything we can to help these people who half the time dont even respond. The magic in alot of us has died as we are now completely no longer immersed in what once was a good game.

    People wanted to play this game to escape from the hell hole of 2020. This was supposed to be the turning point. It seems not even the small stuff can go well nowadays.

  • guest-bnpX850F
    5 posts

    @jmdattoma amen to that. My sentiments exactly.
    How is this still a problem?
    In a year where all disappointed by TLOU2 at least that game was playable. SMH

  • Jasette
    27 posts

    @ubi-woofer I just submitted a ticket with a couple of recent saves. I hope this helps enough to get it fixed soon u__u

  • Ubi-Woofer
    Ubisoft Support Staff 1268 posts

    Hello everyone,

    I do apologise that some of the conversations within this thread have become a little disjointed - this is due to a thread merge I performed yesterday. Please rest assured that the investigation into this issue has not only just started - the thread I merged was just a little older, so the messages referred to our progress a few days ago.

    @Sword_Gas Thank you for submitting your save files and those screenshots! I've uploaded the .zip folder to the devs' investigation for review now.

    @Peronella I am sorry to hear that you lost so much progress when reloading a previous save, but it is really great to hear that you found a workaround and have been able to progress since. Thank you for sharing it here in the thread as well, it may well help other players with the issue in the meantime while the devs are investigating.

    @Jmdattoma We are actively investigating this issue and hope to share an update soon. I am sorry to hear that you have been experiencing it for so long, and would like to reassure you that it is being taken seriously. 🙂

    @Jasette I will go to your case right away and submit those to the devs, thank you! 😄

    Official Response
  • Ubi-Swaggins
    Community Manager 430 posts

    @aaroncochrane I'm sorry to hear that you cannot proceed in this quest.

    Can you provide a video of this issue in action, so we can pass it to the team for investigation?

    Official Response
  • wofpawel
    14 posts

    I'm wondering how long it will take...
    I'm unable to progress science one week.

    Ubisoft, any update on this case?

  • Halaloya.
    12 posts

    @wofpawel i hope within this week.
    I literally stopped playing. Nothing to do. Finished all quests up to this point, killed all drengrs all legendary animals etc...

  • Cameron_Swagger
    2 posts

    @zaanickster123 same lol i put 20 more hours in, i aint restarting tthat.

  • guest-MVCx30S2
    1 posts

    Seems to be having the same issue as everyone else on brewing rebellion when it comes to forcing the door open on the long house, Sigurd and hythem just watch, tried everything to re set it from starting new quests, pledging to different areas, getting rid of all enemies in the area and trying to open the door completely undetected, nothing seems to work.

    im now at a stage where I can’t continue the story and complete other areas of the map unless I complete this mission so UBISOFT! pleaseeee get this resolved soon because I’m absolutely loving this game!

    thank you!

  • SCG.Qrampage
    2 posts

    Still waiting for the brewing rebellion to be fix.Ubisoft should just implement restart mission from the beginning option because i’ve been waiting since the first week it came out. 86 hrs in i got excalibur killed most of the order that i can without the story killed legendary animals all the other alliance missions literally can’t do much else i’ve even killed the witches of delarian or however you spell it. Can’t advance in the story please fix soon or give me a refund

    4 posts

    Same problem here, my previous save game is 30h before. I’m stocked with the mission.

    4 posts
    This post is deleted!

Suggested Topics