Welcome to discussions

Quick Suggestions

  • Bensley_III
    1 posts

    The mission brewing rebellion. The alliance of Oxenfordshire. Meet up with Sigurd and Basim. After going to the bar to find them, tracking them to a fishing house, you then have to go to the longhouse. Here is where the bugs start.

    I have aggro'd enemies on my way to the longhouse. Sigurd and Basim will not move, unless there is an enemy to attack. After combat, they stay still. The quest marker does not appear in Buckingham, even though it is marked. I can go to the longhouse, hold 'Y' to begin force door animation, and no ally comes to help. Sigurd and Basim will not move. 

    I've gone into as much detail as possible because the dumb tools who act as support staff in your forums cannot be bothered to read a thread before asking stupid questions.

    Sincerely, for the love of God please fix this. I'm 70 hours in and I will not start again. Your potentially 10/10 game is ruined by game breaking bugs. 

  • yeti4life
    14 posts

    yep still not showing up as an available quest... how can you guys be such [censored] ups.... you fix all this bs and you leave a game [censored] bug... [censored] you seriously going to try and get my money back you guys are a bunch of [censored]. The least you could have done is acknowledge this is problem.

  • yeti4life
    14 posts

    @ubiexcellent

    its been 2 weeks since you have responded this is ridiculous, see what your customers are saying... this is bs you guys are failing us on a daily basis. Especially since you just released a patch with a bunch of BS fixes that dont help anyone cuz were stuck on this dam mission. Screw you do your dam job

  • buschlight_24
    3 posts

    I am also having the same problem but they are at the long house and will not help force open the door. Like you said I am far into the game and will not restart.

  • OberstSlayer
    1 posts

    Same Problem for me since weeks.
    I was hoping 1.04 Patch would fix it but it didn't.

  • henrier
    1 posts

    BUG STILL NOT FIX
    STUCK FOR A WEEK

  • LittleLenny6108
    2 posts

    same for me
    in the beginning i though "i dont care cuz i have so much more to do"

    but now i cant progress anymore

    its rly a shame what ubisoft is doing right now....they know the problem since 2 weeks+
    and its STILL buggy

    yea i love to spent 100€ for a product which didnt works well
    gg ubisoft


    i did not any of those problems in origins or odyssey....problems like couldnt progress the main story

  • Jasette
    27 posts

    Lol I just got the trophy for “we’re in the end game now” and I haven’t even been able to get through this second Sigurd quest 😹😭

    I mean I haven’t been trying to “steal Sigurd’s glory” or whatever but like, dude better freakin step it up. He’s just hanging out in Buckingham itching for a fight while I conquer the world for him 🙄 the longer I wait for him to help me open this dang door the more I don’t really mind the betrayal prophecy 😆

    I'm going to try seeing if I can get a raid to help me open the door after this new patch... will report back.

    EDIT: nope, no one even steps off the boat still. Buckingham is CURSED. Must find cursed object @___@ maybe I’m the cursed object 😭

  • Scoundrel_FM
    1 posts

    I am actually enjoying a ubi game for once but this bug is making it so hard. remeber when they used to polish games and have a decent reputation 😬

  • Corbae
    12 posts

    Six days since a ubi response. Eleven days since ubi updated known issues. This is not a known issue.

  • TylaaS
    1 posts

    i’ve been dealing with this same problem for going on 2 weeks now and i can’t progress any further. i’ve went back to the alliance map did the other missions but this one won’t even pop up. i’m very much looking to finish the game but i’m not able to w the as is version and it’s quite saddening because i love assassins creed, ive played every console game. i just need this fixed. i thought the new patch would fix it and i’ve been watching this thread for a week as well and i thought it had been confirmed for a fix. very disappointed as of right now because i just wanted to do the mission before i go see my family for thanksgiving😕

  • Chento.D
    2 posts

    I have rescued all the thegns but the next quest step won't pop up, it still says I have to rescue them. They followed me everywhere but now only 1 NPC follows me and the other are lost.
    for almost 2 weeks i cant continue the game!!
    The update did nothing!!

  • Carlt0nG
    1 posts

    Completely stuck on world missions now, had this Buckingham Longhouse glitch for over a week now (XBOX One), and now in the Snotitinghamshire Quest line has stopped, the Seer got assaulted by a hog that was chasing me and has died - so although there is a quest marker on her, I can't follow her to her destination. Tried carrying her there in the hope it may have kicked into the dialogue, but still nothing. It's broken. So can't do Oxford or Nottingham quests now, and no more new ones will open up whilst they are pending, so due to the glitches I can no longer continue the game. Time for a refund I think, pity as. the concept and gameplay are great. But can't have a game I can't actually play or progress with. Hoped the patch would help today, but sadly it didn't.

  • cygale
    6 posts

    Do something !
    The only reason I bought this game is because of the cyberpunk report!
    How do I get my money back? 100€ for a beta game...!
    If at least you communicate but it's been 2 weeks and this bug is not even in the known bugs it's unforgivable !

  • RogueCheyne
    2 posts

    Downloaded the patch that said it fixed this, but went into town and they still will not help opening the door.

    What is it going to take for us to have an option to simply redo a quest or something?

  • Kurtiz717
    1 posts

    Same issue here. Longhouse door with no help. Almost 70 hours in, no main line missions left. Getting bored of treasure hunting.

  • Darkcheddar
    3 posts

    Still broken as of patch 1.0.4. The guys just act like guards when not fighting. You can whistle to get them to come investigate the bushes but they are otherwise unresponsive.

  • Schottgun006
    7 posts

    The case I filed on the 13th for this bug has a case status of "ESCALATED" now.

    It is very clear to Ubisoft that this is a serious problem....finally.

    Stay on top of them about this guys. Compensation is mandatory at this point. Also, I'll never pre order a game from Ubi ever again. Facts.

  • tjhg1996
    1 posts
    This post is deleted!
  • begonebihh
    1 posts

    Still bug is not fixed! Now I am just waiting for cyberpunk to release so I can yeet this [censored] game. Tired of Ubisoft. Never going to purchase any of thier product. Why wont these devs just put a [censored] restart [censored] mission in this [censored] game.

Suggested Topics

Community Details

51
Online
193.2k
Users
32.6k
Topics
163.1k
Posts