Welcome to discussions

Quick Suggestions

  • Probably_A_LS
    2 posts

    cant get into buckingham longhouse tried reloading and essentially restarting...please fix

  • Ubi-Woofer
    Ubisoft Support Staff 1152 posts

    @OfficerLego Just as a quick request - if replying to multiple people, please @ them in one post rather than creating individual replies. It also means you don't have to repost the video multiple times to separate people - they'll all just see it under that one reply. At the moment your replies are more in the nature of bumping, which goes against our forum rules, so please try to avoid this!

    @yeti4life I am not ignoring the other posts, not at all! That said however, this megathread was created with the issue with opening the door in mind, as that is the primary issue and the one most players have reported. If you would like to start a separate thread for your issue with obtaining the Brewing Rebellion quest, then we could separately investigate this there - but as it is now, I'm communicating on all issues here. It would be helpful if you could provide a video showing that you are unable to obtain the quest. 🙂

    @oz10w Our investigation is ongoing, but this issue has proven quite complex to pin down. It isn't that nothing is happening - but I do not have a more substantial update for the moment, as the issue has not yet been confirmed as reproduced.

    As an FYI for you all though - I discussed the issue with the community team as I mentioned I would yesterday, and now this issue with Brewing Rebellion is listed under the "issues under investigation" section of the Known Issues List. 🙂 I hope that its inclusion there will reassure you all that we're all doing our best to get this issue nailed down and resolved. Thank you.

    Official Response
  • FluShot99
    2 posts

    @schottgun006 this is ridiculous! I’m not going back and missing the hours of gameplay that I have under my belt. I’m ready for a refund and just be done with the game.

  • Corbae
    12 posts

    @flushot99 They rudely told me I would not get a refund. Just going to uninstall and forget about it. Was excited about this game but a lot of it feels rushed and unfinished not just talking about bugs but just basic gameplay. Shocking they rushed a game out for the holiday season. Looking forward to 2077 and hopefully CDPR lives up to their reputation and releases a polished game, I have no doubts.

  • THATRICHBRIT
    3 posts

    @ubi-woofer
    oh no I won’t be able to play broken Ubisoft games what ever will I do. This is crap, if the workaround had not worked you’d have already heard from my bank. Game devs need to start being held accountable for this. Any other industry including the auto industry and your company would already be facing a lawsuit same with BioWare and EA over anthem. Sooner or later karma is gonna sneak up and bite you much the same way as EA is getting some karma in Europe currently. Quit releasing broken, defective, and sub par products or face gamers / customers wrath’s. I for one won’t be giving you another dime especially after how you guys have handled your latest debacle. To the other gamers reading this sooner we stand up and tell these [censored] how it is the sooner we start getting good games again.

  • Denarchy
    3 posts

    @b_r_e_n_0 Thank you for the video. Unfortunately, I've already passed that point in the game and completed the world event with the annoying poet woman (Gleewoman). I'm about 120 hours in, and basically only have the main story left to complete.

  • yeti4life
    14 posts

    @ubi-woofer

    bro the whole quest is broken what do you mean just because someone was bored enough to come up with a workaround doesnt mean the whole quest isnt broken...

  • DDawson._
    3 posts

    Sigurd and Basim do not move and don't help you force open the door to the longhouse. I've had this glitch since launch and have not been able to progress through the main story since.

  • EsotericBook404
    1 posts

    Why can’t I get into buckingham longhouse with Sigurd in the mission “Brewing Rebellion”??? Can someone help me???

  • jrod614
    3 posts

    @jrod614 i guess ubisoft doesn't care because I still can't open the damn doors. This game was one of my favorite games until now. So many glitch in this game

  • jrod614
    3 posts

    @blackwidowsport doesn't seem like ubisoft cares i been stuck in the same spot for 2 weeks now. Those damn doors won't open. A ton of glitches in a game that was so great to this point

  • OfficerLego
    13 posts

    @jon-wileman I created a video on how to work around it. its worked for like 98% of the people who have watched it on multiple platforms.

  • ChickieRULES
    2 posts

    @gorechi Worked for me! There's also a youtube video to help walk you through this. I recommend manual saving all throughout just for security!

  • OmgItzZ3R0
    3 posts

    @gorechi shout out to you for being more useful than the entire Valhalla team. Ubisoft should send you a free copy of the game and then some. Finally able to progress! Ubisoft you should be absolutely ashamed, over a month and still no official fix. Stop releasing half finished games and making the community play test it.

  • yeti4life
    14 posts

    Still waiting with no dam quest marker to even start this mission!!!! this is rediculous

  • LieutenantTR0LL
    1 posts

    I am at the end of chapter 1 where I am being told to report back to Geadric, but when I go to him I cannot interact or talk to him. I am unable to progress any more on the game.

  • DingusBopper
    4 posts

    @gorechi
    Holy [censored] this actually worked. You're a savior.

  • Jon-wileman
    3 posts

    @officerlego

    Your workaround is epic, no doubt about it.

    However, I had already completed this side mission some 30 hrs ago.

    I've been wandering around like an angry Ronin for some time. The fact that these little hacks exist is a testament to the community, but also a big turd on the desk of Ubisoft that this has to be done.

    Three weeks and no chance of a refund. This is a defective, not as advertised product with an amazing community. A lesser franchise (Anthem) would have sunk!

  • Jon-wileman
    3 posts
    This post is deleted!
  • findnitai1988
    1 posts

    @officerlego This worked for me on PC. Thanks!!

Suggested Topics

Community Details

109
Online
217.6k
Users
36.7k
Topics
182.2k
Posts