ubisoft discussions


  • locked topic_solved [RESOLVED] Unable to progress with "Brewing Rebellion" | POST HERE

    20 likes/595 replies/25191 views
    ubisoft:x-posts, 8

    @guest-fv7wnlsf this [censored] sucks man I feel you I keep going back with false hope knowing it’s not gonna work Sigurd and basim aren’t even there anymore there’s no quest marker it’s just broken as all [censored] I’ve been doing all the other [censored] that I can do but I know I’m gonna get to the point where I need to do that quest and am gonna just be like ok welp [censored] me

  • Zaanickster123
    ubisoft:x-posts, 6

  • OmgItzZ3R0
    ubisoft:x-posts, 3

    Same issue here, over 30 hours in I absolutely refuse to restart. Come on Ubisoft this is a AAA game, you can't have issues like this and expect people to wait 5+ days for a fix. We need a patch asap! I have stopped playing entirely.

  • Schottgun006
    ubisoft:x-posts, 7

    I'm ready for a refund. I've been waiting for this to get fixed for days like everyone else. Ticket in and everything. Screw this!

  • Jasette
    ubisoft:x-posts, 27

    @jasette FYI I tried using the horn but it didn’t help at all. It just drew all the guards to me

    ubisoft:x-posts, 9

    I would have [censored] Sigurds wife if I knew he was going to [censored] me like this lol

  • Jasette
    ubisoft:x-posts, 27

    @lucaboccia honestly same! Here I was trying to not betray him and he literally stands and whistles next to me while I jump at the door by myself for 30mins. wish I could have brought Randvi instead for this political negotiation 🙄 she wouldn’t leave me hanging like this

  • Ciaossu-
    ubisoft:x-posts, 29

    Tried searching threads about this but mine is i cannot talk to the NPC. any work around?

  • Cameron_Swagger
    ubisoft:x-posts, 2

    i got this as well its so [censored] bs.

  • gustaaaav
    ubisoft:x-posts, 3

    I have the exact same glitch but worse. I managed to get the guards inside to break the door open and it completely hit the fan. Because I free'd the hostage, whenever he kills anyone now they're dead but it still gives you the ability to assassinate them. The guards have basically turned to ragdolls. He only follows Sigurd and even though I free'd him I still have to break into the longhouse. Please fix this.

  • gustaaaav
    ubisoft:x-posts, 3

    What I play on: Xbox One
    Time: 36 Hours play time (Been a minimum of 10 hours since I first encountered this glitch, so there's not a chance of me wiping my progress)

    Basically, during the Brewing Rebellion quest you have to complete as a part of the main story line, I've run into a glitch which won't let me progress any further. I have an option to force open the longhouse door but Sigurd of Hytham won't come over and help me open the door. I spent an hour trying to glitch into the longhouse, which I did in which the guards opened the barricaded door for me, but that's caused even more problems now such as ragdoll guards. I freed the prisoner you have to free and it still won't progress. He kills guards, along with Hytham and Sigurd but he won't move. I've seen countless threads made about this already but all of them just ask: 'Can you please send in a video of your problem', where people do and yet there's still no response. I took the liberty of recording two of the problems I've encountered already. Please at least inform me how long it'll take before I can continue with the main story line.

    You can see in one of the videos even though I try to force the door open they won't move. You can also see they just stay still.

  • MortisEntreri
    ubisoft:x-posts, 1

    Reporting the same bug stuck on that door UBISOFT do Your thing and fix it

  • Blayser4148
    ubisoft:x-posts, 5

    Yeah this quest is bugged, I've been in contact with Customer Support twice about it and provided a video link and a saved game file where it happens.

  • Rozil1801
    ubisoft:x-posts, 2

    I have some new information. I heard on reddit that you could open barred doors by using rank 2 dive of the valkyries on the door, so that it would break the lock with the big AoE. I did this and I managed to get into the longhouse. However it did not trigger a cinematic, there were a few enemies in there aswell as an enemy that doesn't die, think quest npc's in Skyrim. I hope I didn't break the quest further. I am still stuck.

  • wofpawel
    ubisoft:x-posts, 14

    Back from work and i see there is no Ubisoft respone on this...
    Never again ubisoft game on pre order. I'm close to sell this game...

  • Blayser4148
    ubisoft:x-posts, 5

    @rozil1801 Haha yeah I just did that and burned down everything, doesn't help one bit tho. He just walks around inside the Longhouse while it's burning xD

    Problem appears to be that the objective is simply gone.

    If we just had a reset mission option this wouldn't even be an issue 😞
    I've been stuck on this mission since Saturday...

  • Hagemaru4
    ubisoft:x-posts, 1

    I'm trying to enter Buckingham's longhouse but I can't. My character tries to force open the door while Sigurd and Hytham just watch.

  • wofpawel
    ubisoft:x-posts, 14

    There is a whole topic about that. Alot of people have this problem. We are still waiting for ubisoft respone


  • Ubi-MrM
    Ubisoft Support Staff ubisoft:x-posts, 4195

    Hello everyone,

    Thank you for continuing to report this issue with "Brewing Rebellion" to us. I've merged as many threads as I could find for the issue into this megathread, so that we can hopefully now keep the provision of new information, workarounds and videos in one place. I do apologise if any conversations have been interrupted or become disjointed as a result!

    I'd like to confirm that this issue has been reported to the devs, and we've provided them with several videos from this thread as well as submitted support cases. So far they have not managed to reproduce the issue, but their investigation still continues, so please don't worry.

    As soon as we receive any further information, or if there is any information we need to request of yourselves, we will let you know. One request from myself would be if any players on PS4 or PC could submit their save files to us via a support case, so that we can pass these on as well, and quote the number here so I can find them and pass them on. Thank you to anyone who takes the time to submit those.

  • Blayser4148
    ubisoft:x-posts, 5

    "I'd like to confirm that this issue has been reported to the devs, and we've provided them with several videos from this thread as well as submitted support cases. So far they have not managed to reproduce the issue, but their investigation still continues, so please don't worry."

    Just use the save I submitted and you have your issue.

Suggested Topics