Welcome to discussions

Quick Suggestions

  • Schottgun006
    7 posts

    @ubi-woofer I think myself and many others are looking for a refund ASAP. Pre ordered game, 30 hours in and haven't gotten anywhere in the game in what?...about a week now? Because of a systematic flaw on the Ubisoft end? This is an issue across all platforms. This is unacceptable.

  • Ubi-Borealis
    Ubisoft Support Staff 2812 posts
    Best Answer

    Hello there!
     
    I'd like to reach out to you all with an update. I'm happy to announce that the development team intend to deploy a several fixes for "Brewing Rebellion" in TU 1.2.2. This update will be deployed 15 June, 2021 at 2 PM CEST / 8 AM ET. The list of fixes includes the following:

    • The door to the longhouse in Buckingham cannot be forced open
    • Quest NPCs, such as Basim and Sigurd, cannot be interacted with
    • The Thegns are not registered as rescued after they are freed
    • Objective marker appears off-map during the "escort the thegns to safety" objective
    • "Secure the Longhouse" is not marked as completed

     
    If you are still encountering issues with "Brewing Rebellion" following TU 1.2.2, please don't hesitate to update this thread so we can take a closer look. Please include a video that shows the following:

    • You have the latest Title Update installed on your platform. You can view this information in the opening game menu in the bottom right-hand corner.
    • The issue you're experiencing in-game following this update.

     
    Additionally, please ensure that you have an up-to-date save uploaded to the cloud. We can then pass these reports to the development team for further investigation.
     
    Thank you! 😊

    Official Response
  • Jasette
    27 posts

    @exoculare dude a lot of us have progressed way past getting stuck (on other pledges/quests) so we are completely unable to go back to the last quest objective. I’ve played over 20 hours I think since I ran into this bug 😂 thankfully there was other stuff to do! But that means we don’t have this easy “fix.”

    @ubi-woofer it sounds like some have already sent their save files. If this isn’t fixed in a couple of days I’ll figure out how to do that with my ps4, too 😂 sorry your game is so freakin buggy. Must be v stressful for y’all right now...


  • Jasette
    27 posts
    This post is deleted!
  • megadeth1a
    2 posts

    Yep have the same bug have to go back and do hours worth of stuff again and see if it works. Probably not. This is some game breaking stuff. Shame on ubisoft.

  • AaronCochrane
    1 posts

    At the start of the quest i'm instructed to find Sigurd in the Alehouse, but upon arriving he isnt there. Once realisng this i'm then instructed to ask around the tavern to see if anyone knows Sigurds whereabouts. This is where the issue lies as when i went to do this the speak command doesn't appear meaning i'm unable to speak to the npc's to further progrress the quest. I've already tried relaoding an older save to no avail, i've also tried activating another arc and going back to the previous one also to no avail and i've tried interacting with other npc's in the area and returing to the tavern afterwards again to no avail. Could i please get some advise on what to do next. Thanks

  • linxin2014
    2 posts

    After meeting Sigurd at the pub can't be in the fish shed trigger the plot

  • Sword_Gas
    11 posts

    @ubi-woofer but i cant upload a file of '.save' type on the support case page

  • WiggleWorm57
    1 posts

    Can’t get passed the level and it won’t let me go any further

  • Dragonkilla802
    1 posts

    Mission is broken and not finishing. Sigurd and Basim just stand there when trying to force the door open for the Buckingham longhouse.

  • Halaloya.
    12 posts

    @ubi-woofer hi , any ETA on the patch?

  • Ubi-Wan
    Ubisoft Support Staff 630 posts

    Hey there, Dragonkilla802! Sorry to hear you're running into this issue with 'Brewing Rebellion'. Have you attempted retrying the mission? If so, and the issue persists, please provide us with a clip or video of this issue occurring!

    Official Response
  • Peronella
    5 posts

    I have the exact same problem. Retrying the mission doesn't work, either.

  • Peronella
    5 posts

    @peronella Here's the clip of the issue:

  • Ubi-Wan
    Ubisoft Support Staff 630 posts

    @peronella Thank you so much for that! Can you let me know if you're currently 'raiding' in that clip? (As in, you've called your raiding party with the horn.) Hopefully Sigurd and Basim forgive you for hacking away at them! 😜

    Official Response
  • Peronella
    5 posts

    😂 @ubiwan yes, but the bug had already appeared several times before, so I used 'raiding' as a last resort (that's what you can see in the clip) in order to open the door, but the crew didn't even disembark.

  • Ubi-Woofer
    Ubisoft Support Staff 774 posts

    @Blayser4148 I checked your support case and can see that a member of the Valhalla team forwarded your save file and video from within to the devs already! Thank you for taking the time to send them our way, it really does help and is much appreciated.

    @Momobeast7 Thank you for this insight! Earlier in the thread, Dab_Youre_it did say "Staying close to your allies and not going into combat helped me do it", and both LUCABOCCIA and Zaanickster123 have reported above that staying in stealth after reloading an older save did help them, so you very well may be right. I'll pass this idea onto the devs to see if they can test it both ways (in stealth, and after combat).

    @LUCABOCCIA I'm afraid compensation is not something I can comment on, but should the Valhalla team announce any for any issue, we'll be sure to share this information in the appropriate thread(s). Thanks for sharing that reloading an older save and staying in stealth worked for you as well!

    @Corbae An issue such as this one may be triggered by multiple in-game actions unique to players' individual experiences, so it can be complex to reproduce. The team are trying to do so and we're continually providing them with as much information as we can, so hopefully they'll manage to do so soon. You can find our refund policy here, however if you have played the game already and it is a digital copy, your right to withdraw was waived at the point of accessing the game, so a refund will not be possible.

    @exoculare Thanks for sharing the workaround that worked for you! >> Can anyone else confirm if this works for them? <<

    @Jasette I have seen only Blayser4148 mention submitting their save files here in this thread, and those have been forwarded to the devs already as the agent who handled their support case took care of that. 🙂 I haven't personally been able to forward any additional files as a result. Additional save files are always welcomed for the devs to compare and investigate.

    @Sword_Gas Please compress the files into a .zip folder and then upload that! Thank you for taking the time to do so, it's much appreciated.

    @Halaloya Not just yet I'm afraid. I'll keep you all updated as soon as I learn anything new.

    Official Response
  • gustaaaav
    3 posts

    @ubi-woofer Thank u for doing the work that youre doing. please fix this asap doe

  • Ubi-Wan
    Ubisoft Support Staff 630 posts

    @peronella Gotcha! Thanks for clarifying. I'm interested to see if the troubleshooting steps in this FAQ help get the mission working properly again. (Perhaps restarting could help too!) Should these steps not help in resolving this, I'd like know if you've tried fast traveling away - or perhaps starting/completing an entirely different mission, then coming back to this one?

    Official Response
  • Peronella
    5 posts

    @ubiwan I just followed the steps in the FAQ and I keep having the same issue.

    The first few times the bug appeared I didn't fast travelled or start a different mission in-between. I followed the logical order of events. The only 'strange' thing is that I didn't managed to keep the low profile and had to kill several poor enemies, but nothing else. When I approached the Buckingham longhouse, it popped the 'try to force the door open' message and then I tried and didn't work. Then I stepped back a little and the short dialog between Eivor and Sigurd started, which made me think that it was an only time bug, but it appeared again, and again, and again. So I'd tried different things (starting a new mission, killing all the enemies, going away and then coming back, burning the longhouse down, ...) but none of them worked.. And here we are.

  • monte991
    3 posts

    Brewing rebellion stuck sigurd has disappeared and can no longer progress

Suggested Topics

Community Details

75
Online
139.1k
Users
24.4k
Topics
126.3k
Posts