Welcome to discussions

Quick Suggestions

  • kinghatake12
    1 posts

    ive reloaded saves ive kiilled everyone ive ran away and ran back ive fast traveled ive done litterally everything and cant break the door down this is stopping me from continuing the main story this [censored] takes 2 people to break down a door mechanic is [censored] just like ubisoft

  • Ubi-Borealis
    Ubisoft Support Staff 2812 posts
    Best Answer

    Hello there!
    I'd like to reach out to you all with an update. I'm happy to announce that the development team intend to deploy a several fixes for "Brewing Rebellion" in TU 1.2.2. This update will be deployed 15 June, 2021 at 2 PM CEST / 8 AM ET. The list of fixes includes the following:

    • The door to the longhouse in Buckingham cannot be forced open
    • Quest NPCs, such as Basim and Sigurd, cannot be interacted with
    • The Thegns are not registered as rescued after they are freed
    • Objective marker appears off-map during the "escort the thegns to safety" objective
    • "Secure the Longhouse" is not marked as completed

    If you are still encountering issues with "Brewing Rebellion" following TU 1.2.2, please don't hesitate to update this thread so we can take a closer look. Please include a video that shows the following:

    • You have the latest Title Update installed on your platform. You can view this information in the opening game menu in the bottom right-hand corner.
    • The issue you're experiencing in-game following this update.

    Additionally, please ensure that you have an up-to-date save uploaded to the cloud. We can then pass these reports to the development team for further investigation.
    Thank you! 😊

    Official Response
  • lxndr_albert
    1 posts

    Same here, it's super annoying and I've tired literally everything, without any luck so far.

  • ashtg133
    3 posts

    I have this same issue aswell

  • UbiExcellent
    Ubisoft Support Staff 756 posts

    @ashtg133 Hey everyone! We haven't received any reports about this issue before. Would any of you be able to send over a video of this happening, so I can get that over to our teams to be evaluated further please?

    Official Response
  • guest-9r9B9wOF
    6 posts
    • @ubiexcellent @UbiExcellent Hi, in regards to the AC Valhalla bug in Brewing Rebellion. I have a videorecording of Eivor pushing the door and not Sigurd nor Basim come to help me open the door to the Longhouse in Buckingham. Where do i need to send the video?
    • Regards J

  • ashtg133
    3 posts

    Is there any fix to this yet

  • moko789
    1 posts

    I have exactly the same problem on pc. Thanks in advanced for fixing it.

    1 posts

    Hi, I’m stuck in a main mission where 4 NPCs were rescued from a camp, but it doesn’t trigger the end of that quest and the NPCs are following me everywhere I go.

    below a footage of the problem:
    System Xbox one X

    thank you

  • Halaloya.
    12 posts

    @ubiexcellent how can we send the video??

  • Halaloya.
    12 posts


    i think through an email but they need to provide you one.

  • FrostiK-rus
    5 posts

    How the hell every other topic on the forums are game breaking bugs... did you actually test the game before release?
    The AI (Sigurd and Basim) are not reacting to the doors of the longhouse. They are agroing the enemies but not proceeding with the quest

  • slynjegare
    1 posts

    can't progress or continue the quest a brewing rebellion, the part reach Buckingham's longhouse can't be done due to sigurd being bugged and not doing anything just standing still and not helping with the door, just hade to reset the game 4hrs yesterday due to another bug but it seems to reset this quest i need to reset the whole game, and with 38hrs put into it i don't really think i can do it, any help would be appreciated

  • Halaloya.
    12 posts

    @ubiexcellent i have a video of it, how can i send it to you?

  • Halaloya.
    12 posts

    @frostik-rus i just found them in the middle of Buckingham but they are just standing not following me or reacting to anything

  • MadsSpring
    1 posts

    @blackwidowsport i also have this problem, did you find a solution

  • RobinMossing
    1 posts

    Just reload the quicksave and it is fixed

  • elfkicker666
    3 posts

    @ashtg133 I am having the same issue on my xbox one. Companions are right next to door, but not helping me force the door open when I push the button. I've tried reloading older saves, but am still having this issue! A real shame as I'd like to continue the game.

  • valkurd
    2 posts

    Same here on pc 😕

  • valkurd
    2 posts

    Same here, tried to reload an older save, but it didn't worked.

  • DingusBopper
    4 posts

    also having the same problem, Sigurd and Basim refuse to help me open the door after I've killed everyone in Buckingham

    edit: on PC

Suggested Topics

Community Details