Welcome to discussions

Quick Suggestions

  • yeti4life
    14 posts

    I just spent an hour too like trying to coax them out of the house and like get them killed to trigger an NPC reaction got them both killed but seemed to just come back to life without me reviving them.. .ive finished all other places within my power range this sucks

  • Ubi-Borealis
    Ubisoft Support Staff 2812 posts
    Best Answer

    Hello there!
     
    I'd like to reach out to you all with an update. I'm happy to announce that the development team intend to deploy a several fixes for "Brewing Rebellion" in TU 1.2.2. This update will be deployed 15 June, 2021 at 2 PM CEST / 8 AM ET. The list of fixes includes the following:

    • The door to the longhouse in Buckingham cannot be forced open
    • Quest NPCs, such as Basim and Sigurd, cannot be interacted with
    • The Thegns are not registered as rescued after they are freed
    • Objective marker appears off-map during the "escort the thegns to safety" objective
    • "Secure the Longhouse" is not marked as completed

     
    If you are still encountering issues with "Brewing Rebellion" following TU 1.2.2, please don't hesitate to update this thread so we can take a closer look. Please include a video that shows the following:

    • You have the latest Title Update installed on your platform. You can view this information in the opening game menu in the bottom right-hand corner.
    • The issue you're experiencing in-game following this update.

     
    Additionally, please ensure that you have an up-to-date save uploaded to the cloud. We can then pass these reports to the development team for further investigation.
     
    Thank you! 😊

    Official Response
  • DMenning5
    2 posts

    THIS STILL HASN’T BEEN FIXED - Worst game ever, weeks have gone by and this main story line game breaking glitch still has not been fixed. I am extremely disappointed in UBISOFT. Who released this god awful game. Obviously all they care about is releasing shiity products and taking people’s money. I have spent over $100 on this game, I bought some cosmetics and extras because I’m an extra person, and now I can’t even play with them in the game anymore due to this bug.

    I’ve come here for the main quests, I’ve played all 12 or 13 Assassins Creed games from start to finish for the main storylines and Valhalla was my beginning to be my favorite! Note I will be blasting my utter disgust in the game through all my social media channels and review sites. This game breaking bug and lack of any type of fix is unacceptable! And my large following will hear about it. This is completely unacceptable as I have seen no action from Ubisoft to fix and with the holidays we will not see one anytime soon. If you did not use stealth in this mission like me you will not be able to progress the story probably until next year when Ubisoft finally fixes their glitch.

    This has broken the game for me, I made no manual save before this mission, I shouldn’t of had to. Now I am [censored]. As a die-hard Assassins Creed fan, believe me I’m a huge fan who is now beyond disappointed in this game and the company and publisher behind it. Their support of ignoring the issue for weeks with no fix is unacceptable. You have lost a long time huge fan, someone who has spent well over $1000 on your games and merchandise over the years. I will now be moving my support somewhere else and letting everyone know.

    Thanks and best wishes
    -Drew Menning

  • wofpawel
    14 posts

    Hahaha, still no fix. Ubisoft, where are You?!

  • guest-Op9FDdUz
    2 posts
    This post is deleted!
  • LittleLenny6108
    2 posts

    after patch it still didnt work
    they still stand there...doing nothing

  • TheFlash0412019
    18 posts

    @littlelenny6108 serious wow that's stupid
    So they fix some stupid thing about fish but haven't fixed an actual main storyline mission (censored) ridiculous

  • wofpawel
    14 posts

    Still the same after patch... this is INSANE!

  • discopants89
    4 posts

    I am so angry at this. I cannot believe they have just left us here rotting and unable to move forward without an update.

    Time to ask for a refund as this is an absolutely miserable excuse for customer service.

    I excitedly downloaded the update, fully sure it would have been fixed. They said in the patch notes quest bugs that were stalling progress would be fixed.

    They are a massive disappointment. I'd be highly surprised if I go near one of their games again.

  • Halaloya.
    12 posts

    @discopants89

    they are on thanksgiving holiday enjoying that big fatty turkey.

  • Snoopdoggyxxl
    3 posts

    Unfortainitly after the update on ps4 the bug is still there. Please fix it, you’re a big companie, minor issue with big concequenses in the game. It’s dissapointing due that the game overall in my experience very nice is.

  • Sword_Gas
    11 posts

    Two more weeks to wait 😬
    Thank you Ubi

  • THATRICHBRIT
    3 posts

    Nah they’ve had two weeks to fix this if they left it as is and went on holiday, then we should get the presents ready guys... start filing for those refunds. Go through your bank not who you purchased through. Only way game developers learn is when you take away their profits. It’s time that we started getting finished working games on launch day again. I mean come on any other industry and these guys would already be in a court room why should game devs be able to create defective broken products yet keep our money?

  • TheFlash0412019
    18 posts

    @sword_gas what do you mean two more weeks

  • herobrine1999
    1 posts

    On this quest I am stuck on the task "Reach Buckingham Longhouse", when I get there there is the prompt to "Force Open" the door, however the AI for both Basim and Sigurd is bugged and they just stand around. From my testing I have founf the following:
    Whistling causes Basim and Sigurd to walk to you
    Being on a horse causes them to follow you
    They will fight any enemies that come over, but then will return to their glitched state

    Now onto things that I have done in an attempt to fix this:
    Travelling back and away
    Meditating
    Using the Horn
    Quitting and reloading
    Exiting the game and reloading
    Dying and Reloading
    Forcing them to move close to the door

    None of the above seemed to have any affect, and my most recent save is around 20 hours in the past, and as such I am not going to go back that far. I have seen that this is a prevalent issue, however it has not shown up on the Known Issues list because it is not "repeatable". To this end I am going to stipulate exactly how this occurred:

    1. Arrived at Buckingham
    2. Walked to the alehouse by crossing the river
    3. Lost 1 round of Orlog, then won the next
    4. Talked to the alewife
    5. Used charisma to get her to tell me where Sigurd was
    6. Crossed the river to get to the fish house
    7. Had the cutscene with Sigurd and Basim play
    8. Crossed the river again and made my way to the longhouse
    9. Remained in stealth until I got to the side door of the longhouse
    10. Killed all nearby enemies

    After this sequence of events the quest became stuck. I hope that this can be resolved, or at the very least be placed onto the known issues list to be resolved soon.

  • buschlight_24
    3 posts

    I have been stuck on the Brewing Rebellion mission for about a week. I can not force open the door Sigurd and the other just stand there and don't come help force open the door. I just keep hitting and hitting it and nothing. Can ubisoft help? Can anyone help? Get frustrated with trying to beat this main guest and can not complete it.

  • guest-bnpX850F
    5 posts

    Tried the 1.0.4 patch this morning.
    Still can't open the door. Quest Icon doesn't show. Sigurd and Basim nowhere to be found.
    #brokengame. BREWING REBELLION IS BROKEN

  • Bensley_III
    1 posts

    The mission brewing rebellion. The alliance of Oxenfordshire. Meet up with Sigurd and Basim. After going to the bar to find them, tracking them to a fishing house, you then have to go to the longhouse. Here is where the bugs start.

    I have aggro'd enemies on my way to the longhouse. Sigurd and Basim will not move, unless there is an enemy to attack. After combat, they stay still. The quest marker does not appear in Buckingham, even though it is marked. I can go to the longhouse, hold 'Y' to begin force door animation, and no ally comes to help. Sigurd and Basim will not move. 

    I've gone into as much detail as possible because the dumb tools who act as support staff in your forums cannot be bothered to read a thread before asking stupid questions.

    Sincerely, for the love of God please fix this. I'm 70 hours in and I will not start again. Your potentially 10/10 game is ruined by game breaking bugs. 

  • yeti4life
    14 posts

    yep still not showing up as an available quest... how can you guys be such [censored] ups.... you fix all this bs and you leave a game [censored] bug... [censored] you seriously going to try and get my money back you guys are a bunch of [censored]. The least you could have done is acknowledge this is problem.

  • yeti4life
    14 posts

    @ubiexcellent

    its been 2 weeks since you have responded this is ridiculous, see what your customers are saying... this is bs you guys are failing us on a daily basis. Especially since you just released a patch with a bunch of BS fixes that dont help anyone cuz were stuck on this dam mission. Screw you do your dam job

Suggested Topics

Community Details

75
Online
139.1k
Users
24.4k
Topics
126.3k
Posts