Welcome to discussions

Quick Suggestions

  • Jasette
    27 posts

    @corbae you have to stop bashing and start again with her next to you once she appears! Or at least I did. Maybe try a few times with her next to you if the first and second don’t work?

    also I spoke too soon on her being my hero, she’s the worst. Why do all the bards in this game suck?? 😭

  • Ubi-Borealis
    Ubisoft Support Staff 2906 posts
    Best Answer

    Hello there!
     
    I'd like to reach out to you all with an update. I'm happy to announce that the development team intend to deploy a several fixes for "Brewing Rebellion" in TU 1.2.2. This update will be deployed 15 June, 2021 at 2 PM CEST / 8 AM ET. The list of fixes includes the following:

    • The door to the longhouse in Buckingham cannot be forced open
    • Quest NPCs, such as Basim and Sigurd, cannot be interacted with
    • The Thegns are not registered as rescued after they are freed
    • Objective marker appears off-map during the "escort the thegns to safety" objective
    • "Secure the Longhouse" is not marked as completed

     
    If you are still encountering issues with "Brewing Rebellion" following TU 1.2.2, please don't hesitate to update this thread so we can take a closer look. Please include a video that shows the following:

    • You have the latest Title Update installed on your platform. You can view this information in the opening game menu in the bottom right-hand corner.
    • The issue you're experiencing in-game following this update.

     
    Additionally, please ensure that you have an up-to-date save uploaded to the cloud. We can then pass these reports to the development team for further investigation.
     
    Thank you! 😊

    Official Response
  • Jasette
    27 posts

    @discopants89 I think it’s really the “force open” door you have to get through, not any other one.

  • guest-fV7wNLSF
    6 posts

    @gorechi i love you! You are officially better than the ubi support team 😂

  • Brutal_Legacy83
    4 posts

    @gorechi Thank you so much!!!!

  • CyanideJay
    2 posts

    I'm running into the same type of problems. I managed to get inside the building, but then everything bugged out. The person to save just stayed there standing staring at the wall as if nothing was going on, and I had one of the enemy NPC's somehow get stuck in the wall where I can't interact with them at all and they became unkillable. I have no idea why or what is going on here, this is just a mess. I don't understand why after so many Assassin's Creed games that have had these exact similar issues in every game, that we don't have a option to drop a quest to completely restart its progress by this point. Here is my exciting screenshot of this mess :

    undefined

  • Sword_Gas
    11 posts
    This post is deleted!
  • RiseXChace
    2 posts

    @gorechi YOU'RE MY FREAKING HERO!!! THIS WORKED!!!

  • iBN__
    10 posts

    @gorechi
    it works, thank you so much.. now go working on the bugged Reda quest 😅 😅

  • Heinricht96
    7 posts

    @ubiexcellent Hi,
    could you give us an update about a possible fix?

    I would also mention that there is no quest marker at all anymore in my case, with the quest selected and the raven doesnt spot anything either. I can currently still play other missions first, but I hope the issue will be adressed as soon as possible 😞

  • Halaloya.
    12 posts

    @gorechi

    i’m speechless, thank you and god bless you.

  • elfkicker666
    3 posts

    @gorechi IT WORKED!!!! I've been stuck here for over 2 weeks. You are a god among men!

  • Johnbhoy1967
    2 posts

    Hey I had this issue and tried so many things to get passed it. Eventually I got it to work because I have autosave on, I could load an autosave that put me right at the door and it seemed that if Sigurd and Basim both went in to anonymous (hoods up) it wouldn't work. I had to be quick as when the save loaded Sigurd would already have his hood up but Basim wouldn't, if i got to the door quick enough and tried to open it basim would help open the door but if i left it too late Basim would put his hood up and not help. I reloaded and tested this a few times and it seems to work everytime if you get it quick enough. I can upload a video if anyone needs further help. Hope this works for everyone else.

  • Schottgun006
    7 posts

    @gorechi ....it worked....you're a damn genius!!!. Ubisoft still owes all of us compensation for this [censored]. And they better hire you now at this point

  • Darkcheddar
    3 posts

    @gorechi BASED AS [censored]!! I didn’t pay the bard. I just freed her and waited for the dialogue to end then fast traveled to buckinghamshire dock. I skirted up and around the long house to the front door and forced it open. She spawns behind you spouting a bunch of nonsense. I had to back out of the force door animation then try again and she helped immediately. Well done man!! Better than waiting another month for a fix.

  • kingdievl
    1 posts

    Can’t continue quest because Sigurd and Basim don’t have weapons and will not help open door they walk around!!!!

  • JonnyIkeCizzle
    2 posts

    @gorechi
    OMG you sir are a saint! Thanks for finding this and letting us know.

  • Dirtymarine7986
    1 posts

    @kingdievl hello I also walk into the fish house and can not speak with them and start the quest thus can not proceed with the storyline.

    V/r Derrick

  • nsbegye
    1 posts

    @gorechi many Valhalla for you man!! You saved my game and my 70 hours invested in the game!! When the bard shows up at the door. DO NOT TALK TO THE BARD. I had to reload a previous save and go through without engaging in conversation outside the long house

  • TheFlash0412019
    18 posts

    @gorechi you my friend are a decendant from Odin thank you for this stupid bug fix I could kiss you my friend idk where your from but thank you sooo much.

  • Snoopdoggyxxl
    3 posts

    Since the update it is still not possible to open the door in the longhouse! Please fix this....!!!!

Suggested Topics

Community Details

65
Online
142.7k
Users
25.2k
Topics
130.8k
Posts