Welcome to discussions

Quick Suggestions

  • DDawson._
    3 posts

    Sigurd and Basim do not move and don't help you force open the door to the longhouse. I've had this glitch since launch and have not been able to progress through the main story since.

  • Ubi-Borealis
    Ubisoft Support Staff 2877 posts
    Best Answer

    Hello there!
     
    I'd like to reach out to you all with an update. I'm happy to announce that the development team intend to deploy a several fixes for "Brewing Rebellion" in TU 1.2.2. This update will be deployed 15 June, 2021 at 2 PM CEST / 8 AM ET. The list of fixes includes the following:

    • The door to the longhouse in Buckingham cannot be forced open
    • Quest NPCs, such as Basim and Sigurd, cannot be interacted with
    • The Thegns are not registered as rescued after they are freed
    • Objective marker appears off-map during the "escort the thegns to safety" objective
    • "Secure the Longhouse" is not marked as completed

     
    If you are still encountering issues with "Brewing Rebellion" following TU 1.2.2, please don't hesitate to update this thread so we can take a closer look. Please include a video that shows the following:

    • You have the latest Title Update installed on your platform. You can view this information in the opening game menu in the bottom right-hand corner.
    • The issue you're experiencing in-game following this update.

     
    Additionally, please ensure that you have an up-to-date save uploaded to the cloud. We can then pass these reports to the development team for further investigation.
     
    Thank you! 😊

    Official Response
  • EsotericBook404
    1 posts

    Why can’t I get into buckingham longhouse with Sigurd in the mission “Brewing Rebellion”??? Can someone help me???

  • jrod614
    3 posts

    @jrod614 i guess ubisoft doesn't care because I still can't open the damn doors. This game was one of my favorite games until now. So many glitch in this game

  • jrod614
    3 posts

    @blackwidowsport doesn't seem like ubisoft cares i been stuck in the same spot for 2 weeks now. Those damn doors won't open. A ton of glitches in a game that was so great to this point

  • OfficerLego
    13 posts

    @jon-wileman I created a video on how to work around it. its worked for like 98% of the people who have watched it on multiple platforms.

  • ChickieRULES
    2 posts

    @gorechi Worked for me! There's also a youtube video to help walk you through this. I recommend manual saving all throughout just for security!

  • OmgItzZ3R0
    3 posts

    @gorechi shout out to you for being more useful than the entire Valhalla team. Ubisoft should send you a free copy of the game and then some. Finally able to progress! Ubisoft you should be absolutely ashamed, over a month and still no official fix. Stop releasing half finished games and making the community play test it.

  • yeti4life
    14 posts

    Still waiting with no dam quest marker to even start this mission!!!! this is rediculous

  • LieutenantTR0LL
    1 posts

    I am at the end of chapter 1 where I am being told to report back to Geadric, but when I go to him I cannot interact or talk to him. I am unable to progress any more on the game.

  • DingusBopper
    4 posts

    @gorechi
    Holy [censored] this actually worked. You're a savior.

  • Jon-wileman
    3 posts

    @officerlego

    Your workaround is epic, no doubt about it.

    However, I had already completed this side mission some 30 hrs ago.

    I've been wandering around like an angry Ronin for some time. The fact that these little hacks exist is a testament to the community, but also a big turd on the desk of Ubisoft that this has to be done.

    Three weeks and no chance of a refund. This is a defective, not as advertised product with an amazing community. A lesser franchise (Anthem) would have sunk!

  • Jon-wileman
    3 posts
    This post is deleted!
  • findnitai1988
    1 posts

    @officerlego This worked for me on PC. Thanks!!

  • yeti4life
    14 posts

    @ubi-woofer no quest marker... its ridiculous we have to prove this to you...its clear the whole quest is messed up like come on... its been over 3 weeks now... please do SOMETHING!
    you guys [censored] suck


    undefinedundefined

  • sheiebs
    2 posts

    @officerlego thank you this worked for me too!

  • Ubi-Woofer
    Ubisoft Support Staff 799 posts

    @yeti4life Rest assured that our investigation has not stopped despite a workaround being found - we're still looking into this and will share more as soon as we can on the subject. Thank you for providing images of the issue - I'll pass these onto the developers now.

    @jrod614 As I mentioned previously the issue is known to us and we are investigating. We will share more as soon as we can. Thank you.

    @OfficerLego You have shared this same video multiple times in the thread already, and I'd like to request that you refer back to one of your previous posts as opposed to reposting the video repeatedly from now on. 🙂 You can link to your previous post by visiting it, and copying the URL (as the post number updates as you scroll to reflect the post you're currently reading). Thank you!

    Official Response
  • FluShot99
    2 posts

    There is a work around on YouTube where you can save a prisoner in a world mission and they will follow you back to the Long House to activate the cut scene. It worked for me and saved me several hours of game play!

  • BigJSmith16
    2 posts

    Looted Leah villa before doing the main quest. After defeating longhouse it says to find and rescue the thegns, but no marker shows up so I go to the villa to see if something will happen and there is no one to rescue so I can’t finish the mission. Anyone else have this issue or bug?

  • elladeer
    1 posts

    I have been stuck on this same thing for weeks. Can't get through the doors and half the time I go to the village to try again Sigurd is missing. No where to be seen....I would like to finish the game as well but I'm def not starting over.

    I already helped that prisoner mentioned in the work around so it doesn't work for me as it's been too long since I helped them.

  • mike561960
    1 posts

    My game is patched to 1.04.
    I committed myself to the Oxenefordscire alliance. I get to part of the Brewing Rebellion topic of "find and speak to sigurd". I get to the section with the lady at the alehouse. I pick choice two of the dialogue discussed further down this post. I have no other choices available for me. I am stuck at option 2 at finding "sigurd hid southwest of buckingham's alehouse. I have looked with Eivor as well as the raven for 500 meters to search for Sigurd as far as Meldeburne. No blue circle with Raven view found either.

    See this pics for references.


    Three choices available: 1) Pay the silver (130) 2) Solders won't help you. 3) I know you are an honest woman
    I do not have enough silver. I could not charm her since I did not have enough charisma. I have spent hours researching on youtube and google searches with no luck,. too. Various independent websites have stated that no matter what option you pick, then the next quest will be "meet sigurd at the fish house" The fish house never appears in the areas described to be 500 meters within Grantebridge as a part of the quest.

    I can not provide a video or picture attachments to before picking option 2 I have deleted 50 saves since then. For now, I am working around the glitch or trying another alliance attempt within a few days via Randvi by the alliance map. I do not want to start the game from beginning all over again because of this glitch.

Suggested Topics

Community Details

118
Online
141.2k
Users
24.9k
Topics
129.3k
Posts