Welcome to discussions

Quick Suggestions

  • DingusBopper
    4 posts

    also having this same issue on PC, reloading older saves isn't helping

  • Ubi-Borealis
    Ubisoft Support Staff 2877 posts
    Best Answer

    Hello there!
    I'd like to reach out to you all with an update. I'm happy to announce that the development team intend to deploy a several fixes for "Brewing Rebellion" in TU 1.2.2. This update will be deployed 15 June, 2021 at 2 PM CEST / 8 AM ET. The list of fixes includes the following:

    • The door to the longhouse in Buckingham cannot be forced open
    • Quest NPCs, such as Basim and Sigurd, cannot be interacted with
    • The Thegns are not registered as rescued after they are freed
    • Objective marker appears off-map during the "escort the thegns to safety" objective
    • "Secure the Longhouse" is not marked as completed

    If you are still encountering issues with "Brewing Rebellion" following TU 1.2.2, please don't hesitate to update this thread so we can take a closer look. Please include a video that shows the following:

    • You have the latest Title Update installed on your platform. You can view this information in the opening game menu in the bottom right-hand corner.
    • The issue you're experiencing in-game following this update.

    Additionally, please ensure that you have an up-to-date save uploaded to the cloud. We can then pass these reports to the development team for further investigation.
    Thank you! 😊

    Official Response
  • guest-9r9B9wOF
    6 posts

    Guys, im starting over, I'min England already. Let you know if I get the door open in Buckingham. Pray to Odin Sigurd will help.

  • Mahoushiro
    1 posts

    I found a sort of fix.. Use your Horn (the G button that summons raid) this forces that assasin guy to come by your side.

    After go back to the same spot you released the prisoners with the executioner and run down the way they faced. They refused to run around it seems..

  • DDawson._
    3 posts

    There is a glitch on the mission Brewing Rebellion where you cannot get into Buckingham's longhouse due to Sigurd being glitched and just stands still. This stops me from progressing the main story.

  • MissyxMayhem
    1 posts

    @dingusbopper me too, I accidentally broke into the side door and killed them instead of the door and he is free but glitched

  • FrostiK-rus
    5 posts

    @halaloya Yeah... same. But they are attacking enemy if near them and then they go into standby state... I guess AI is broken on that mission

  • bubabadjhi
    1 posts

    @halaloya Same problem here. Tried everything. Hoping for swift action from Ubi

  • Halaloya.
    12 posts

    @ubiexcellent can you please respond and let us know that this issue is under investigation? We need some relief that this bug is known to you

  • guest-9r9B9wOF
    6 posts

    After starting again with a different account snuck into buckingham and opened the doors of the longhouse with the help from Basim. Make sure your level is high enough for the next part. Cheers

  • Minttymint
    2 posts

    Another one here who is stuck with Sigurd and Basim doing nothing. Tried reloading, fast travelling, unmarking the quest, using the horn- nothing has worked. 😕

  • sourace
    1 posts

    i have this glitch too.
    The ally pnj are in stealth mod and dont move. i find a way to move them by whistle but they dont want to help break to door.

  • Dab_Youre_it
    2 posts

    Staying close to your allies and not going into combat helped me do it

  • princepd
    1 posts

    Hello i am in brewing rebelion and i am trying to open the door in quest brewing Rebellion,reach Buckingham longhouse and nothing is happening ..plz try to fix it so bad to happen this in main story

  • CenturionLD
    1 posts

    @ddawson-_ Have the same glitch

  • JarlJerry
    8 posts

    I’m also having this issue I’ve tried everything and I’ve already sunken 20 hours plus and am not tryna restart I’m on xbox one pls fix this game is gas and this is really disappointing that I’m being stopped in in my tracks I feel like you guys [censored] me no offense

  • Unthariel
    1 posts

    Have the same issue. My Eivor just keeps on pounding the door with Sigurd and Basim standing there looking pretty. Left it for 20 minutes and nothing changed.

  • JarlJerry
    8 posts

    Sigurd and that other [censored] are just standing still I’m stuck before you enter the Buckingham long house or whatever

  • JarlJerry
    8 posts

    @ubiexcellent please fix I have so much time sunk in the game already

  • ChickieRULES
    2 posts

    I am having the same issue on the Xbox 1. I've tried everything and haven't found a solution. I've also put in a ticket with Obisoft, still waiting on a response.

  • Lesnea
    1 posts

    In doing the Brewing Rebellion quest and it seems that it's completly stuck. I cant progress anymore. There arent any markers on the map or anything
    Please assist

Suggested Topics

Community Details