Welcome to discussions

Quick Suggestions

  • JarlJerry
    8 posts

    @ubiexcellent please fix I have so much time sunk in the game already

  • Ubi-Borealis
    Ubisoft Support Staff 2877 posts
    Best Answer

    Hello there!
     
    I'd like to reach out to you all with an update. I'm happy to announce that the development team intend to deploy a several fixes for "Brewing Rebellion" in TU 1.2.2. This update will be deployed 15 June, 2021 at 2 PM CEST / 8 AM ET. The list of fixes includes the following:

    • The door to the longhouse in Buckingham cannot be forced open
    • Quest NPCs, such as Basim and Sigurd, cannot be interacted with
    • The Thegns are not registered as rescued after they are freed
    • Objective marker appears off-map during the "escort the thegns to safety" objective
    • "Secure the Longhouse" is not marked as completed

     
    If you are still encountering issues with "Brewing Rebellion" following TU 1.2.2, please don't hesitate to update this thread so we can take a closer look. Please include a video that shows the following:

    • You have the latest Title Update installed on your platform. You can view this information in the opening game menu in the bottom right-hand corner.
    • The issue you're experiencing in-game following this update.

     
    Additionally, please ensure that you have an up-to-date save uploaded to the cloud. We can then pass these reports to the development team for further investigation.
     
    Thank you! 😊

    Official Response
  • ChickieRULES
    2 posts

    I am having the same issue on the Xbox 1. I've tried everything and haven't found a solution. I've also put in a ticket with Obisoft, still waiting on a response.

  • Lesnea
    1 posts

    In doing the Brewing Rebellion quest and it seems that it's completly stuck. I cant progress anymore. There arent any markers on the map or anything
    Please assist

  • guest-PXctMGF9
    1 posts

    I’m having the same issue currently @jarljerry

  • Qoali123
    3 posts

    @ubiexcellent

    im also having the same problem, I have a video of it as well.

    please for the love of god fix this... I’ve gone as far as I can with every other quest and can’t go any further with the game due to power differences.

  • Jmdattoma
    6 posts

    @jarljerry same dude if this doesn’t get patched soon I’m done

  • dragonborn0336
    2 posts

    Sneaking to the longhouse and not being spotted fixed the bug for me. Wish y'all luck

  • dragonborn0336
    2 posts

    @dab_youre_it it worked for me! Thank you!

  • Schottgun006
    7 posts

    @jarljerry same...this is bs

  • Rajhinn
    8 posts

    @slynjegare
    Same thing, did all optionals I had but this quest's progress is saved at the "Reach Longhouse" checkpoint at which Sigurd with the assassin are just standing around near longhouse and won't help open the doors. Can't progress the game.

  • KO3NW
    1 posts

    Reloading last save worked for me. Hope it helps

  • Hatshoe
    1 posts

    @lesnea I have the same problem. Sigurd is just standing around and isn't helping with the door. The quest also doesn't show up anymore on the map. Main story is stuck because of this.

  • wofpawel
    14 posts

    Same problem here. Earlier save doesnt help. Already 30 HR in game. I will not start again!!! Ubisoft say something!!

  • Minttymint
    2 posts

    I bit the bullet and just reloaded an earlier save- had to redo a couple hours of stuff but the quest proceeded properly this time. I stayed out of combat and circled around as per @Dab_Youre_it's advice. 👍

  • sheiebs
    2 posts

    No one comes to my aid when trying to force open door to longhouse. I have a video but cannot post it.

  • JarlJerry
    8 posts

    I’m already like almost 40 hours in now and this [censored] is aggravating I encourage anyone who’s having this issue to also make a post
    we need to flood there [censored] with this cuz I’m not [censored] restarting no thanks

  • Zaanickster123
    6 posts

    @dab_youre_it did you have to reload a save to do this?

  • Zaanickster123
    6 posts

    Can't get into longhouse because sigurd and basim stand there doing nothing. Not restarting an earlier save as I have put in over 20 hours into it already. This needs sorting out right now as I know that I'm not the only person with the issue!

  • DDawson._
    3 posts

    Sigurd and Basim are not moving and will not open the Buckingham longhouse door which means I am unable to progress with the main quests.

  • Bpd2011
    1 posts

    In the mission of Brewing Rebellion, you are unable to enter the longhouse. The additional characters show up near the door, but the characters will not help open the door. Unable to continue the story mode

Suggested Topics

Community Details

78
Online
142.2k
Users
25.1k
Topics
130.2k
Posts