Continue your odyssey

Welcome to discussion

Quick Suggestions

Hello! These new forums are an open beta and we welcome your feedback in this section.
  • sourace
    1 posts

    i have this glitch too.
    The ally pnj are in stealth mod and dont move. i find a way to move them by whistle but they dont want to help break to door.

  • Dab_Youre_it
    1 posts

    Staying close to your allies and not going into combat helped me do it

  • princepd
    1 posts

    Hello i am in brewing rebelion and i am trying to open the door in quest brewing Rebellion,reach Buckingham longhouse and nothing is happening ..plz try to fix it so bad to happen this in main story

  • CenturionLD
    1 posts

    @ddawson-_ Have the same glitch

  • JarlJerry
    8 posts

    I’m also having this issue I’ve tried everything and I’ve already sunken 20 hours plus and am not tryna restart I’m on xbox one pls fix this game is gas and this is really disappointing that I’m being stopped in in my tracks I feel like you guys [censored] me no offense

  • Unthariel
    1 posts

    Have the same issue. My Eivor just keeps on pounding the door with Sigurd and Basim standing there looking pretty. Left it for 20 minutes and nothing changed.

  • JarlJerry
    8 posts

    Sigurd and that other [censored] are just standing still I’m stuck before you enter the Buckingham long house or whatever

  • JarlJerry
    8 posts

    @ubiexcellent please fix I have so much time sunk in the game already

  • ChickieRULES
    2 posts

    I am having the same issue on the Xbox 1. I've tried everything and haven't found a solution. I've also put in a ticket with Obisoft, still waiting on a response.

  • Lesnea
    1 posts

    In doing the Brewing Rebellion quest and it seems that it's completly stuck. I cant progress anymore. There arent any markers on the map or anything
    Please assist

  • guest-PXctMGF9
    1 posts

    I’m having the same issue currently @jarljerry

  • Qoali123
    3 posts

    @ubiexcellent

    im also having the same problem, I have a video of it as well.

    please for the love of god fix this... I’ve gone as far as I can with every other quest and can’t go any further with the game due to power differences.

  • Jmdattoma
    6 posts

    @jarljerry same dude if this doesn’t get patched soon I’m done

  • dragonborn0336
    2 posts

    Sneaking to the longhouse and not being spotted fixed the bug for me. Wish y'all luck

  • dragonborn0336
    2 posts

    @dab_youre_it it worked for me! Thank you!

  • Schottgun006
    7 posts

    @jarljerry same...this is bs

  • Rajhinn
    8 posts

    @slynjegare
    Same thing, did all optionals I had but this quest's progress is saved at the "Reach Longhouse" checkpoint at which Sigurd with the assassin are just standing around near longhouse and won't help open the doors. Can't progress the game.

  • KO3NW
    1 posts

    Reloading last save worked for me. Hope it helps

  • Hatshoe
    1 posts

    @lesnea I have the same problem. Sigurd is just standing around and isn't helping with the door. The quest also doesn't show up anymore on the map. Main story is stuck because of this.

  • wofpawel
    14 posts

    Same problem here. Earlier save doesnt help. Already 30 HR in game. I will not start again!!! Ubisoft say something!!

Suggested topics

Community details

22
Online
125.0k
Users
21.6k
Topics
111.2k
Posts