ubisoft discussions

Quick Suggestions

  • Zerrotol
    1 posts

    Same issue on Xbox One X. went to save and noticed all of my save files from today were corrupted. When I tried to manually save it was also corrupted. Hoping to see them restored like others, by quitting to the main menu, I attempted to Quite to Title Screen. The game froze when I selected the option and could not be recovered without shutting the game down. Upon restarting the game, all corrupted game files were automatically deleted. I selected Load from the main menu and the only option was to load from my last uncorrupted save file. Luckily, this was 45 minute earlier. I thought I should post this as the fix others mentioned did not work for me.

    I'm honestly thinking about putting the game down. Between the constant screen tearing and now this possible game breaking bug, it doesn't seem worth it to continue until fixes are released.

  • gengsta19
    5 posts

    I lost approx. 6hrs of my game progress. Playing on xbox series x... I won't play again till it's fixed. Please restore the saves! The funny thing is that Ubisoft Connect on Xbox shows me the correct stats on e.g. how many people I killed from the order.

  • OakBayGamer
    1 posts

    @magnumgooseye Just happened to me too, first time ever on Xbox One. Lost 4 hours of game play. I hope they fix this issue soon!

  • Nomision
    3 posts

    Same Issue on PS4 with plenty of space left

  • Moonriver33
    1 posts

    Also having that problem. I also tried loading from a different save to my main and it copied the side game to the main. Got a loading screen and then my 20 hour playthrough was gone

  • Magnumgooseye
    3 posts

    I have just lost a whole day of gaming due to a corrupt save file error. I looked online for how to fix it and the common consensus was to quit the game, log out of profile, then re start the game and the save files should be fine. I did this and found it has randomly picked a save file from 12hours ago and started me back there with no evidence of more recent saves. The reason I had to restart was because I was in the main stroyline and the enemy I was dueling spawned lying on the ground and I couldn't leave the area. I have already had issues throughout the game with bugs but have tried to ignore them as I've been a huge fan of AC since day one. I've spent so much money on this franchise over the years I can't understand what's happend. This is insane. I haven't had an issue with corrupt save files on xbox ever. The first time it has happend is for Assassin's Creed Valhalla in 2020. 

  • guest-ScOjRf2H
    2 posts

    I'm playing on ps4 and right when I'm leaving for England on the boat I get a message saying the files corrupt after the AC Valhalla emblem shows on the screen. Second time downloading it, problems happens in the same spot. Pretty frustrating.

  • guest-ScOjRf2H
    2 posts

    As I'm leaving Norway to go to England I get a corrupt file notification, had to delete and re install only to find the same issue when I got to play again. It's pretty frustrating, this games got 2020 written all over it.

  • SirKrimzin
    1 posts

    I'm also having the same issue. Manual saves are all data corrupt (even newly created ones) and all auto saves. I noticed it happened after auto looting wealth items from guards in Templebrough Fort and the wealth icons still appearing on the map (as if they weren't claimed). I have an exclusive mission save that isn't corrupt however.

    I'm playing on Xbox one X

  • JaseDakota
    1 posts

    Xbox Series X here, just had this happen to me. Went to save and my saves said Data Corrupt. It let me make a new save just fine and I deleted the corrupt save. Closed and restarted the game and my game loaded ok, but I think I might wait for a patch to continue playing. I don't want to lose my hours of progress.

  • Hearthmann
    7 posts

    Yeah, there are no easy workarounds for corrupt save file. Some files can be recovered but not easily; this is wide spread problem across all platforms, only thing to do is wait until they fix it in a patch. That support team keep brushing this off rather than sending this issue to relevant development teams is worrisome. I doubt this will be fixed next patch. Might be a couple patches from now. As it stands you will probably have to keep restarting over and over again.

  • Wh33lo
    2 posts

    @hari_ajith Which is actually such a shame as it was shaping up to be one of the best assassin's creed games to date, I've checked around on other forums and this seems to be a very common occurrence and haven't found one statement from ubisoft in regards to this problem

  • C4PT41NxCRUC14L
    1 posts

    Same issue on PS4. Also had to delete and re-download the ENTIRE GAME. Can't imagine I'd continue trying to play if that happens more.

  • Redw0lfAlpha
    61 posts

    Please don't tell me this is really happening,first Watch Dogs legion which is in a unplayable state due to crashing,freezing and saving problems and now Valhalla too?

    Valhalla goes on hold as well. My goodness what the *peep* is goin on With Ubisoft games. This can't be right.

    We all understand because of the pandemic that things are going to be a bit more difficult. And we've gotten used to some minor bugs here and there. Most of those bugs are therefore resolved in most cases. But two games with these kinds of problems? That can't be right.

  • Redw0lfAlpha
    61 posts

    @c4pt41nxcruc14l Terrible if you have to that. I'm not going to do that. I'll put Valhalla on hold instead.

  • guest-DDuQdfGH
    1 posts


    After completing the mission and heading off on the boat to England where I see the AC:Valhalla splash screen, the game crashed saying the game was corrupted and to eject the disc and delete the game and re-install. So I did, and now when I start the game it's stuck on the circular screen with the 2 blue axes and does nothing. I've literally left it here for 30mins and there is no animation - nothing.

    I cannot play the game.

  • qvistis
    1 posts

    The same thing happened to me.

    Started the game and explored basically all of Rygjafylke. Got to a Seer's Solace and couldn't complete it. Not too bad I thought so I restarted. 

    Started it again and legged it to a Seer's Solace. Completed the quest and then started exploring everything for the second time. Eventually came to Sigurd and told him we're good to go to England.

    The game then crashes, saying the game is corrupted and to eject the disc, delete the game and reinstall. Literally tried everything. Old save files, restarting, disconnecting from internet (just in case). Even did what it said and deleted and reinstalled the game. Now all my saved files are corrupted and I can't load any of them. Also unable to "Continue" so by the looks of it another restart is looming. Frustrating doesn't begin to describe it.

  • adeybe
    2 posts

    I'm not as hardcore as some, and my expectations aren't as demanding, but I must admit, this is pretty poor!

    Firstly I encountered the 'Seers' bug rendering the whole game impossible. I look on the internet and it's been raised with other players and with a future fix - leaving me with two options - restart (not the end of world) or be patient and wait for the fix. So I decide to restart.

    Then I get this 'Data Corrupt! bug... To be honest an equally game killing bug. But with this one it's more a nusiance as it's known but NO info about workaround OR a fix. Ubisoft haven't even acknowledged it!

    At least Ubisoft are quickly pushing out fixes to solve other major game killing issues like surrounding language...

    Ironic because as it stand this game is as much use as a bookend to the books the people it's trying to appease to want burning...

    OT - If you're getting players (like me) who paid good money writing on these forums wanting game killing bugs fixed... Your game has MASSIVE problems.

  • SinisterKevi
    2 posts

    13 Gameplay hours lost, I can't imagine the amount of people who have probably lost more hours than me. How pathetic to release a hyped game and expect people to continue playing when they lose their freakin Manual saved/Cloud saved data. Pick up your standards Ubisoft, you've been in the industry for so long and yet you still look like 1st graders compared to others. [censored] lift.
    -First time angry post

  • Scaretactic.
    9 posts

    @hari_ajith having the same issue

Suggested Topics