ubisoft discussions

Quick Suggestions

  • Timbo_Redbeard
    8 posts

    I could talk to him after I found the codex but after a but of playing I again can't talk to him. Can't do a quest to reset him, cause I finished the game already. Also the kids don't show up again. I think he's bugged because I never listened to the story.

  • Ubi-Wan
    Ubisoft Support Staff 636 posts

    Hey all! Our team is currently aware about this, and we invite you to share your experience on our dedicated thread for this issue here!

    Official Response
  • cbantug
    4 posts

    I completed the Vikings for Hire quest several days ago. Already completed the kids quest, haven't been able to speak with him since. I've sat in the settlement for a couple hours, meditated to pass time, slept to pass time in hopes of catching him telling a story but he never does. Can we expect any kind of response on this anytime soon?

  • ProtoHawk789
    1 posts

    It will not let me speak to Reda at all. This is new to me today, I have spoken to him many times in the past. I see others on Reddit are having this same issue. I play on Xbox Series X. Because of this, I cannot access his opal store. 😞

  • subilaci
    3 posts


    Thank you!

    That worked! Thank you! Thank you! 🙃

  • Ubi-Wan
    Ubisoft Support Staff 636 posts

    @protohawk789 Hello there! Sorry to hear you're having trouble with this mission. Our team is aware of this issue and are looking into a solution. You can have a look at, as well as share your experience on our dedicated forum post for this issue here!

    Official Response
  • Croooozer
    3 posts


    danke für deine Antwort, das problem mit der Geschichte hatte ich auch aber nichteinmal das macht er... sitzt nur da und is unansprechbar. Schnellreise, Meditation das alles hat keine Wirkung.
    Ich spiele einfach weiter, vielleicht fixt Ubisoft das Problem und wenn nicht dann kann ich halt nix vom "Ingameshop" kaufen -.-.
    Thanks for your answer, I also had the problem with the story but not even that he does ... just sits there and is unresponsive. Fast travel, meditation - none of this has any effect.
    I just keep playing, maybe Ubisoft will fix the problem and if not then I can't buy anything from the "ingame shop" -.-.

  • pharmartist
    4 posts

    Solved, sort off...I´ve tried everything and so it goes all the same with my most recent save. I decided to load a previous save before completion of the 10th contract and the appearance for the first time of the quest "viking for hire" cause i know when it was, yesterday. Back then, Reda was still a interactable guy. i ask for a couple contracts and completed one. The Viking for hire popped immediately. I rushed to Raventhorpe and Reda was available. I spoke to him, received vikings for hire reward, and from now on I'll, i make sure i have a save before fulfilling Reda's contracts. I wish i hadn't to reveart to a previous save. This is really a game breaking bug that should be addressed soon by the devs. Hope it helps someone

  • C4n4ri0n787
    9 posts

    Alvarosantan11 estoy en la misma situación que tu me sale el símbolo y no me deja hablar con el llevo asi ya dos dias y no puedo ni comprar o mirar su tienda tampoco, la única manera de aceptar misiónes son en los ottos pueblos pero hablar con Reda no me deja si das solucion a ese problema informa por aquí mi nick ps4 canarion7878

  • M331331
    2 posts

    the kids appeared today again and i listened to the Story again
    now it is not bugged anymore and Reda is talking to me.

  • heikathegamer
    1 posts

    I am also having this same issue on PC, did the children and wolf quest hours ago, just finished the 10 contracts for the Viking for Hire quest, Reda is now just sitting on the ground with a quest marker, uninteractable. Please fix this and give us back the full functionality of the shop.

    5 posts

    @Burlzey post worked!!! Thank you!!!

    See his workaround below:
    "I also encountered this bug and found a workaround but it may not work for yourself. I decided to complete the quest for the Hidden Ones where you need to find six codex pages. After handing them in, Hytham tells you to speak to Reda. I was then able to interact with Reda for this quest which then enabled me to interact with him again about the Viking for hire quest."

    Was able to do exactly as he stated and cashed in my Opals. Just find a Youtube post on the 6 Hidden one bureaus and grab them all. I followed the one from 'Gaming with Abyss' creator.

    So happy! If only someone finds a work around for my story mission in Cent that i cant complete due to a similar type of bug.

  • Trustym2
    3 posts


    This is exactly how mine looks, can't finish the quest, because I cannot talk to Reda.

  • Alexroxburgh225
    1 posts

    As soon as the Viking for hire quest activated I haven’t been able to speak to reda at all, he’s there but there’s no option to interact with him. I can get quests from the other kids but can’t spend my opals.

  • bloedvuur
    1 posts

    I've got the same problem. The workaround with the 6 codex pages worked. Until I loaded back in today. Now I don't have any quests anymore. So I don't have any work around option anymore. 😔

  • MasterCmndr35
    4 posts

    I actually figured this glitch out; you have to listen to Redas story. When he is telling origins story interact until he is finished. If he is sitting down because you ignored him (like I did) you just have to teleport away and back (could be a time or two) until he is telling the story again. Do a quest then go back to settlement and goof around for a minute and check back he will eventually tell the story again. Daytime is best because he doesn’t tell the story at night I don’t think.

  • Ubi-Ginge
    Ubisoft Support Staff 257 posts

    Would you both be able to share your save files with us via either Twitter DM or Facebook PM so we can investigate this further

    Official Response
  • aazhari
    10 posts

    I have the Viking for Hire bugged where after completing all 10 contracts the last step which is to interact with Reda does not have a button prompt.

    Things that I have already tried:

    • Fast traveling
    • Quitting to main screen and reload the save
    • Quitting the game completely and load again
    • Verify game files and load again.

    I couldn't find any posts in here but there is a reddit thread that some people are experiencing the same issue:



  • aazhari
    10 posts

    @ubi-spud the last step of the quest is "Speak to Reda", so we can't substitute other merchants.

Suggested Topics