Welcome to discussions

Quick Suggestions

  • FluggerNO
    3 posts

    I`m stuck at this point.
    Reda has the green marker but the E for speak does not show.

  • Ubi-Borealis
    Ubisoft Support Staff 3625 posts
    Best Answer

    Hello all!

    The development team have marked this issue as resolved following TU 1.1.1. As we have not received any new updates about being unable to interact with Reda, we will be marking this topic as resolved.

    If you are still encountering trouble when interacting with Reda, please don't hesitate to post in this thread so we can take a closer look. Please can you include the following when making a new post:

    • Which TU you have installed currently? You can check this in the bottom right-hand corner of the main menu screen.
    • When did this issue begin? Did it happen after completing a certain activity or an interaction?
    • A video that shows you are unable to interact with Reda.

    We can then pass this along to the development team for further investigation.

    Thanks! 😊

    Official Response
    3 posts
    This post is deleted!
    3 posts

    I can't talk to Reda and I'm done with the story and my camp is level 6. He is sitting down in his tent and no interaction with anyone. He's not telling kids stories anymore either. The Viking for Hire is the only mission I have left.

  • hokousharingan
    10 posts
    This post is deleted!
  • Dgermany39
    1 posts

    @deaserex I can't either. Just got the stuff done and can not interact. What gives? I have been able to talk with Reda the whole time and now that I have that quest finished I can't complete it. . . . . Have you found a work around yet?

  • panfried01
    4 posts


    Reporting same bug. Unable to speak to Reda. Game keeps crashing too.

  • dinahcat5
    1 posts

    Same issue here. I CAN interact with other thousand eyes agents, but Reda just sits there and his adult apprentice is nowhere to be seen. I cannot buy anything as he does not offer.

    This wouldn't be an issue so much if my husband was experiencing this bug, too. We play on the same PS4 with our own accounts. My Reda doesn't work, his does. Grrr....

  • FluggerNO
    3 posts

    Same problem for me.
    This is the only quest I have open at the moment.
    Reda has the green marker but the E to speak is not there.

  • Tigress601
    7 posts

    I'm having the exact same problem. Every time when I run in to him he stands up but then sits back down.
    I was hoping the update wouldn't fixed it but obviously not

  • ItsJakeM8
    6 posts

    Having the same issue. He is just sitting on the floor and I am unable to interact at all. I have already completed the all missions/quests/story in the game so i have no option to "maybe he'll work after so and so quest". Kind of frustrating that Reda has been stuck like this for over a week now. "Well hey you don't have to pay money for the store items after already paying full price for the game and season pass, you can just grind opal. Even though you can't spend it and you're probably missing out on an item you want that won't be available from reda for another year so.. just give us more money for it clearly our quality is worth it right??"

  • apw2
    4 posts

    Even after the latest patch this problem sitll exist...

  • caesarbert15
    1 posts

    once completed 10 contracts, Reda wont be able to talked to, so the Opal shop is also bugged.There seems to be a mass situation about this bug on reddit already.

  • mustangjoe2439
    1 posts

    I can't talk to Reda nor can I talk to either the blind or the lame man for the world event in sciropescire.

  • JC_GAMER884
    7 posts

    So i did the 10 contracts for the thousands eyes from Reda and after i completed the 10 contracts it says go speak to reda but i can't speak to reda so it doesn't let me speak to the person.

  • E-PlazaBoy
    1 posts


    love the game so far, only downsize is that I can't finish quest Viking for hire. I can not speak to Reda. Some npc's doesn't interact (sometimes) like the normally should.

    ps4 player

  • DCoombsy007
    4 posts

    I can't interact with Reza, it marks him as a quest "viking for hire" yet I can't start it or buy anything

  • DCoombsy007
    4 posts

    @deaserex im having the same issue.

  • HeathenShip6935
    8 posts


    Having exactly the same issue as you, but using an XBoxOne X.

  • BootlessOpossum
    6 posts

    I still can't talk to Reda, I've completed the Cent Story Arc already. No kids are around him for him to tell his story and he just sits there. I also never got the achievement for completing that story arc but I have all the rest.

  • BootlessOpossum
    6 posts

    Apparently the work around is to complete the Cent story arc and listen to him telling the kids the story but I completed that arc ages ago and he's not telling the story to any kids.

Suggested Topics

Community Details