Welcome to discussions

Quick Suggestions

  • Dave.Tin
    1 posts

    Hi I clear 10 contracts now I need to talk to reda but I can’t talk to him why is this I see the mark but I can’t talk can someone help me

  • johnjaybee1978
    2 posts

    I've just spent 100+ hours completing the main game and I now am unable to interact with the reda character or return to asgard. I bought the season pass too which I can't access.i feel ripped off out of the best part of £100 and I want my money back.

  • Ubi-Woofer
    Ubisoft Support Staff 787 posts

    Hello everyone,

    Thank you for continuing to share your reports of being unable to speak with Reda (the Thousand Eyes merchant) in Ravensthorpe. I have merged a few more duplicate threads into our megathread here, so I do apologise if any conversations have become disjointed.

    Following extensive investigation, I am pleased to say that the developers believe they have found a fix, and this is due to be implemented in a future update. I do not have any additional information to share at the moment - such as when the update will become live - however as soon as I know more, I'll be sure to let you all know here. This issue is also now listed in our Known Issues list under "issues addressed in future update", and the Valhalla community team will cross-post the relevant information there as well when it becomes available.

    In the meantime, there are three workarounds that we know of that may be worth a try. Please find these below, and let me know if any of them work for you:

    • When Reda is telling the story of Bayek to the group of children, stand close by and listen to the full story. When this is done, you may be able to speak to him again then.
    • Collecting all six of the Codex pages and handing these to Hytham in the Hidden Ones Bureau will result in a prompt to talk to Reda; once you have done so and read the letter in his tent, you may be able to then interact with him again.
    • Completing the Cent arc in full triggers an event at the settlement which may allow Reda to be interacted with again.


    Thank you all for your continued patience and understanding. 🙂

    Official Response
  • M1ch4el69
    1 posts

    After competing the 10 Viking contacts for reda, I'm unable to finish the quest since the game won't let me interact with reda.
    And during the lost glory quest, I'm unable to interact with the hammer after killing the three wolves.

  • Hound_Wr
    1 posts
    This post is deleted!
  • streethawkfan
    14 posts

    I have the same issue on PS5, Hopefully we can get some feedback on when this could be fixed as because we can't speak to Reda it all so locks us out of being able to buy items and gear with opals.undefined

  • Mr.Karper
    1 posts

    Hello Devs, during my ventures through Valhalla I stumbled across several bugs that has halted my gameplay and added hours of frustration, the main one being the most recent, with Reda during the "Viking For Hire" quest. I finished the quest, and like the thousands of other players I cannot interact with Reda, which is irritating since I want to complete the quest and view his shop, etc. I know this question has been asked constantly but I wish to know if there is anything I can do to speed up the process or fix my issue. I have attempted fast traveling and waiting for the kids, restarting the game and reinstalling, loading previous saves, but anything post completing 10 contracts screws with the game and doesn't allow me to interact with Reda at all. I hope that bringing this to your attention once more can help you see how annoying this bug is and that it can be fixed shortly. I know that you and your team is in the process of fixing this error, though it seems like it has been widely known since release of the game and yet to be patched. Thank you for your time, I hope that someone has an answer to my problem.

  • MacBADGER-1971
    1 posts

    Good Morning

    I have completed the 10 first tasks give to me to do by REDA,
    I got the side quests form various locations. On completion I was told to speak to REDA. once back in the settlement he just looks at me. I am unable to communicate with him.

    Please advise how to fix this BUG

  • FayamanGielo
    7 posts

    Cent storyline fixed it again!
    listen to his story and finish it and you are able to interact with read agaian

  • CrazyClownFish
    1 posts

    My issues started when I first had Reda come to settlement I could do quest for opals but the market was empty. I stopped playing a while after (don't remember quests around that time) that and came back the next day (real day) and I was unable to interact.. was early on in the game that this happened, I kept playing hoping this would sort itself out. I can speak to other "thousand eye" kids in other towns for quests but just can't interact with Reda.

  • WizzyPickuper
    1 posts

    @fluggerno same for me. Devs, please come back on this

  • Ubi-Wan
    Ubisoft Support Staff 630 posts

    Hey all! Our teams are currently investigating reports similar to this, and are working on a fix. If you play on PlayStation or PC and would like to assist in the team's investigation, please create a new case with our dedicated support team, and attach your game's files, so this information may be forwarded to the game's team!

    Official Response
  • Arch4ngel73085
    1 posts

    @ubiwan I can't even get into Ubisoft connect it pops up an error message that says online service error problem occurred while trying to communicate with a Ubisoft online service please try again later and then it gives me the error code 0x7000015f

  • JBJared
    2 posts

    Same, on PC and can't speak to Reda. I'll try and wait and see if he tells a story like someone suggested.

    The bugs a frustrating.

  • Woodman918
    1 posts

    I cannot believe all the glitches I am getting with this game. I have played every Assassins Creed since it’s inception and have to say this makes the game the worse. I have the Reda and Ubba glitch. Fix your damn game or you shouldn’t have come out with it!!

  • ObiWanKonnoli
    4 posts

    Unable to talk to Reda after completing main quest and a bunch of side quests. Contract shop does not even open as I can not speak to Reda.
    See photo below.

  • humzzn
    1 posts

    problem not solved on PC... cant talk to Reda anymore

  • Enmitynz
    1 posts

    I can confirm I cannot interact with Reda either - Playing PC version - And I have completed the main story and most other quests, I just cannot complete the viking for hire quest as Reda is being a snob 😛 I have never been able to view Reda's Shop so I've missed out on so many opportunities for rare gear and its frustrating that I cannot complete the quest.

    Granted, I did start this quest a long time ago, but didn't really follow through until I finished the main game so I was able to visit other thousand eyes from various locations until I've done my 10 contracts...now I get no more daily contracts from any of them, and Reda is not possible to speak to.

    I saw that some people had success with completing the 6 codex quest so since I already had 5 of them, found the 6th...took them back to the dude at settlement who then sends you to Reda to read the hidden ones letter..I was able to do this! and completed the hidden ones codex quest ....go back to Reda and nope, can't talk to him again.

    Super frustrating because I'm getting bored now that I've completed the story and have been looking forward to possibly getting some rare gear or weapons etc. Can we please get this one fixed asap.

  • eclaudio01
    2 posts

    Hi Everyone,

    I'm having the same issue but with the witch in Grantebridgescire. I can't interact with the dead body to start the fight. Any options?

  • J_Roesler
    3 posts

    I have had the same problem for over a week. I was able to interact with Reda after the Hidden One guy sent me to him about Bayek's letter, but after that, he went back to sitting on has [censored] and ignoring me. You just had a major update 2 days ago, why wasn't this fixed?

Suggested Topics

Community Details

111
Online
139.7k
Users
24.6k
Topics
127.5k
Posts