Welcome to discussions

Quick Suggestions

  • penjazz
    3 posts

    I can talk but it wont connect to Ubi so it’s useless

  • stoltz612
    3 posts

    @kamiback did you ever figure this out ?

  • Lycan_333
    3 posts

    @stoltz612 Same deal. Have you got any updates or fixes yet?

  • penjazz
    3 posts

    no, I have checked all the prefs outside the game and so far can find no reason for it. I even reloaded an older AC game and it had no trouble connecting

  • Takumii332
    1 posts

    Noticed something about Reda when I did my 10 contract missions then returned to go turn in the "Viking for Hire" quest. His character model is about the same height as yours. He looks like a grown up man child now. This leads me to believe that this is a stand-in model and not the real Reda.

  • rasmusadson
    10 posts

    Finally can talk to him again, for atleast once so I got my quest done. He told the same story again after the fight with Dag and was accessible after that.

  • Kurohyou25
    5 posts

    Broke for me on pc. Seems to have broken after the wolf quest with the kids.... Unable to turn in vikings for hire or see the shop/quests.

  • sunford
    3 posts

    I am also experiencing this issue.

  • Kdamme
    3 posts

    I can't interact with Reda to fines the viking for hira quest

  • livden
    4 posts

    @apple5333 I had the same bug.

    Did the quest for the bakery, then I was able to talk to him again. Not sure why this helped, but might be you have to finish any quest you have active in the settlmement. (I still have a seers quest active, so might not be this)

  • Npc-.-
    1 posts

    I had the same Bug. I did the following to fix it. I went inside the longhouse and spoke with the Child. After the mission with the children, I spoke to the woman right of the Longhouse, the mission was to find her husband. After that I went back to reda and listend to the story. After that he was interactable again. You can probably do any mission after the mission with the children.

  • kamiback
    2 posts

    @stoltz612 Not at all, I'm at power 221 and pledged almost the entire map but I'm still unable to talk to Reda

  • BearKaiser
    1 posts

    I have the same issue, it's really annoying..

  • sunford
    3 posts

    @kamiback I am almost powerlevel 350 with the entire map discovered - I can't interact with him.

  • Vxena1980
    3 posts

    Cant speak to reda after completing the 10 contracts.
    Already tried reloading ,didnt work.

  • The-Southpaw
    2 posts

    Having this same issue. Reda is just sitting on the ground and I cant interact with him. I've never seen Reda surrounded by kids telling a story, That has never happened at my settlement. It's obviously bugged and a huge, annoying one at that.

  • doubleshock085
    1 posts

    Same here, I completed the 10 quests and have to "Speak to Reda", however nothing happens when I approach him in Ravensthorpe, and there is no option to speak to him (untargetable).

  • philibird
    2 posts


    I am also experiencing this bug. I went to go spend my Opals as I finally hit 150. Plus I finished my Viking for Hire mission which I am unable to turn complete at Reda. I can no longer interact with Reda. I tried fast traveling back and forth, and I tried restarting the client to no avail.

    This article mentions the bug as well, I will paste below the description of it as it matches my scenario perfectly. I was waiting for Reda to finish telling stories and wasn't able to interact with him once he did. Also worth noting, anytime I Left the area and came back he would restart the story.. extremely annoying. I had to sit and wait for him to finish it which took a while.


    Sadly, as mentioned in our official review, Reda bugged out. I’m still able to grab contracts from other Thousand Eyes NPCs (which means I can still earn opals). However, I’m unable to actually purchase anything since Reda’s just sitting in the tent. Note: For the sake of clarity, the bug happened after a scene where Reda was telling stories to the other kids in the settlement.

  • Dem0niac_Live
    2 posts

    @rasmusadson I've got the same issue and I dont see anything posted about it being fixed or them even knowing about it.

  • APPLE5333
    28 posts

    @livden oh Dam.. x_x I did the bakery quest before this bug started for me.

    But thank you so much for posting. Hopefully it'll help somebody else! ❤

Suggested Topics

Community Details