ubisoft discussions


  • locked moved topic_solved [RESOLVED] Unable to progress with "A Sword-Shower in Anecastre" as Aelfgar will not move | POST HERE

    2 likes/203 replies/4004 views
    ubisoft:x-posts, 1

    This quest is broken. I've uninstalled and reinstalled, fast traveled, and came back. The characters you are supposed to follow are stuck on the road and will not move.

  • overduefart911
    ubisoft:x-posts, 5

    @igor2098 Yea there isn’t a solution yet... Hoping Ubisoft fixes this soon, really sucks. I’m completely stuck in the storyline in Lincolnshire until they fix the game. I can’t progress to Hamtunscire or Snotinghamscire until they fix the game for the Sword-Shower mission as I still can’t follow Aelfgar... frustrating

  • Eaglethatsbald
    ubisoft:x-posts, 1

    In the mission A Sword-Shower in Alcestre, When told to follow Aelfgar, he stands still and will not move, preventing the player from progressing through the mission.

  • Burg3r07
    ubisoft:x-posts, 7

    I have tried everything to progress in the game but the bug not letting me follow Aelfgar is prohibiting that. I have tried everything to fix it and have over 90 hours in the game and just want to complete it. I really hope this gets addressed in an update soon as I've been waiting over 2 weeks for an update to fix it. So please if any devs are reading this please look into that.

  • Ubi-Baron
    Ubisoft Support Staff ubisoft:x-posts, 798

    @alliancestuck Thanks for the report, I can see you've had a reply there now.

    @Lypitiern300 Thank you for the added report.

  • Albirdo
    ubisoft:x-posts, 2

    The only way he moves is if shoot him or run past him. I can't get him to go to the camp up the hill. Earlier saves are also bugged. I tried verify file integrity and still nothing. Please help!

  • Bowhanon
    ubisoft:x-posts, 1

    So, it bugged on me to. And then I came to here to check if anyone figured it out. Someone said push the dude even though I had him on his horse stuck. But somehow...i unstuck him on his own? I ran out on the main road about 500m trying to find the camp but didnt know what i was looking for...zoomed in and i could see a smaller path going to a lake and ran into the camp. So I started at the gate on my horse still and ran all the way to the back where horses are and a soldier yelled out a cheer. Then I took the back path out and cut across the country next to a house along the way to the stuck npcs and all of a sudden they started on their own. Probably a 10 min wait with me looking this up and traveling around on my horse. Now im at the camp and moving on so far. Hopefully this helps.🤘

  • UbiExcellent
    ubisoft:x-posts, 756

    Hello everyone, and apologies for not adding to this thread earlier. I'm happy to announce that our teams have received numerous reports about this issue, and were able to find a fix for it. We hope to add this solution into the game in a future patch! In the meantime if anyone else experiences this issue, please try some of the workarounds posted earlier in this thread, or create a manual save then load that specific save file.

    I'd also like specifically thank desdecardo13, Alake314, and Bowhanon for sharing their workarounds. 👏

  • Ubi-MrM
    Ubisoft Support Staff ubisoft:x-posts, 4172

    Hello everyone! 🙂

    Title update 1.1.0 launches today, and in it we have a fix for the issue in "A Sword-Shower in Anecastre" whereby Aelfgar doesn't move to the assault location. You can find the full patch notes here.

    If, after the patch goes live and you have applied it to your game, you are still unable to progress in this quest, please let us know and provide a video of the issue for us to review.

    If you have any questions, concerns or feedback, don't hesitate to get in touch. Thank you for your patience and understanding!

  • Alake314
    ubisoft:x-posts, 12

    @ubiexcellent Glad I could help. But really, this kind of problems have brought a lot of disappointment. I am sorry, but I don't think I am ever going to buy a game on its release date. I don't know how much are you allowed to send a message up there, but for the next game I would hire more testers and avoid, if not all, a bigger amount of these bugs. The list of quests with bugs in this last patch should be shameful enough to realize this game has serious developing issues and was not ready at all to be at the stores. I sincerely don't see the point in spending the money it costs on its release date, when I can purchase it for a bunch less in a year, patched to a reasonable quality. Games are to be enjoyed, not suffered. At least, not for technical reasons that could have been avoided. If I could, I would tell Ubisoft CEOs, or whoever took the decision of releasing this when it has, that this is not the way. Not at all. We players are not kids. Some of us are even over 30. And we feel we are no being taken seriously enough. If sales go south with the next title, Ubisoft has the answer of why.

  • phil3765
    ubisoft:x-posts, 3

    After the latest patch, 1.1.0, Aelfgar is still stuck standing by the house (not on a horse) about 20 meters from where the quest started. I have tried all of the suggested solutions again this morning after updating.

    Any further suggestions, other than restarting from a MUCH earlier game save, would be greatly appreciated!

  • Arathorn_ToXiK
    ubisoft:x-posts, 13


    Aelfgar still doesn't move at all. He waits, doing nothing on the road.

    It will be soon a month that this bug is preventing me from completing the game...


  • AgntFrost12
    ubisoft:x-posts, 3

    @ubi-woofer Hello I have updated to the new patch and still Aelghar is in the same spot and doesn't move! What can be done for this?


    @phil3765 Hopefully this gets resolved soon Ive been stuck for a while and have been waiting this patch and sad that still in the same position!

    @ubi-baron how was it not focused on when it stops you from continuing the story of the game?! That doesn't make sense I've legit gone and done all other terrorites that where accessible and now just at a halt because of this.

  • AgntFrost12
    ubisoft:x-posts, 3
  • LutherG0D
    ubisoft:x-posts, 1

    @arathorn_toxik I chose the path with Hunwald and he froze in the middle of the street, I play in Stadia . why Ubisoft can not fix its game ? I pay to play the game, not cracking it. So fix the game or refund .undefined

  • AgntFrost12
    ubisoft:x-posts, 3
  • dbeale83
    ubisoft:x-posts, 6

    Yup, still stuck, outrageous. Have been waiting for this patch for like 2 weeks and still not fixed!

  • AirSoupBowl
    ubisoft:x-posts, 4

    Still unable to interact or follow or get Aelfgar to move. Still stuck on the road. This is after Patch 1.1 downloaded today. I’ve tried several other things, like restart console, unfollow quest, then refills quest. I went back to Randvi at the Alliance Map, but am unable to “unpledge” Lincolnscire and I’ve completed all other areas including Vinland, so I have no where else to pledge and cannot complete the main story. I’ve eliminated the entire order except for Bishop Herefirth, the Lyre, and the Father.

    I even tried eliminating the Bishop in Anacaster, but found you can’t, unless you’re in the main story.

    So, is there a way to unpledge Lincolnscire, so I can repledge and re-trigger the entire Lincolnscire story arc? Or possibly detach the bishop from the main story (like the oil, the adze, etc)?

    (I’ve got 165hrs in, Level 400, so I’d rather not restart the game or reload from an earlier save)

  • Arathorn_ToXiK
    ubisoft:x-posts, 13

    @lutherg0d Yes totally agree. Huge disapointmment. I'm a big AC fan and I played all the games of the franchise but all the bugs I encountered + overall I appreciate the game but nothing crazy...

    It even make me wonder if I will continue to play next games.

    Ubisoft seriously please put more love in your games and fix these ridiculous bugs (you could even simply allow players to reset quest to fix these kind of bug).

  • Burg3r07
    ubisoft:x-posts, 7

    I Swear, if we don't get a hot fix for this quest to follow aelfgar I'm going to lose it. I paid $60 for a game I cant even beat I have 90+ hours in this game just to get slapped in the face again. I've waited 26 days for a patch to fix it and hoped this title update would do so but just got on after almost a 3 week break just to see they didn't even attempt to fix it. Please I want to finish your game I am on pc and this game is really good but I just want it beatable so I would be more inclined for the DLC when it releases.

Suggested Topics