Welcome to discussions

Quick Suggestions

  • Testyfy
    2 posts

    @jesustsrikesbac
    same problem here
    tried to relog/reload/reboot
    he moved 100units further, but then stopped
    undefined

  • Ubi-Borealis
    Ubisoft Support Staff 2877 posts
    Best Answer

    Hello there!
     
    I'd like to reach out to you all with an update. I'm happy to announce that the development team intend to deploy a fix for "A Sword-Shower in Anecastre" in TU 1.2.2. This update will be deployed 15 June, 2021 at 2 PM CEST / 8 AM ET.
     
    If you are still encountering issues with "A Sword-Shower in Anecastre" following TU 1.2.2, please don't hesitate to update this thread so we can take a closer look. Please include a video that shows the following:

    • You have the latest Title Update installed on your platform. You can view this information in the opening game menu in the bottom right-hand corner.
    • That the issue continues to persists in-game following this update.

     
    Additionally, please ensure that you have an up-to-date save uploaded to the cloud. We can then pass these reports to the development team for further investigation.
     
    Thank you! 😊

    Official Response
  • Lypitiern300
    11 posts

    I got through this quest fine but a few after it "A sword-shower in Anecastre" while following Aelfgar he is frozen on the road and won't move, I am on Xbox One and have done everything I can think of and been suggested but he still won't move.

  • FoolishPlanet34
    4 posts

    THERE IS A GLITCH IN THE BRAND NEW UBISOFT GAME, ASSASSINS CREED VALHALLA. In the MISSION, A Sword-Shower In Anecastre" in the Pledge to Lincolnscir. A mission that requires you to follow Aelfgar is very very bugged. Aelfgar will not move at all, this is the last mission i need to complete so i cannot proceed further until this issue i have is fixed, I have tried everything to fix it and nothing has worked. For example i have tried, loading to a previous save and replaying the mission, reinstalling the game, and some of the little things ive found on Reddit but nothing appears to be working, this is really starting to annoy me as im so very close to completing the game and this is the only thing holding me back.

    This is causing serious doubts on UBISOFT and its capabilities to be a good development company. This is poor work and it must be fixed immediately. 
    @ubi-swaggins

  • jesustsrikesbac
    Original poster 11 posts

    @foolishplanet34
    I agree. The worst part is that I was genuinely enjoying this game and now cant even proceed because it is completely broken. An AAA $60+ new video game by a reputable developer released so broken is terrible. I've played about 70 or so hours and now because of this I cant even finish the game and the only reply from Ubisoft in another thread is to reload an old save and lose my progress. No mention of when this will be fixed. I can overlook small bugs but something literally game breaking that doesnt seem to be fixed anytime soon is terrible. I would expect this from some type of indie developer on steam but from a big studio like Ubisoft? ....

    Really disappointing unfortunately. Doubt I'll buy any other new ubisoft games, not until after a few months when everything is actually fixed and not rushed out.

  • Kurfang
    10 posts

    @lypitiern300 Looks like the issue you are having is a known issue that is to be fixed in an update. Which gives those of us stuck on this quest something to look forward too 🙂
    https://discussions.ubisoft.com/topic/82440/unable-to-progress-in-a-sword-shower-in-anecastre

  • FoolishPlanet34
    4 posts

    I can’t find this screenshot. Can someone please put a video or a picture of the location your pushing him around in . 3 hours in and I can’t do this anymore

  • FoolishPlanet34
    4 posts

    @danigabraeel97 I need help,comment below

    @whatsadanny I need help, read comment below.

  • FoolishPlanet34
    4 posts
    This post is deleted!
  • SuperChakras
    1 posts

    MEE2. Has anybody fixed it yet?

  • Cm23xTuRnErx
    9 posts

    @ubi-baron this doesn't work when I reload my manual save I have the quest item in my inventory before I even go to the room to start the cutscene once the cutscene has finished the quest still doesn't update and the game doesn't register the quest item I've had from just exploring ...

  • Testyfy
    2 posts

    @FoolishPlanet34 @jesustsrikesbac
    I tried also many things, nothing helped

    If you didnt complete all other regions, u can go to the settlement and change region on the map, this is what i did in the meantime... u wont lose your progress in the current region

  • Alake314
    12 posts

    This is really upseting. I want to say stronger things, but not appropiate. I stopped saving because all saves become "corrupted" so I don't see the point in saving. This is really frustrating. I can't go on. I tried everything also. I want my money back. This game is rubbish. Launched before being remotely ready!

  • Mel1lo
    3 posts

    @ubi-ginge i done that while back, so you guys should have received the video and such 🙂

  • Kayser72
    1 posts

    [Resolu]
    Pas le choix il faut recharger au moment du festin pour hunwald une fois tuer les ennemis attendre le chargement, quitter le jeu relancer et partir à la rencontre de hunvald à la sortie du château et aller au campement à pied moi sa a marcher sur pc.

  • mawksee
    1 posts

    Same issue, stuck at "Follow hunwald" and he won't move from out side the camp. Annoying.

  • iR3iV3n
    1 posts

    so there is a way to push this forward, literally...

    all you need to do is to push the stuck character, identity depending on your previous choice to the siege camp near the castle (not the actual castle); in the camp there is a few fellows discussing siege near a table with the map and once you push him ALL THE WAY THROUGH THE WOODS quest just jumps to the next phase, which took me only about +2h to do that;

    note the guy gets stuck on anything really which is hard object (wall, ledge), but other then that just dodge into him and once he's back on two legs rinse and repeat, ideally in a single attempt as saving during the operation resets the guy back to original the point where he gets stuck again, tried after pushing for 10mins, didn't dare to do it later for the obvious reason.

    was also hoping that changing language would help, hence the german, but that didn't help

    you can use below for reference on what you need to do, but castle marker is placed incorrectly, you have to take him to siege camp, not the castle gate:
    https://streamable.com/6tw4gu

    @ubisoft - shame on you! you should really compensate users for this, since this prevents game completion

  • davidtreelife86
    1 posts

    The mission where you have to follow the guy and he wont move.

    spoiler

    I saw the suggestions to go back to another save, but before 54 hours is 14 hours to redo that alliance I would have to go back and redo many others. Any other suggestions?

  • Ratash97
    1 posts

    Guys, for anyone still having the same problem, you can move him to the platform by continuously shooting him with a hunter bow, takes about 3-4 full quivers... The next quest objective will trigger once you get him there!

  • CastOOr78
    3 posts

    In the quest A sword shower in Anecastre I need to follow Aelfgar but the NPC just don't move and so I'm blocked in the game. I have no way to load a previous save and nothing can be done to unblock the NPC. I have already reported the issue but my post was ignored. I have this issue since a week and the new patch 1.0.4 didn't help that why i report it again.

    As you can see in the picture the NPC don't want to move and it may be because i took his horse after the cinematic and so he's just stuck with no way to advance any futher in the game.
    undefined

  • Lypitiern300
    11 posts

    @cm23xturnerx I got around this, it'll take a while but I just kept running into him and knocked him closer and closer to where you're suppose to go and once I got there it continued fine but it did take me three goes and 1.5hrs, just keep running into him don't try to attack him with fire or get in any conflict cos he might run the opposite direction and/or return to his original spot

Suggested Topics

Community Details

88
Online
141.7k
Users
25.0k
Topics
129.8k
Posts