Continue your odyssey

Welcome to discussion

Quick Suggestions

Hello! These new forums are an open beta and we welcome your feedback in this section.
  • overduefart911
    5 posts

    @krimsontk Thanks for explaining, but are you kidding, this is impossible! Half the time I jog into him he takes 2 steps back the way we came... Think this will be addressed another way? I can’t seem to get that to work...

  • Alake314
    12 posts

    @alake314

    I discovered that if you "push" him to the destinaron where he was supposed to guide you, it works again!

  • KrimsonTK
    6 posts

    @overduefart911 Sucks to hear you couldn't get this to work, but at least you tried. Hopefully this gets addressed soon so people like you and me don't have to do these stupid work arounds

  • CastOOr78
    3 posts

    @ubi-swaggins Just me chlling with your half finished bugged game. It's really disappointing to be ginea pig for your game it's definitely the last Ubisoft game I will ever buy until you make some improvement on your development method. I had no responce about this bug from my post and you don't annonce it on the reported bug you better fix this soon or I will be a fervent activist against any game Ubisoft have and will make.

    It's not the first major bug in the game I encounter but it's the one that prevent me from finishing the game.

    undefined

  • FellbladeX
    3 posts

    @alake314

    I can confirm this does indeed work. I spent probably close to an hour pushing him along the road with my mount towards the objective point and the mission resumed as it should have. Thank goodness.

  • SlickyRicky4269
    7 posts

    @ubi-baron Still not patched out in 1.04

  • Adithyan_Cyrus
    1 posts

    I got another solution. Since I ran out of arrows when I tried to move the ealdorman, I went to the nearest shop to get arrows. The game autosaved at that point and I tried loading that save. After that the ealdorman was 200m away from the quest starting point on a horse and I was able to continue the game. Hope this helps.

  • IGOR2098
    3 posts

    @overduefart911 I have the same problem m8. That's annoying cause it is my last region to conquest

  • Ubi-Baron
    Ubisoft Support Staff 730 posts

    Hey guys,

    This issue has a fix identified for it, but as you noticed it wasn't included in the last update.

    At the moment we don't have an exact date for when this will be resolved, we'd advise keeping an eye on the Patch notes.

    Official Response
  • xXJohnnyboiiXx
    2 posts

    @alake314 Omg It actually worked!!!!! The community is trying harder than the actually game company that developed the game to fix its many bugs.

  • Adamcosta1988
    1 posts

    I have the same problem , used a bow , fire , restarting and loading old saves.. he isn’t moving from the bridge.. off the start of the quest..

    any more ideas ??

  • Seffcool
    1 posts

    How do i report a issue to the fourm?

  • GeneralCody053
    2 posts

    @ubi-spud having this issue 8 days later how is there not a fix for a game ending glitch. Making the game unplayable. Very disappointed in this game and all of its glitches.

  • Docta_Dee
    3 posts

    @whatsadanny I don't even see the camp on my map, can you provide further detail?

  • Aceagles00
    1 posts

    Same issue here, he’s just standing in front of a little bit about 200m from the starting point. I tried every single fix in this thread and every other thing I can think of, but nothing’s worked. The only thing I have left to do in the game is finishing each area 100% and I will occasionally go back to see if this has gotten fixed. Very frustrating after almost 60hrs of play time.

  • Ubi-Baron
    Ubisoft Support Staff 730 posts

    @gn0m388 This was not planned on being addressed in the last update, we'd advise keeping an eye on the Patch Notes for when this will be resolved.

    Official Response
  • LuckyJokerPL
    1 posts

    Can you just add restart or cancel quest option to the game? It will solve some problems, I don't think that's a lot of work for you guys, and I would help a lot, I have 2 quest glitched and I cannot do anything.

  • SlickyRicky4269
    7 posts

    @lypitiern300 Unfortunately this isn't possible for me. He's stuck halfway between the camp and where you begin to follow him. Initially he was inside the camp, then when I went back another time he was way outside the camp.

  • renegadewolf101
    1 posts

    Need help

    Hey guys, I’m about 50 hours in on my save file and I have an issue where my main objective is to follow Aelfgar. The problem is that they are not moving and I cannot speak to him or follow him, he just stands in place.

    The main issue is it is a main quest and I cannot continue farther into the story without it being fixed. As I said I’m 50 hours in and I am unable to revert to a save file prior to this quest issue.

    Is there anyone just to restart/reset a mission? I have done other story arcs, gone to Vinland and done any possible fix I have seen on forms but with no luck. Playing on Xbox Series X mission is A Sword-Shower In Anecastre.

    Thanks for any help.

  • jacobirish123
    2 posts

    Hello, I'm on what appears to be one of the final missions in the Lincolnshire segment. After choosing Aulfgard as the new Ealdorman, I see him and his crew waiting across the bridge for me so we can go and raid the traitor Bishop, but actually speaking with the new ealdorman is not possible. I run all around him, prompt fights with passing guards that he will engage in, kill civilians to resynchronize - and am still unable to get him to speak with me. I have tried everything. Including completing entirely different pledge sections to return to Lincolnshire, unable to continue beyond this point "Speak to new Ealdorman". I also tried traveling to the mission's monastery to assassinate the Bishop on my own, but he is unable to be harmed. I'm unable to beat this section and therefore the game... Please help!

Suggested topics

Community details

16
Online
124.0k
Users
21.3k
Topics
110.0k
Posts