ubisoft discussions

Quick Suggestions

  • standoffjosh
    78 posts

    @wmmurphy000 I’m not fussed about a refund in all honesty.

    It’s just crazy that it’s been 4 months since the game was released in November and this issue was raised week of release as a bug and still no fix. Only fixed spawn issue of outside the builders sheiks which still stopped players finishing the level. I can’t even get the builder to recognise the jars

  • Kayyfax
    2 posts

    This issues happen for almost more than 2 month, This game literally just got an update but still this quest is still bugged, for my problem, there is no quest description under quest title and i stucked there because the builder doesn't talk thus i can progress the game

    Anyone had the similar issues or do you have any solution regarding this problem?

  • LedoveeeKladivo
    64 posts

    I hade this problem earlier, so I found players fix (not official), to change English language to any other. So I did it for this quest and it helped to me. If you play in eng, give it a try 😉
    If not, you will have to wait for next patch (the fact is that 1.0.4 did not repair this bug, 1.1.1 did not repair this bug....and very sad is that this newest patch still not repair this bug).

    Looks like Asgard is very weak part of this game 😞

  • nonchalance_kec
    7 posts

    @ledoveeekladivo they should add the option to reset/restart/abandon a quest

  • NotSo277
    15 posts

    @ledoveeekladivo I have finished the story line about 4 weeks ago and have been stuck on this mission since which means that I can't progress to Jotunheim.
    The builder is not there and the big blue guy's just keep running through the green screen and I keep killing them with no ending in sight.

    If I change to another langauge how am to know what is going on! Will that restart the mission!
    Any help would be great.

    And ... Update 1.1.2 has not fixed it for me on Xbox One.

  • LedoveeeKladivo
    64 posts

    @notso277 as @nonchalance_kec said, here should be reset quest option to avoid this stupid bugs. Sorry that my help did not help you, hope fix will be released soon.

    btw....I am on PC

  • Mexicore_93
    3 posts

    @ubi-wan The new patch didn't address this... It's been months and I still cant get past Asgard because of this. Can you at least remove the fact you die when leaving the bubble??

  • standoffjosh
    78 posts

    Can we have an update on this please? We need more insight onto when you’re actually going to fix this issue. Why isn’t it being prioritised as urgent? It’s been under investigation now for almost 4 months, we need an ETA on a fix

  • guest-V4gV3lDM
    1 posts

    The builder will not recognise the jars at all. So I left and now I’ve came back to realise this is a big bug and you have to reload an earlier save. Which is ridiculous to say I have to go so far back to do it.Youve had four months to fix it and you haven’t even tried in any update. This is a game breaker glitch something really needs to be done about it you’ve essentially sold a broken game and this is not the only bug. There’s no point giving out condesating ps trophies and mission with the title “this is not a bug, it’s a feature” when your games full of bugs that stops it working. Will you honestly ever be able to fix it or is Asgard a location that’s never going to work for so many people.

  • standoffjosh
    78 posts

    @guest-v4gv3ldm we’re all in the same boat mate, I’ve had this issue since November the week off release. Very frustrating when we’ve uploaded saved games and got videos off the issue, it’s affecting users on every platform so we have done all the investigation work. Just needs a fix implementing, surely justifies a hot fix patch for this level

  • d24rohit
    13 posts

    The case which I had opened about this issue has been closed saying “Issue is resolved”. Obviously thats not true. Not sure if uploading the saved games or the videos of the issue is also helping. Very disappointing.

  • standoffjosh
    78 posts

    @d24rohit same here it seems Ubisoft have a ridiculous close if no response policy after 3 days in support cases. What more can we add if the issues still not fixed and we’ve already submitted videos and saved genes off the issues. They don’t feedback any information on this is with such and such department who have replicated the issue also and are now investigating a fix. No estimated time of fix provided, I work in IT and their whole ITIL and ITSM framework in place is none existence, resulting in us receiving terrible customer support where our issues should be quick easy wins for the developers to fix.

    Would be nice if we could get an official response on this please from Ubisoft

  • standoffjosh
    78 posts

    @ubi-borealis can I get your thoughts on my above post please? Think we’re all getting very frustrated about defensive Measures issues not getting the attention it deserves

  • wmmurphy000
    20 posts

    They won't respond since they can't duplicate the issue.
    You'll get the cut and paste "We're sorry..."

    [Image removed as it didn't adhere to forum rules]

  • Ubi-Borealis
    Ubisoft Support Staff 6078 posts

    Hello all!

    I apologise for the delayed update. The development team are still investigating this issue further, which is why it was not included in TU 1.1.2. We apologise for any disappointment caused by this. The player support team is checking in with them regularly for updates. Once we have any new information to share from the investigation, it will be posted within this thread or in our News & Announcements forum, so please keep an eye out in these places for future updates.

    @standoffjosh - We are unable to provide a definite ETA for a resolution. All up-to-date news and updates will be posted in our News & Announcements forum, so I would recommend checking here regularly. Thanks for taking the time to share your feedback as well. Please note that you're able to reopen a closed support ticket at any time if you require any further support, or if you have any further queries.

    @wmmurphy000 - I have removed your image from your post as it goes against our forum rules. Please make sure any content you share here adheres to these rules, or it will be removed and you may be sanctioned.

    Thanks all! 😊

    Official Response
  • jonolh
    2 posts

    I am beyond dumbfounded with this glitch.....it makes my bloody boil. I can't finish the friggen game....I can't progress.
    This should be illegal!
    Xbox Series X - first game I get is this........and I'm still here.....

    Painter gives no further prompts.
    He just paint the pole over and over....
    Then I run out to bring some baddies in....kill them....run out of them.....die trying to find more.....nothing happens....NOTHING HAPPENS.

    I TRIED reloading 1000s times. In different ways with different languages.........NOTHING....NOTHING!!

    THIS IS A JOKE. IM SICK OF THIS.

  • jonolh
    2 posts

    @jonolh

    UbISOFT just give me the ability to skip this mission for all I care.....this is a joke

  • standoffjosh
    78 posts

    @jonolh I feel you’re pain mate, I’ve been stuck on this level since November. I get my hopes up every update too see this level on the issues to be fixed and get disappointed every month

  • Sharpie620
    3 posts

    @jonolh exactly i honestly dont care about the mission just give us an option to skip it or restart it

  • Oneshotdev
    1 posts

    I tried all the ways to kill all the blue guys in this quest and nothing happens. FIX IT.

Suggested Topics