ubisoft discussions

Quick Suggestions

  • Solved [RESOLVED] Assassin's Creed Valhalla missing from Ubisoft Connect library after purchase | POST HERE

    0 Likes/1195 Replies/14428 Views
    Kenopy24
    1 posts

    Same issue as the rest bought the game in ubi store and is not showing up in my library

  • atiinqvisitor
    1 posts

    I have the same issue, and support chat died on me.

  • sctvorp
    5 posts

    This is kinda [censored], maybe we should cancel and buy on the epic game store instead?

  • aerkfeed
    6 posts

    Happened to me as well. I bought the game a few mins ago. Since my account are link to steam games the "Store" tab is hidden and I have to bought it through browser. This is my first time buying something from Ubi store too.

  • cherrieomega
    1 posts

    Just preordered the game like an hour ago and have the same issue, even got a confirmation email. This is crazy since Legion worked with no issues at all.

  • Kajny_
    1 posts

    Hi Ubi,
    Today i bough this game and like other people, doesn´t show in my library and doesn´t recieve confirmation email.

  • hugRmunR_
    7 posts

    Hi there. I ordered Valhalla not long ago and the game does not show up in my library (games have always shown up immediately for me before)

    I have received the order confirmation, and it does show up in my orders in the app (order page says "Your game is displayed in the Uplay library", which it isn't)

    Would be lovely if I would be able to play the game on release 😃

  • Zuther11
    1 posts

    @hugrmunr_ I am also experiencing this issue! bought the game about 20 mins ago!

  • mint-drops
    5 posts

    Hello,

    I was able to preorder through browser and received a confirmation email of the purchase. However, the game did not show up on my library in the Ubisoft Connect app (PC).
    Is there any way to fix this?
    I already sent a support ticket. Nobody is answering the support ticket and LiveChat is unavailable too. Please help.

  • Feran0ks
    1 posts

    @zuther11
    Having the same issue. I was hoping to pre load the game but it isn't showing up in my library.

  • az4zin
    2 posts

    Same, bought it 1 hour ago. submitted ticket as well

  • Ralleeen
    4 posts

    Hi, im experiencing the same thing. Bought the game an hour ago on the web store but if im on Ubisoft Connect it doesnt show in library. It tells me i have to buy it again in the Ubisoft Connect when trying to preload. I have recieved an email with order details. Getting disappointed, was really looking forward to the game tonight.

  • Tar-Naugrim
    52 posts

    +1

    Bought the game about an hour ago and it's not showing in my library either. I've also opened a ticket, but I doubt they'll reply anytime soon.
    Ubisoft disappoint once again with their store/uplay.

  • cruzg1
    2 posts

    Just bought the game but its not showing in my library. It appears in the "My Orders" tab in Ubisoft connect and says it should be in library but its not. I was already charged for this and would like to play at launch. Can anyone help? Opened a ticket but seem to be getting no response. Ref # 13125678

  • johnchikr
    5 posts

    Same issue here. Purchased it about 30 minutes ago through the browser, checked Ubisoft Connect, and the game is simply not there. I was gonna go to sleep while it downloaded, but apparently not.

  • Tar-Naugrim
    52 posts

    @cruzg1 There are a few of us and there is also anotehr thread for the same issue. I'm alos affected by this. Was hoping to start the pre-load and have it ready.

  • nielsoonk
    13 posts

    I assume due to high level of traffic you might experience a delay in receiving your purchase. Please be patient as I am sure you'll be able to play the game soon.

    If you'd like to create a support ticket feel free to do so here; https://support.ubisoft.com/

    Signed by Gen#0002 Moderator for the official Assassins Creed & Immortals Fenyx Rising Discord • Do you need assistance? Do not hesitate to DM me here or on Discord • All comments are my own and can be wrong as I am person and not an all knowing robot :-).



  • Twizted_Drake
    2 posts

    I'm having the same issue, only difference is I ordered it through Ubisoft Connect on 10/25 and it's still not showing showing up in my games list.

  • Junarcel
    1 posts

    I also dont see my game in my library. Bought it about 30 minutes ago. stop the cap niels!

  • ahmetbayramas
    1 posts

    same here! I want to preload the game since I do not have the best internet. Please help!

Suggested Topics