Welcome to discussions

Quick Suggestions

  • Gaurwaithi
    Original poster 2 posts

    My setup:
    Nvidia GeForce GTX 1070 Ti
    Intel Coffee Lake Core i5 8600K 3.60GHz
    16 GB RAM

    I play at High with 60-70 FPS but the graphics are blurry, at distance. The only solution I found was to increase Resolution Scale to 200%, but I lose 30-40 FPS.
    Do you know of this issue, will there be a fix?

  • Contrary to popular belief, Lorem Ipsum is not simply random text. It has roots in a piece of classical Latin literature from 45 BC, making it over 2000 years old. Richard McClintock, a Latin professor at Hampden-Sydney College in Virginia, looked up one of the more obscure Latin words, consectetur, from a Lorem Ipsum passage, and going through the cites of the word in classical literature, discovered the undoubtable source. Lorem Ipsum comes from sections 1.10.32 and 1.10.33 of "de Finibus Bonorum et Malorum" (The Extremes of Good and Evil) by Cicero, written in 45 BC. This book is a treatise on the theory of ethics, very popular during the Renaissance. The first line of Lorem Ipsum, "Lorem ipsum dolor sit amet..", comes from a line in section 1.10.32.

    Contrary to popular belief, Lorem Ipsum is not simply random text. It has roots in a piece of classical Latin literature from 45 BC, making it over 2000 years old. Richard McClintock, a Latin professor at Hampden-Sydney College in Virginia, looked up one of the more obscure Latin words, consectetur, from a Lorem Ipsum passage, and going through the cites of the word in classical literature, discovered the undoubtable source. Lorem Ipsum comes from sections 1.10.32 and 1.10.33 of "de Finibus Bonorum et Malorum" (The Extremes of Good and Evil) by Cicero, written in 45 BC. This book is a treatise on the theory of ethics, very popular during the Renaissance. The first line of Lorem Ipsum, "Lorem ipsum dolor sit amet..", comes from a line in section 1.10.32.

    Contrary to popular belief, Lorem Ipsum is not simply random text. It has roots in a piece of classical Latin literature from 45 BC, making it over 2000 years old. Richard McClintock, a Latin professor at Hampden-Sydney College in Virginia, looked up one of the more obscure Latin words, consectetur, from a Lorem Ipsum passage, and going through the cites of the word in classical literature, discovered the undoubtable source. Lorem Ipsum comes from sections 1.10.32 and 1.10.33 of "de Finibus Bonorum et Malorum" (The Extremes of Good and Evil) by Cicero, written in 45 BC. This book is a treatise on the theory of ethics, very popular during the Renaissance. The first line of Lorem Ipsum, "Lorem ipsum dolor sit amet..", comes from a line in section 1.10.32.

  • Ubi-Spud
    Ubisoft Support Staff 702 posts

    Hi there! Would you be able to post a screenshot of what you mean? It may just be a resolution issue, however.

    Official Response
  • Gaurwaithi
    Original poster 2 posts

    @ubi-spud
    Here is a screenshot with my normal options:


    Here with 200% resolution scale:

    Here are my game settings:


    Take a look at the branches of the trees and the leaves, you can see that they are pixelated. Also fire, odin's sight, water are pixelated.

  • RedIndianRobin
    188 posts

    @ubi-spud I tried to bring this issue into notice. People on reddit pointed this out. No response from anyone.

  • PatoDonalld
    1 posts

    Same problem here, the games suck

  • PrimusPalus
    1 posts

    I have the same problem. I'm running the game everything maxed out in 4k. Looks like blurry trash. Here's a screenshot and you see the flag in the top is completely pixelated, the ground, wall, and other textures are terrible:

    https://imgur.com/Dat4vmA




  • MrFisse
    1 posts

    @primuspalus The same here, the [censored] type of AA they chose and which cannot be turned off makes the entire game looks like its out of focus. Nvidia users can atleast activate Geforce Experience overlay and add a sharpen filter via the game filter section. Makes it look a little better atleast.

  • blinder022
    2 posts

    @gaurwaithi was having the same issue and apparently, this also works for valhalla.

  • SM1LL3
    2 posts
    This post is deleted!
  • SM1LL3
    2 posts

    @ubi-spud It has to be connected with forced TAA, there are no settings to disable it in game. It's very blury on 100% resolution scale on my computer too, is there a way to fix it? I have disabled MFAA and still the same

  • KickItGaming
    1 posts

    Have the exact same problem. Tried everything, still does not look right.

  • RedIndianRobin
    188 posts

    @sm1ll3 There is no forced TAA in this game. The AA they used is Temporal reconstruction. Their own AnvilNext 2.0 engine does a good job of eliminating jagged edges that they don't even use TAA. Hardware unboxed spoke about this as well.

  • longjohn119
    775 posts

    @blinder022

    Turn off Depth of Field ..... It's only supposed to work in cut scenes but it tends to make things blurry a lot ...... It's one of the most worthless gimmicks besides motion blur .... I paid $500 for crisp clear high resolution graphics only to intentionally blur most of the screen so it looks like a fix lens camera .... Frankly I don't get why anyone thinks simulating 100 year old technology is preferable ...... You'll probably even gain a couple of FPS in the process ......

    Go look at my YouTube channel most of which was with a RX 5700 except some of the newer ones which area RTX 2080 Super and none of them look blurry at all
    https://www.youtube.com/channel/UCNOysgvZQXRKc3_4POuBrmA

  • blinder022
    2 posts

    Try turning off multi frame sampled AA in nvidia control panel and turning hsarpness up. Worked wonders for me.

  • Lotan_
    10 posts

    So still no way to turn of the AA?

  • RedIndianRobin
    188 posts

    @lotan_ Just use a reshade if it bothers you that much.

  • Lotan_
    10 posts

    @redindianrobin
    that's not a solution, adding another filter on top of already existing filter just ruins the image even more

  • ElzaDay
    1 posts

    I have a same issue. Textures are pixelated at 100% resolution scale , raising it to 200% kills the framerate.

  • prokid1911
    1 posts
    Try turning off multi frame sampled AA in nvidia control panel and turning hsarpness up. Worked wonders for me.

    THe option is greyed out in my Nvida control panel. Any idea why?

  • Schother12
    63 posts

    @prokid1911
    Which of the settings is greyed out? The MFAA seems not to work with AC Valhalla anyway as for me it's also saying "not supported for this application".

    In any way, add sharpening and increasing resolution through resolution scale or DSR can improve things but still not replace a complete turn off option.
    Also for me I need to use such a high resolution to avoid the blur to a nice level that the came is barely playable anymore.

    We simply need a turn off option.

Suggested Topics