Continue your odyssey

Welcome to discussion

Welcome to discussion

Quick Suggestions

Hello! These new forums are an open beta and we welcome your feedback in this section.
  • DenhomChiken
    17 posts
    This post is deleted!
  • DenhomChiken
    17 posts

    Actually it is now in the known issues thread just added today so this makes me quite happy it looks like it will be fixed in the next title update. Will have my full support again after that one so thanks for letting us know it's the near future Ubi! 😊

  • ZHandsz
    1 posts

    Wanted to flag an issue to see if any others were experiencing the same. I'm playing on a PS4, for the obvious reason that it's near impossible to get a next-gen console, but it seems that even after the recent patches I'm still experiencing bugs that were supposedly fixed.

    First off the quiver, it's still showing me that I have 12 arrows and I'm one upgrade away from a maxed out quiver. I've tried the Vinland workaround, but still no luck. Aside from that, I was having the "floating arrow" issue where the quiver didn't appear, but now I have a quiver with no arrows. Even if I have max capacity, still appears empty at Eivor's side.

    Secondly the fabric. I understand that there was an issue where fabric was finite and stopped spawning from chests, but in patch 1.04 that supposed to be fixed where you could purchase fabric in Ravensthorpe after getting to Settlement level 6. I've reached level 6 and still no fabric from the store, is anyone else seeing something similar?

    I appreciate any help with how to resolve these!

  • Cole_239
    2 posts
    This post is deleted!
  • Cole_239
    2 posts

    I also have this bug on PS5 version. I’m level 400 plus 39 mastery points, fully upgraded pouch and quiver, level 6 settlement. This has taken 126 hours and I am clearing everything in order to platinum trophy this.

    I have completely cleared approximately 50% of the territories and haven’t received any fabric in that time. This includes Hamtunshire, Glowecestrescire, Essexe, Wincestre etc. all high level areas and have been scouring for all chests through all areas.

    Please add the fabric back to the trader to purchase. I need 4 more (as I have 1) to compelete Dobby’s Altar in Eurvicscire. I hope this issue is resolved soon as I want this platinum.

    Great game otherwise!

  • Furkan66386638
    9 posts


    an average of 20 chests left. do you open it? will it fix with the update in the future? will a fabric come out of one of them? everything at the last level.

    I need one fabric 😞 for last side mission
    Im playing pc

  • vitta.Rocko
    1 posts

    Any updates on this? I need the last 2 to complete the game.

  • guest-9kWDVDeF
    1 posts

    Over 120 hours into the game, the offering alter is the LAST thing I need to do to 100% every territory. Please fix this bug with not being able to loot or buy fabric I literally have 4/5 fabric for this last offering alter.

  • leighsmagic
    2 posts

    i have 2 issue getting fabric on Xbox one can’t buy it anywhere or find it in chests looted everything in the game near enough and can’t do way of the berserker mission



  • Alexandru27p
    18 posts

    Hello! There is a problem with "fabric material". After a while, you stop getting it and you have to choose between upgrading ration/arrow capacity or to offer fabric to the altar. I decided to give them so I could finish every mystery in the game and to get the achivement "Completionist all the way", that I got on 27.11.2020. I heard that some people could get them after the patch 1.04 but my problem still persists. It's stuck at 7 fabric and need 5 more to upgrade last state of quiver.undefined

  • TBA_Marko
    1 posts

    When you max your quiver and rations you stop getting fabric. And you need fabric to complite dobby altar mystery.

  • SherlockGhostBR
    2 posts

    problem finding fabrics. I'm having trouble finding fabrics, needing four units to complete the altar. making it impossible to release achievements. I’m already at level 400+ and I’ve run the entire map and don’t drop the fabric.

  • WildHunt
    62 posts

    @sherlockghostbr There was a bug where if you maxed out your rations and arrows, fabric would no longer spawn. It sounds like it may not be fixed yet.

  • GZA2008
    1 posts

    Can't find any fabric to finish quest or upgrade after latest patch.
    Xbox Series X.
    Please fix ASAP I stopped playing for three weeks due to the arrow capacity bug (stuck at 12max and the war shouts during loading and a few other annoying bugs drunk after load in, random npcs following me etc) during the arrow bug debacle I upgraded my quiver to full but no change to capacity then after the patch I came back to the game with fingers crossed only to find i still only had 12max arrows, I then went onto the inventory and hid bow appearence and then re clicked to show it and the quiver dropped back down to the 4th upgrade. Now I can't find any fabric anywhere to upgrade it back up, also I just found whilst playing today an offering altar that wants x4 fabric which is great seeing as I can't even find any to re upgrade the quiver to begin with let alone spare any for the offering meaning I can't 100% the game.

  • PresidentPrez1
    15 posts

    @gza2008 i thought it was just me that experienced the war cry and screaming during loading screens. It's bloody horrible isn't it. i too stopped playing four neatly 4 weeks since the previous update to the latest one because of bugs. But nothing has changed or been improved i won't be buying anymore ubijoke games after this one.

  • tommy96allan
    2 posts

    Hi,

    When will this be fixed please? I have 0 fabric and haven’t looted any in ages, I need 5 for the altar for 100%. My rations are fully upgraded but my quiver is not even fully upgraded, one away.

    This is stopping me from getting the platinum.

  • Chriz297
    5 posts

    I still need 13 fabric to platinum the game, Ive done practically everything and I've run out of chests to loot now and its really getting annoying. I've seen a lot of people complaining about this but I can't see anything being said to patch it. Any ideas?

  • Chriz297
    5 posts

    Im on the ps5 and I've done everything apart from upgrade the quiver and dobbys altar. I need 13 fabric to finish the game off and get platinum but after putting in 145 hours its really annoying that something so stupid is holding us all back. I've seen many people complaining about this but I've never seen Ubisoft give any answers for it

  • goodfellat88
    1 posts

    I still cant get anymore fabric. I need 5 more to finish the alter and get platinum. How do i do this plz????

  • TheCptDanger
    2 posts

    I had my quiver and rations pouch fully upgraded and then my quiver disappeared and went back to level one as far as capacity goes. I did the Vinland trick (go to Vinland, empty quiver, return to Ravensthorpe) and it brought my quiver back with four upgrades missing and now I can’t find fabric anywhere. This is incredibly frustrating. I spent hours hunting down fabric to fully upgrade. I paid a buttload for this game. I’d be happy if I could just get some more fabric and upgrade my quiver again. 😒

Suggested Topics

Community Details

72
Online
129.2k
Users
22.3k
Topics
115.4k
Posts