Welcome to discussions

Quick Suggestions

  • Sparky702
    1 posts
    • PS4
    • fully upgraded rations pouch
    • Carrying 2 Fabric
    • Cannot complete the Altar nor the final upgrade to the quiver.
    • Fully upgraded rations after update 1.1.0


    I've reached the max level of 400 and have completed everything aside from the altar; the smaller chests that I loot currently contain either supplies or more iron and leather; haven't had any drop fabric for a while.


  • StevenB82
    13 posts

    Since i finished the Quiver i am not able to buy or find Fabric anymore. I could buy Fabric since my Settlement reached Level 6 and after finishing the Quiver it is not possible anymore until now after 1.1.1
    I am also not able the find fabric in high level regions since then.
    I realised to late, so i couldn't load an older Savegame.

  • dutton93
    9 posts

    I just want to echo the thoughts of everyone else going through this issue.

    This has been raised numerous times by so many people, and the forum seems to have gone very quiet in terms of admin/company support.

    This may not be perceived as a major bug, but the fact it prevents people from getting the final trophy/trophies in my opinion it needs to be addressed quickly otherwise consumers are going to continue to be disgruntled.

    Until I’ve read that this has been resolved, I won’t be playing this game again. 100 hours of my time wasted.

  • TheSmio
    26 posts

    I agree with everyone else, an update would be really welcome. I am sure the devs and the support team have a lot of work to do, but we haven't had an official update about this issue for more than two weeks already. I am starting to worry that this issue will never be fixed, because the number of people who came across this issue isn't really worth it and there won't be new people with this issue because this probably doesn't happen anymore if you create a new save in the recent versions. I really hope this isn't the case and Ubi didn't forget about us.

  • CyborgianToast
    2 posts
    This post is deleted!
  • Kormac67
    622 posts
    With this issue being something that halts my 130+ hours of gameplay because there's is basically nothing left to do

    And if they fixed it? Then you could do the altar, and there would be nothing left to do again. So what is your point?

  • ARMADILOMANdog
    7 posts
    This post is deleted!
  • ARMADILOMANdog
    7 posts

    @kormac67
    (Other account, same person, not sure what happened there)
    My bad wording, should have wrote "I have spent 130+ hours trying to obtain 100% completion and my platinum trophy" just stressed that spending that much time trying to achieve something, only to not be able due to a known problem and yeah I know, very first world problem and yeah, definitely could have worded it better.

  • DeekyJay
    2 posts

    While I understand that this may be frustrating to us (I myself, with over 140 hours in this game and need a few fabric to actually 100% it), I think it is valuable for us to see the bigger picture here.

    Is this bug frustrating and blocking us from our goal? Yes.

    Is this bug effecting the majority of the player base? No.

    Is this bug blocking us from completing the main story? No.

    For the two previous reasons listed, I think this is fair to say that we will and should respectively wait. I get that it's annoying that we can't finish 100%, but there are other people out there today unable to even finish the main quests due to bugs. That's a much worse experience for those players compared to what we're dealing with here.

    Ubisoft is clearly aware of the issue and has even gotten the developers to investigate some of our save files to further narrow down the issue. You should not take their silence as "Well, we aren't going to fix it", but rather as "We are still investigating" or "We understand the issue, but it's not the highest priority for us right now"

    When you compare this bug to bugs that literally crash the game or just straight up stop you from continuing the story, it's obviously (at least to me) that this isn't a high priority.

    The best we can do right now is to continue to give VALUABLE information (Specifically, what the Support Staff asked for) and wait. They have no reason to abandon this, it's already in their system and being looked at.

  • LittleYanYay
    7 posts

    @ubisoft Had a fully upgraded quiver before the 1.1.0 update broke it. Now after the 1.1.1 upgrade has "fixed" the quiver issue i now have a no longer fully upgraded quiver and all the fabric has been looted already since i am at a 403 power and the only thing left to do in the game is finish the Order/Father quest line but THAT is also STILL broken after the 1.1.1 upgrade. How are you fixing the fabric issues? Can it be purchasable in stores? Please update your community... we are ALL very aggravated that this wasn't fixed with the 1.1.1 update.

  • RyanThomasIV
    1 posts

    @oli1988

    I have been unable to complete Dobbys Altar since November due to no fabric spawning. I maxed out quiver and rations before i did the altar, so i am assuming this is why the fabric didn't spawn. This would need to fixed asap, make it available to purchase from the trader in the settlement. This issue has been going on for far to long and clearly there are thousands of people facing the same issue.

  • brotn0
    3 posts

    Same problem at PS4. 160 game hours, all arcs, settlement level 5 (due the raw material bug) map complete (except dobby altar due the fabric bug)... 2 bugs that steals me platinum trophy at PS4 after 160 game hours...

    The last patch dont solve the trouble

  • DenhomChiken
    17 posts
    This post is deleted!
  • DenhomChiken
    17 posts

    Actually it is now in the known issues thread just added today so this makes me quite happy it looks like it will be fixed in the next title update. Will have my full support again after that one so thanks for letting us know it's the near future Ubi! 😊

  • ZHandsz
    1 posts

    Wanted to flag an issue to see if any others were experiencing the same. I'm playing on a PS4, for the obvious reason that it's near impossible to get a next-gen console, but it seems that even after the recent patches I'm still experiencing bugs that were supposedly fixed.

    First off the quiver, it's still showing me that I have 12 arrows and I'm one upgrade away from a maxed out quiver. I've tried the Vinland workaround, but still no luck. Aside from that, I was having the "floating arrow" issue where the quiver didn't appear, but now I have a quiver with no arrows. Even if I have max capacity, still appears empty at Eivor's side.

    Secondly the fabric. I understand that there was an issue where fabric was finite and stopped spawning from chests, but in patch 1.04 that supposed to be fixed where you could purchase fabric in Ravensthorpe after getting to Settlement level 6. I've reached level 6 and still no fabric from the store, is anyone else seeing something similar?

    I appreciate any help with how to resolve these!

  • Cole_239
    2 posts
    This post is deleted!
  • Cole_239
    2 posts

    I also have this bug on PS5 version. I’m level 400 plus 39 mastery points, fully upgraded pouch and quiver, level 6 settlement. This has taken 126 hours and I am clearing everything in order to platinum trophy this.

    I have completely cleared approximately 50% of the territories and haven’t received any fabric in that time. This includes Hamtunshire, Glowecestrescire, Essexe, Wincestre etc. all high level areas and have been scouring for all chests through all areas.

    Please add the fabric back to the trader to purchase. I need 4 more (as I have 1) to compelete Dobby’s Altar in Eurvicscire. I hope this issue is resolved soon as I want this platinum.

    Great game otherwise!

  • Furkan66386638
    9 posts


    an average of 20 chests left. do you open it? will it fix with the update in the future? will a fabric come out of one of them? everything at the last level.

    I need one fabric 😞 for last side mission
    Im playing pc

  • vitta.Rocko
    1 posts

    Any updates on this? I need the last 2 to complete the game.

  • guest-9kWDVDeF
    1 posts

    Over 120 hours into the game, the offering alter is the LAST thing I need to do to 100% every territory. Please fix this bug with not being able to loot or buy fabric I literally have 4/5 fabric for this last offering alter.

Suggested Topics

Community Details

123
Online
141.0k
Users
24.9k
Topics
129.1k
Posts