ubisoft discussions

Quick Suggestions

  • JBC1123
    3 posts

    @ubi-baron I'm on PC, and have had the same issue. I answer all of his questions, but the quest does not complete. From what I saw he is supposed to send you to Thieves' Warren. I wonder if my issue is that I already cleared it out for loot before I talked to the druid. Meanwhile, I've been running around the map hitting up loot spots and mysteries and hoping for a fix soon so I can progress in the plot. I tried again after spending a day doing other things, but no luck.

  • disdis55
    1 posts

    I am playing on PC. I can not complete the mission " Clues and Riddles". After I have given the right answers to the druid, he says " cudd Lladron". But the speak marker doesn't go away and I am having the same conversation all over again. After that section the quest must be completed ( ı have seen from walkthroughs) but it doesn't. It is the last section to go on with the story and I can't continue. Please fix it URGENTLY...

  • bddeath05
    1 posts

    I am having the same issue with this quest. I have left and completed other quest while waiting for an update. The update came through today and I am still unable to progress through the quest.

  • kevinstites
    6 posts

    I'm having this exact problem on PS4

  • ImMadBroXBOX
    2 posts

    I'm having the same problem even after 1.04 update. The druid's door is open but he won't talk with me or do anything. There is no button to even interact with him.

  • guest-NXmlSx0F
    5 posts

    I burned all 5 hay statues and it won’t let me progress it still says to help halewyn prepare his ritual. I’ve gotten 80 hours into the game and I don’t want to reset it and I thought the new update fixed it.

  • edelgiud
    13 posts

    Same problem here guys. I cannot progress past this point. This is my last section to complete most of the game. I went to another section first, completed that one, came back to this, but it doesn't start over, it is still at the same point. The 5 straw men are lit, all clues found, but won't progress to say to go see Halewyn....


  • udinbakk
    1 posts

    The same problem - after talking with druid and solving his riddles nothing happens.
    More than a week has passed - an issue affecting dozens of players has not been resolved!
    I have requested a refund, as the product was found to be defective.

  • Bafotsi
    1 posts

    there is a bug on the door , it will not let me interact even though i'm dressed with the goat mask . i've tried everything , nothing worked so far . please solve it as we can not progress any further.
    pc platform

  • SoulmasterxX
    37 posts

    I only have this one to progress



  • paratrooperrich
    4 posts

    @gymtan having the same problem for 2 days now. I did everything even finished other territories and still cant talk to him.

  • paratrooperrich
    4 posts

    @bafotsi same boat been two days. this sucks

  • Dev_86
    6 posts

    Hey, I’m having bug on the quest “Clues and Riddles.” I did everything but it won’t let me get through the next mission. Playing on ps4.

  • Dev_86
    6 posts

    Still stuck on “Clues and Riddles” quest even after update.. Help pls!

  • Ubi-Swaggins
    Community Manager 437 posts

    Hello everyone, I am sorry to hear that you are still having issues with this quest.

    It is still under investigation with the team.

    Once we have more information to share we will do so.

    Official Response
  • SupremeCymbrani
    12 posts

    I’m also having trouble with this quest. Basically the same as everyone else. Found all clues etc but now there’s no quest marker so I can’t progress further.
    Hoping this can be fixed.

  • SoulmasterxX
    37 posts

    Today I complete 2 weeks without being able to play, I already did everything I could do in the game and I can't continue because of this bug, incredible this delay in solving such a serious problem

  • Tigress601
    7 posts

    I'm having the same issue. Went to find all the clues then my disguise vanished and I know it's definitely not in my inventory. Now I can't compete the quest because of it.

  • noromoto
    1 posts

    Same problem as everyone. I can't load save. This really need to be fixed.

  • vibewell88
    1 posts

    On clues and riddles. I can't speak to the Druid to answer his riddles the final time? Is there any fix to this? I'm stuck and not able to move on from this point...

Suggested Topics