ubisoft discussions

Quick Suggestions

  • Dev_86
    6 posts

    Oh whoops my bad I meant to say new gear set and other stuffs

  • Ubi-Borealis
    Ubisoft Support Staff 6075 posts

    Hello there everyone!

    I apologise for the delayed response. Thank you for continuing to update this thread with your reports and experiences of the issue. Allow me to provide you all with an update, as well as to answer some questions/statements within the thread.

    As mentioned by both of my colleagues, Ubi-Woofer and UbiWan, a fix for this issue is due to be implemented in an future update. I'm afraid that we don't have any additional information to share regarding this update, including when the fix will be deployed. Once we have more information to share, we will update you all within this thread.

    We apologise for any inconvenience caused, and appreciate your ongoing patience and understanding. If you have any additional questions or information that you wish to share, please don't hesitate to update the thread 😊

    @TylerEmma2015 - As the issue you're encountering is different to the one discussed in this thread, I would suggest finding a more appropriate thread for your issue, or creating a new thread so we can keep track of it separately.

    Official Response
  • travjones58
    1 posts

    can't even talk to the guy with mask on . . no old saves. on pc. . no you cannot have a screenshot. . yes we should all seek a refund to get ubi in gear. . it is ridiculous that i should have to do anything except play the game i paid for . . . p.s. been waiting at this guys door for a patch for weeks. . . get it together already

  • TylerEmma2015
    76 posts


    that’s fair enough you called me out, but my problem is with this mission the mask and cloak stuck on character I can’t find the druid and I get complete drunk screen even talking to modron this is only quest that can’t be done in order for me and everyone else to continue all I’ve been doing is answering a question to other people and is it true an update is coming 15th 17th as on YouTube a guy called jorapter is saying he works close with you at Ubisoft and says fixes will be implemented basically as you have to give us a new mode before Christmas which in course is an update so at least we can do the campaign before you start rolling our Ireland and Paris dlc’s and even more content I’m not arguing it’s just a lot of people on here are behind me in saying this needs a fix and fast as we love the game only reason others are getting annoyed

    big respect to you guys

  • dr.tanuky
    1 posts

    Re: [Unable to progress with "Clues and Riddles" | POST HERE](/topic/83619/unable-to-progress-with-clues-and-riddles-post-here)

    As of Dec 11, this problem persist. I cannot talk to the druid.
    I have followed the instructions and it doesn't work. Even continued with other side quests and the bug continues and return, and the bug continue. Xbox One S.

  • SoulmasterxX
    37 posts

    @ubi-borealis what is the use of notifying that you found a solution if the correction has no date?

  • eindje01
    1 posts


    even after finding all the clues I cannot give the answer to the druid’s first question. I’ve tried fast travelling bank and forth, reloading, restarting the game. Nothinng helps and now I’m stuck.

  • guest-0u3ALuuF
    3 posts

    playing in PS4-For me am also stuck with druid and i burned all 5 burning men then the next option wasnt coming. I went and completed rest of pledging (higher level ones) all the zealots killed. went to Norway again and found all the treasures and abilities .
    Update completed still having issue. watched youtube there most have no issues after burning these hays druid talks to him. then they do all the clues for me with odins sight i can find the clues i did but halewyn is doing ritual dance only and i tried meditate stayed there for hours,restarted killed myself infront of him,burned nearby extra heys nothing stuck here for long time . I know you guys are looking into it but there should be an option of restart mission then i believe bugs like this wont occur.

  • pschmitty99
    1 posts

    this is mine too. This glitch sucks fam. Can we at least get a refund???

    4 posts

    same problem here. unable to interact with halewyn

    4 posts

    ps4 platform. the solution IS NOT "load a saved game", solution is "sell a working game", i have tried everything and it does not work

    I can finish Asgard because end game mission does not work: i get the paint but game does not

    I can finish order mission, all dead except the father, i have 5/6 clues but Hathym does not interact and give me the last clue...

    and minor glitches, bugs and problems located ... i am boring....i am playing and i do not know if it is a test or a bug when i get a mission...

  • BomberXOne
    1 posts

    In the mission "indizi e indovinelli" i can't move on because there is a bug that denies me to talk with Halewyn, but the patch 1.0.4 didn't solve this problem, so i'm stuck. I have almost tried to go to previous backup, but nothing change, even turning down Xbox. Please help me, i can't wait for patch 1.0.5, i love this game.

  • Frizeru1994
    14 posts

    Two weeks without playing because of this bug and ubisoft informs us that it will be solved (for weeks) but we don't have a date, we don't have anything. Congratulations ubisoft for making fun of the fans of the series, too high a price for an unfinished game. Normally we should get our money back. It is the last game I buy from ubisoft after many far cry, watch dogs, r6 and ac bought.

  • Oomoogi
    1 posts

    Still having the same bug issue on this queest. Today its 13th of december and i want to continue my progress... its last area I need to complete 😞

  • gymtan
    6 posts

    @gymtan Update: almost a month after I posted this and I still cant complete this quest and finish the game, what an absolute shambles.

  • TylerEmma2015
    76 posts


    yep if it’s not fixed I’m gunna do a Man save tomorrow then try the mission if it fucks up im not playing this till it’s fixed pretty crap how they can do a festival but they can’t fix the clues and riddles mission most like the the rewards for Yule will be bugged out 😂

  • Frizeru1994
    14 posts

    @soulmasterxx this is not normal...

  • Zioborchia
    10 posts

    I'm playing assassin's creed Valhalla on PS4 and I can't go through the main story mission cause a glitch or a bug in the mission clues and riddles literally don't hollow me to speak with the druid and I'm stack from already 2 weeks now. Ubisoft Just keep replying to me "give us time for fix the glitch" this almost 2 weeks a go.
    i can't reload cuz my only second load save is at the beginning of the game....meaning game locked untill they make a new patch for fix this glitch. Thanks Ubisoft 60 pound and I cannot finish the main story line after I played 136 hours in the game for take platinum.
    I reinstall the game 4 times and updated all the patches available but nothing

  • Zioborchia
    10 posts

    @marsdenx me too but my door is open and I can't speak with the druid for start the mission very nice....almost two weeks like this

Suggested Topics