Continue your odyssey

Welcome to discussion

Quick Suggestions

Hello! These new forums are an open beta and we welcome your feedback in this section.
  • Zuganug
    12 posts

    @mfcristian92 That is epic. Perhaps you can drop off his dead body in the AC Valhalla QA/QC department next?

    The fact that the devs are still asking for saved games is enraging at this point. Having years of experience dealing with SW development as a profession, this tells me the devs are trying to untangle a mess of spaghetti code with a million problems tying to run down the logic flowcharts to find the exxaaacccttt place their code is still going wrong. Instead of just going "Check - did player start mission XXX", "is player located at X,Y,Z (druid house)", and if both = either a) mark quest as completed or b) present option "There is a known issue with this quest - would you like to skip it and mark as complete". BYPASSING the entire horrible flowchart of broken programming logic.

    BTW, not only am I past purchaser of multiple AC games, I am also a Far Cry customer. At least, a former one - given my experience here, I'm now planning on skipping FC6, as there is no way in heck I want to sink my time and money into it just to encounter this nonsense again.

  • guest-0BW9c0O0
    1 posts
    This post is deleted!
  • splashmonkey
    5 posts

    @ubi-woofer I was finally able to raise a support case - 14199322. Save file and dxdiag (though I doubt the latter will help) are attached there.

  • Marodir
    44 posts

    @mfcristian92 Managed to get the Ragnar mission to work, had to just keep walking around the pit, focusing in all sorts of places, finally worked at the top of the high wall behind the wooden platform above the pit (in case others can get help from it). Very disappointed at the ending of that. I thought it might be a longer mission, just an item drop...😓😒

  • RutilantDryad
    1 posts

    I've seen a few other users noted this problem as well, but the Ubisoft staff seem to have missed the posts when talking about known issues.

    At the start of Clues and Riddles, when you first wake up in bed, I cannot interact with the last clue in the house... The pot/cooking pot. I've tried exiting the house and going through the cut scene and re-entering, loading a bunch of earlier saves and retrying, viewing the clues in the house and nothing works. I do not get the prompt to be able to view the clue. I've tried running in circles mashing Y as well.

    (Xbox One)

    It's disappointing to find out how long this issue has been going on for, without a good resolve, and knowing that I have plenty more bugs to get through during this mission alone.

  • Splerr
    1 posts

    I have the same problem !

    Same problem for 4 months, no support, no bug fixes , a shame, shame for UBISOFT.
    To believe that the developer or UBISOFT don't give a [censored].

  • SounderSpace710
    11 posts

    I hope Ubisoft doesn't forget about the people still stuck with the druid dancing. This forum seems to be slowing down and many of us including myself would still like to finally finish the game.... I hope it gets fixed soon 😞

  • Marodir
    44 posts

    @sounderspace710 I think it appears to be slowing down because most of us have had our problems fixed, but there are still several issues with this mission that's marked as under investigation or fixed during later update, so they're still working on it. I suspect they didn't realize how many different problems there were with this mission, and figured solutions to one (main) problem would fix some of the others. When that didn't turn out to be true, they've been working on fixing them individually, but sadly one at a time, so yours hasn't been resolved yet...😓
    @Ubi-Woofer , can you confirm that this is still being worked on?

  • Zuganug
    12 posts

    Its been about 2 weeks without any response. What the F is going on with this, Ubisoft? Is it really your corporate policy to release a game with many game breaking bugs and then just de-prioritize fixing them.

    WHY DO YOU HAVE BANDWIDTH TO RELEASE RIVER RAID WITHOUT FIXING THESE SORTS OF ISSUES?

  • RiverDan
    12 posts

    So. I have now completed all maps 100% achievement. Completed river raid fully. Caught every species of fish. Collected 95% of all available map opal. Still have a dancing fool preventing me from completing the story. Nothing but crickets from Ubisoft on Clues and Riddles mission. For the future I will not be purchasing any Ubi games day one. Zero micro transactions or season passes. This is the worst problem I have had with a game in decades.

Community details

18
Online
113.1k
Users
19.1k
Topics
96.1k
Posts