Welcome to discussions

Quick Suggestions

  • Charmedkitty
    1 posts

    Ok not sure if people have done this or not but I really want to help if I can we were looking for about an hour and thought OMG ITS CRASHED but WE FOUND HER she is in the mission area but she is in the bushes next steps but the pool. We will have a YouTube vid soon with the exact location I hope this helps a lot of people please go to https://youtube.com/channel/UC6r1hhebBtmWIS5zFaOMZXg

    time stamp of 4hrs 5mins in just in case we haven’t done the clip yet GOOD LUCK 🤞

  • HotShotHaz121
    1 posts

    Stuck in the burning the firebrand quest..
    Im at the point were you have ti return to Ljufvina to go to the archives. But when you speak to her. She stands up to take ypu to the archives but then sits back down again. I have done all loot and she will not take me anywhere. Really annoyed as i can't continue. Ive done everything else but no joy here.

  • Milky43211234
    1 posts

    Burning the Friebrand. After the short video when in the ministry the Friebrand character is missing and I can't complete the mission. I have tried restarting from an earlier save point, restarting the PlayStation and fast travelling but nothing has made a difference. 

  • White_Hammer9
    1 posts

    I’m also having a problem on this mission “burning the firebrand” and it seems like nobody else is getting stuck at this glitch. After I kill the needle and Inform ljufvina that he’s dead and we’re going to check the archives for a clue, she gets up she sits right back down. I don’t even get new mission details.

  • XxD1AM0NNDxX
    2 posts

    Hi, I’m having the same issues with firebrand, I get the cut scene but she disappeared after, I loaded an old save, went through top glass window but got nothing at all, no cut scene. I did find her in another area but she was neutral and could not kill her. Needs a patch as cannot move on with the story quest.

  • dooper_2
    6 posts

    I am also having this issue. I completed both quests with the Needle and the Firebrand. When I returned to Ljufvina she gets up to go the archives, but then sits back down. When I go to the Archives I cannot view the documents I need. I went back to a previous point in the game, and now the Firebrand issues are coming up where the cutscene won't kick in and I can't target them. I've fast traveled, meditated. Restarted. Went back to the settlement and recommitted to Jorvik. Nothing has worked.

  • dooper_2
    6 posts

    @white_hammer9 I also got stuck with this glitch and she sat back down. To try to fix the glitch I reset my PS4, fast traveled and it still didn't work. So I went to a previous save point, and now I am getting the other glitch everyone is talking about.

  • officerdanieled
    1 posts

    I'm stuck at the "Examine" part, can someone help?

Suggested Topics

Community Details

105
Online
195.4k
Users
33.0k
Topics
165.1k
Posts