ubisoft discussions

Quick Suggestions

  • Bigshirtlessron
    1 posts

    Walking to Sigurd in the long house also worked for me

  • PluszowyWiewior
    5 posts

    It works again after patch 1.1.0 🙂

  • SueBB8
    4 posts

    After talking to the order leader I wasnt able to fast travel. I restarted the game and everything but nothing worked. Just wait in the village till the damn song is done playing, few mins after the song you should be able to fast travel again.

  • StickyGrenadeMe
    1 posts

    @kimosabe888 this was fantastic. Thanks!!

  • anthonydean2013
    2 posts
    This post is deleted!
  • Hefeydd_
    27 posts

    I found that this happened straight after completing The Order Of The Ancients. I went to see who sent me the message and got my achievement for completing the OOTA which didn't happen the first time around I receive no achievement at all. 1.0.4 broke a lot of AC Valhalla lets hope the next TU fixes a lot of the issues because at the moment this game has more exploits and glitches than any of the AC Franchise.

  • guest-gOnhT2KH
    1 posts

    All I did was ride to Wincestre and find Aelfred's study. After reading the 2 letters I was able to fast travel again. Your conversation with him in Aethelnay hints to this as he give you the key.

  • Font81
    19 posts

    had this problem only once after finishing talking with "the father" on mission poor fellow soldier of christ. It solved by getting on horse to the nearest sync point. The singing finished already.

    2 posts

    fixed after riding my wolf to he river and getting on my boat, fast travel is now available.

  • LePoof.
    3 posts

    I went to aelfreds study then I could fast travel

    1 posts

    I just had the issue, I happened to find the Ubbas camp that Alfred mentioned between Aethelnay and Winstre. This triggers Eivor to think out loud followed by music and then Eivor says "I should see Hytham" this unlocks fast travel again.

  • Master_M.
    1 posts

    @kimosabe888 this worked great once found the spot.
    South of Aethelnay, north of the dock fast travel spot on the Afon River.

    Listen for when Eivor says "This is where Ubba battled"

  • Ubi-Borealis
    Ubisoft Support Staff 6078 posts

    Hello all!

    I apologise for the delayed response. As some of you have already mentioned, fast-travel will be temporarily disabled after speaking to the Poor-Fellow Soldier. I encountered this in my own game, and found that fast-travel was restored after visiting Alfred's study in Wincestre. You can also go east to the edge of the Afon river to find where Ubba battled. You should receive a prompt from Eivor to visit Hytham, and at this point you should be able to fast-travel again.

    Thank you for taking the time to share your feedback about this event. We apologise for any confusion that was caused, and have passed this feedback along to the development team.

    We are also aware that there was a previous issue where players were unable to fast-travel, even if they were not taking part in the "Poor Fellow-Soldier of Christ" quest. This issue was resolved following TU 1.1.1.

    If you are unable to fast travel after Eivor makes this remark, or if you are unable to fast travel during other parts of the game, please don't hesitate to reach out so we can take a closer look. Please include the steps taken prior to being unable to fast-travel (such as last quest completed, the area you are currently in etc), as this will be helpful for further investigation.

    Thanks! 😊

    Official Response
  • Cerethain
    3 posts

    How, some 10 months after release, is this bug STILL in the game? Honestly, at this point, the state of AC Valhalla is just embarrassing. Don't remember the last time I played a game this broken.

  • Ubi-Litten
    Ubisoft Support Staff 179 posts

    Thanks for getting in contact and sorry to hear you appear to be experiencing this issue after the patch. So we can get this looked into further could you ensure your game is fully up to date and them provide a short video clip showing how this occurs in your game.

    The fastest way to do this would be directly through our "Live Chat" service when this is available but you can also get in touch via our social media accounts on Twitter or Facebook if you have access to these services.

    Official Response
  • ARC1136
    1 posts

    I had the same issue on the Xbox series S. To fix it I traveled all the way back to Ravensthorpe and slept in my bed. It seemed to fix my issue.

  • Ubi-Milky
    Ubisoft Support Staff 3613 posts

    Hello arc1136, thank you for sharing that sleeping in your longhouse in Ravensthorpe fixed this bug for you. It appears doing this, taking a NPC to bed, or speaking to a particular, NPC in a particular area, can resolve this fast travel issue for most.

    If anyone else should encounter this bug now, could you please send us a video showing your interaction with the Poor Fellow-Soldier and the fact that you cannot fast travel afterwards for our investigation, thank you.

    Official Response
  • longjohn119
    1294 posts

    I just finished the Poor Fellow Soldier quest and now Fast Travel will no longer work .... What's up with that? Is this intentional and if so why?

  • Ubi-Keo
    Ubisoft Support Staff 4800 posts
    Official Response
  • longjohn119
    1294 posts

    @ubi-keo That worked and I now have finished the game clearing out my Quest Log except for River Raids and Mastery Challenge

Suggested Topics