Continue your odyssey

Welcome to discussion

Quick Suggestions

Hello! These new forums are an open beta and we welcome your feedback in this section.
  • Savvage91
    16 posts

    I tried to reload or quit and log in again but nothing changed... undefined

  • StevenB82
    9 posts

    Plattform : Xbox Series X
    Date: February 11, 2021
    Game: AC Valhalla
    Issue: no item in the daily selection(empty) at Reda

  • The-Foxhounded
    54 posts

    @savvage91 Also broken on PS5

  • TwinDrags
    1 posts

    PC too...
    First players are unable to access the shop at all, then a weekly rotation that didn't happen so it was the same offerings two weeks in a row and now this...

  • StevenB82
    9 posts

    Same on Xbox Series X in Germany

  • Ubi-Wan
    Ubisoft Support Staff 478 posts

    @haggy51 Hello there! Sorry to hear about this. At this time, our team is aware of some items not properly showing up within Reda's shop, and are investigating. Could you let me know if you've run into this opal reward issue previously? Is it possible for you to grab a video of this issue occurring for us to review?

    Official Response
  • JamesLogan491
    50 posts

    Broken for me too.

  • Yesin069
    276 posts

    Ubisoft are pretty fast in fixing Reda related bugs, so don't worry guys. As long as the bug has to do with microtransactions, it is the highest point on their priority list.They are surely already working on it and putting other stuff to the side, lik saying something about the new patch...

    They also didn't seem to be able to make a own category for weekly and daily quest from Reda. Both are just in one category since release. PRetty hard to make another category in a menu right...

  • The-Foxhounded
    54 posts

    @yesin069 No they aren't... they let him repeat an entire week of weekly and daily items and did nothing about it.

  • Yesin069
    276 posts

    @the-foxhounded

    I know, but at least he always has items. They just need to do some server side change to let the daily selection reappear.

    They clearly are never touching Reda's algorithm. This is hammered in stone, so when two weeks have the same stuff, we need to take it. The only thing they change is adding new microtransaction gear into Reda's selection (but just weeks after the sets were released in the first place, to enforce people to buy it first). This will also decrease chances of gettting a whole set because all the needles naval and tatoo stuff is also added.

  • LA_Frankie
    40 posts

    Not only is Reda not offering a daily selection,
    Reda only offered 1 daily contract today YET AGAIN. This has been ongoing for TWO MONTHS! Every other day, one contract is missing.
    Yet this has not appeared in Known Issues or had an official response on the forums.

    Totally unacceptable. This is probably the last time I buy AC at release. Honestly, what a S*** show.

  • The-Foxhounded
    54 posts

    @the-foxhounded

    Well the item is finally up in the game. It's the Ursine Guard shield

    Funny how they let it go on for a week before but fixed this without a patch in live time.

  • shyam3010
    84 posts

    @la_frankie same. If I buy any ubisoft title in the future, it’ll be directly from a friend. Not letting these crooks see my money ever again.

  • Ubi-Woofer
    Ubisoft Support Staff 576 posts

    Hey everyone,

    Thanks for reporting these issues with Reda's shop missing items in his daily (and/or weekly) rotation. We're aware that items are missing today (11th February 2021) and this is being looked into, however I am unsure how quickly this issue may be addressed. I'll update the thread as soon as I am able to do so with further information.

    I'll pass the link to this thread onto the developers for them to consult. Thanks! 🙂

    Official Response
  • Esox_hunter
    2 posts

    @cm_puma i have the same problem

  • Esox_hunter
    2 posts

    I have an issue where I can collect contracts in Reda's shop but cannot go into weekly or daily item purchases. I played 115 hours and deleted the game and re-set everything because of this issue, but doing this hasn't solved the problem. Also, Opals didn't reset. Anyone else had this problem on PS4 or know how to solve this issue ?

Community details

16
Online
113.1k
Users
19.1k
Topics
96.1k
Posts