Welcome to discussions

Quick Suggestions

  • d33jayfm
    2 posts

    If you notice the skill tree has 6 branches, but only 3 are being used. I have power of 400 with 3 skill points. I was finishing up the the side missions and the other 3 branches opened up and auto assigned my 3 skill points. I was at 403 power for the rest of my session. But when I played again the following day my power was back to 400, 3 skill points and the other 3 branches were closed again.
    This has happened 3 times to me and I'm not sure how to open the other branches...

  • tritens
    2 posts

    Is there an update on the excessive skill points because on this play through i had three new perks appear when I'm already on the mastery points, I then got three skill point but now those three skills have disappeared and I'm stuck with three useless skill points, would love it if I could somehow convert them to mastery points?

  • tritens
    2 posts

    @d33jayfm yeah same thing happened to me it is just annoying one minute they are there the next they aren't.

  • SpirantCrayon22
    328 posts

    I just found this problem and might have something useful. Xbox One, version 1.1.1, with the +50% xp/silver starter pack thing.

    I was at power 400 and 10 mastery on each of the skill trees. I had a manual save at the fast travel dock just inside Cambridgeshire, north-north-west of Halstead Outpost in Essex. From the save I "did" that outpost and then went on to the World Event "Mother" in Essex; when I did that the XP gain bumped me up a "level" and I got 2 Skill Points that I couldn't use. Removing the skills and auto-assigning did nothing.

    I saved the game into slot 2, went back to the manual save in slot 1 and then did the two activities but the other way around. "Mother" took me to close to a level-up point. A couple of kills into Halstead Outpost and I got to the level-up point and then I got a Mastery Point rather than 2 Skill Points.

  • h4rdythegrey
    3 posts
    This post is deleted!
  • h4rdythegrey
    3 posts

    For me it seems to be worse, i got to 398 skills points finished a mission and it gave me 4 points, so i now have 2 skills points i cant use, however i carried on and did another mission, at the end of the mission it looked as if it was going to give me 2 more then didnt the xp bar seems stuck 3 quarters of the way up and it isnt showing mastery points when i go to the skills section, im just going round with 2 unused skills at the side, id previously tried to reload saves so it didnt give me 4 points when i was just on 398, i went back about an hours play and tried to chose different dialogue options but that didnt work either, so now im stuck with not being able to get mastery points and im on 400 skill points with 2 left spare, any help would be great.undefined

  • uKMrBlondeuK
    3 posts

    When I got to 400, 3 new skills appeared (not the mastery ones). I got them but they later disappeared and I was left with 3 unused points for a long time. One day those 3 skills reappeared though and stayed until I had finished the game. I've just loaded up my game to take a screenshot but they have now disappeared again, weird.

  • ReticentRobot
    1 posts

    I just got this same bug playing on Series X version.

  • SquareEnixGamer
    1 posts

    I just leveled up today, and I got a split situation - 1 mastery point and 1 skill point, which I can't use (all skills unlocked with power level 408).

  • auridulis
    39 posts

    @squareenixgamer You are missing one skill. The current max power level should be 409. 🙂

Suggested Topics

Community Details

93
Online
141.8k
Users
25.0k
Topics
129.8k
Posts